Ford Truck Enthusiasts Forums - Search Results

Notices
Search: Posts Made By: '02 Excursion Guy
Showing results 1 to 10 of 10
Search took 0.06 seconds.
08-19-2018, 09:47 PM
Replies: 3
Views: 299
Posted By '02 Excursion Guy

Sudden loss of Power on my '02 Excursion

I have an '02 Ex with a 7.3L PSD and 250,000 miles; I will provide all info I know. Yesterday driving home at 80 MPH, everything was fine and then I felt a slight shudder or hiccup. Then a loss of...
10-14-2017, 11:29 PM
Replies: 2
Views: 262
Posted By '02 Excursion Guy

Digital Climate Controls: All hot, or all cold, no in between

I have an '02 Excursion with a 7.3L PSD. Whether I use the AUTO feature on my climate control or not, I have to adjust the temperature to the highest number for heat and to the lowest number for...
07-25-2017, 10:07 PM
Replies: 3
Views: 405
Posted By '02 Excursion Guy

No I didn't but I will check it out. I don't have...

No I didn't but I will check it out. I don't have any leaks, wouldn't it be leaking from those areas? I don't have any wet carpet and I'm constantly going in and out of the storage compartment where...
07-25-2017, 09:36 PM
Replies: 3
Views: 405
Posted By '02 Excursion Guy

Coolant Question

I have a '02 Excursion, 7.3L PSD with 238,000 miles. I have to constantly add water to the coolant reservoir but no leaks what so ever and no oil contamination. Any ideas why I am losing coolant and...
05-27-2017, 08:25 AM
Replies: 20
Views: 952
Posted By '02 Excursion Guy

WOW, you guys are amazing with the info!! I...

WOW, you guys are amazing with the info!! I thoroughly greased the slip joint spline and so far, no noise; fingers crossed. Nothing but dried blue spatter on it but the splines were in good shape. I...
05-22-2017, 11:02 PM
Replies: 20
Views: 952
Posted By '02 Excursion Guy

Door sticker says Axle = 31 ??? No, I did not...

Door sticker says Axle = 31 ??? No, I did not use any additives in the diff, just AMS oil
05-22-2017, 10:33 PM
Replies: 6
Views: 860
Posted By '02 Excursion Guy

Thanks much! Sounds like everything is working...

Thanks much! Sounds like everything is working OK, just got in over my head in mud that day!
05-22-2017, 10:21 PM
Replies: 6
Views: 860
Posted By '02 Excursion Guy

I do have a stock front end. What you are saying...

I do have a stock front end. What you are saying about an "Open" rear end makes sense. Although when it was on jack stands, I did not spin them, then spun on their own when my wife started the truck,...
05-22-2017, 10:15 PM
Replies: 20
Views: 952
Posted By '02 Excursion Guy

Strange thump in the rear end

I have a '02 Excursion with a 7.3L PSD, 238,000 miles. When I drive and say stop at a stop sign or light, when I transfer from the brake pedal to the accelorator and initially begin moving, I hear a...
05-22-2017, 10:05 PM
Replies: 6
Views: 860
Posted By '02 Excursion Guy

4WD question

My '02 Excursion 7.3L PSD recently got stuck in the mud and my friends who were present, were adamant that my 4WD was working; saying the front tires weren't turning or slinging mud. I noticed in 4...
Showing results 1 to 10 of 10


 
Forum Jump

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.