Ford Truck Enthusiasts Forums - Search Results

Notices
 
Search: Posts Made By: 1968stepside
Showing results 1 to 15 of 311
Search took 0.88 seconds.
04-06-2006, 03:31 AM
Replies: 3
Views: 6,334
Posted By 1968stepside

The insert is installed. I have to say it went...

The insert is installed. I have to say it went much smoother than expected. I have not finished putting everything back together, so I can't say how it runs.

My biggest worry was getting all of...
04-01-2006, 07:12 PM
Replies: 3
Views: 6,334
Posted By 1968stepside

Sorry I didn't post up, but there were no replies...

Sorry I didn't post up, but there were no replies up until now.

I have already received my time-sert kit #5553. That is the "over the fender repair" kit. Instead of pulling the entire top end...
03-27-2006, 11:04 AM
Replies: 9
Views: 1,060
Posted By 1968stepside

Yeah, I plan on taking a pic everytime I remove a...

Yeah, I plan on taking a pic everytime I remove a part. One reason for putting it back together, and two to help others out if they have to do this. It may take me a week or so to get my garage in...
03-27-2006, 12:53 AM
Replies: 3
Views: 6,334
Posted By 1968stepside

5.4 Head Removal/Time-Cert Install

So, who has done this? I plan on removing both heads and installing time-certs for all 8 spark plugs. I've spent a lot of time researching and emailing the people at time-cert. I want to do this...
03-27-2006, 12:52 AM
Replies: 9
Views: 1,060
Posted By 1968stepside

I've been researching the best fix for the money...

I've been researching the best fix for the money on this. I recently blew the #8 completely out of my 99 F150 with the 5.4 engine. I am going to remove both heads and install time-certs in all...
Replies: 3
Views: 278
Posted By 1968stepside

I did change the vacuum modulator today. It...

I did change the vacuum modulator today. It seems to be doing better, but does still slip. I plan on trying the fix from stuart1.
Replies: 3
Views: 278
Posted By 1968stepside

Thanks, I'll give it a try. I have gotten rid of...

Thanks, I'll give it a try. I have gotten rid of the rod and installed the Lokar cable kit and braket. It kicks down great. I used this cable since I couldn't get the rod to not bind on the new...
Replies: 3
Views: 278
Posted By 1968stepside

Question Transmission goes bad without a kickdown tube?

That's the explanation I was given today as to why my trans is crapping the bed, supposedly. I maybe put 20-30 miles on it without the kickdown tube. BTW, this is a late 70's Ford C4 3 speed auto. ...
01-28-2006, 01:37 AM
Replies: 21
Views: 1,006
Posted By 1968stepside

It would be more than a foot

It would be more than a foot
01-25-2006, 11:41 PM
Replies: 21
Views: 1,006
Posted By 1968stepside

I followed this article as a reference.... ...

I followed this article as a reference.... http://www.classictrucksweb.com/tech/0404cl_tank/

I'm almost done installing mine. I'm using a tank from a 69 Mustang. I've seen many of these tanks...
12-04-2005, 08:59 PM
Replies: 9
Views: 590
Posted By 1968stepside

Problem solved!!!

After several hours of wrestling with the overall job, and a little cussing, the headers are installed!!! The noise I had before is gone. I'm guessing it was from a broken pipe flange bolt on the...
11-28-2005, 09:49 PM
Replies: 9
Views: 590
Posted By 1968stepside

Sorry it has taken so long to get back with...

Sorry it has taken so long to get back with this....

I removed the EGR valve and tube. I could not find any obvious cracks, holes, blockages, ect. Someone told me that it could be an exhaust...
10-14-2005, 07:22 PM
Replies: 9
Views: 590
Posted By 1968stepside

I picked up a stethiscope today and spent a...

I picked up a stethiscope today and spent a couple of hours. Still could not pinpoint it. So, I took it to a local shop. They had a 98 in there with the same noise. On that one it was the EGR...
10-12-2005, 09:01 PM
Replies: 9
Views: 590
Posted By 1968stepside

Ok, I spent a couple hours with it tonight. I...

Ok, I spent a couple hours with it tonight. I don't see any carbon buildup. I pulled the throttle body cover off, left the engine on and had someone put it in drive with the foot on the pedal. If...
10-12-2005, 10:02 AM
Replies: 9
Views: 590
Posted By 1968stepside

5.4 exhaust manifold leak?

I have read many threads on this after doing a search. I don't know if I have the same problem or not. There are no engine codes being thrown, already checked that. Can't find a vacuum leak...
Showing results 1 to 15 of 311
 


 
Forum Jump

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.