Ford Truck Enthusiasts Forums - Search Results

Notices
 
Search: Posts Made By: joshofalltrades
Showing results 1 to 15 of 498
Search took 0.24 seconds.
04-22-2018, 01:35 AM
Replies: 5
Views: 2,998
Posted By joshofalltrades

I took a piece of flat bar, probably 1/4 x 1...

I took a piece of flat bar, probably 1/4 x 1 inch, and drilled holes in it, one to go over the pivot shaft on top, a second hole to match the pin where the pushrod originally attached, and a third...
04-07-2017, 01:56 AM
Replies: 7
Views: 775
Posted By joshofalltrades

I should have thought to ask on here before...

I should have thought to ask on here before ordering one, too late now. But I will suggest offering yours on ebay or whatever, assuming you don't plan to need it. I can't be the only one who broke...
04-06-2017, 02:47 AM
Replies: 7
Views: 775
Posted By joshofalltrades

6.9 flex plate write up

hey guys, its been awhile.
i apologize that all my pics are showing up as links rather than pics, but they're safe to click on. i moved them all to the end so its cleaner to read.

so i'm working...
10-08-2016, 09:40 PM
Replies: 10
Views: 306
Posted By joshofalltrades

mine once had a problem with the yellow wires...

mine once had a problem with the yellow wires that supply power to the gp relay, bypassed that with a piece of 4ga direct from the battery. if you see any sign of melting where those wires go through...
10-08-2016, 09:32 PM
Replies: 6
Views: 313
Posted By joshofalltrades

i've had several failed vacuum pumps on mine over...

i've had several failed vacuum pumps on mine over the years. you either have a major leak or a bad pump. they're really simple to replace once you have the right pulley tool
10-07-2016, 02:57 PM
Replies: 15
Views: 596
Posted By joshofalltrades

The light in the dash is the only light I'm...

The light in the dash is the only light I'm focused on here
10-05-2016, 11:40 PM
Replies: 15
Views: 596
Posted By joshofalltrades

I'm back to feeling confused on this one. Tonight...

I'm back to feeling confused on this one. Tonight I went to start it after work, held the button down for ten seconds, light stayed on 4 seconds, went to start and it was like my plugs weren't...
10-05-2016, 02:16 PM
Replies: 15
Views: 596
Posted By joshofalltrades

I already know that for the plugs themselves,...

I already know that for the plugs themselves, it's Motorcraft only, but it's good to know that about the controller as well. Last night I wired up a pushbutton to the relay, but left the controller...
10-02-2016, 11:58 PM
Replies: 15
Views: 596
Posted By joshofalltrades

Ok, I finally got some answers here. I believe...

Ok, I finally got some answers here. I believe The controller itself has failed.
I tested the relay and found a voltage drop of only 0.1v across it, so thats good. I also tested the supply wire to...
09-30-2016, 02:52 PM
Replies: 15
Views: 596
Posted By joshofalltrades

Thanks for all the input guys! I'll be testing...

Thanks for all the input guys! I'll be testing the relay this weekend and see where that leaves me.
I'll post back with an update in a couple days.

And to clarify from the original post, it's...
09-28-2016, 03:08 PM
Replies: 15
Views: 596
Posted By joshofalltrades

Glow plug issues that don't make sense

On my 87 e350, I'm having a heck of a time figuring out why my glow plugs aren't working right. On a cold start, I get about 4 seconds of the wts light, and usually have to run the plugs twice to get...
05-02-2015, 01:03 AM
Replies: 90
Views: 5,090
Posted By joshofalltrades

Thanks for all the info on the studs! I'll...

Thanks for all the info on the studs! I'll definitely torque them a bit harder on both sides, even though I'm only actually repairing the one side. I'll be putting it in place in the morning and...
05-01-2015, 12:42 AM
Replies: 90
Views: 5,090
Posted By joshofalltrades

The first time around I torqued the heads to 80...

The first time around I torqued the heads to 80 ft-lbs as recommended my arp and the service manual for the 6.9 with its 7/16 studs. Some of the guys on the thread were thinking of their 7.3s with...
04-29-2015, 10:46 PM
Replies: 90
Views: 5,090
Posted By joshofalltrades

well boys, sorry to resurrect my ancient thread...

well boys, sorry to resurrect my ancient thread after not being around in awhile, but i just blew it again.
the rear of the left head gasket blew out pretty bad on saturday, gasket was visibly torn...
12-21-2014, 12:24 AM
Replies: 13
Views: 2,003
Posted By joshofalltrades

Well I took a look at it today and found all 8...

Well I took a look at it today and found all 8 glow plugs were Motorcraft and are in good shape. It fired up easy enough and had a noticeable drop for each injector line I loosened (one at a time)...
Showing results 1 to 15 of 498
 


 
Forum Jump

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.