Ford Truck Enthusiasts Forums - Search Results



Showing results 1 to 10 of 10
Search took 0.14 seconds.
Search: Posts Made By: silvman36
Forum: 1997-2006 Expedition & Navigator 01-16-2014, 03:10 PM
Replies: 15
Views: 1,682
Posted By silvman36
OK talked to a local mechanic and he told my to...

OK talked to a local mechanic and he told my to turn on the key and leave it on till the theft light stopped flashing. So I did it took about 15 to 20 minutes then it stopped flashing and started up....
Forum: 1997-2006 Expedition & Navigator 01-16-2014, 12:05 AM
Replies: 15
Views: 1,682
Posted By silvman36
No only have one key. Been working fine for over...

No only have one key. Been working fine for over a year since I used the epoxy and have not had any problems till now.
Forum: 1997-2006 Expedition & Navigator 01-15-2014, 05:51 PM
Replies: 15
Views: 1,682
Posted By silvman36
OK noe have a new problem. Went to store this...

OK noe have a new problem. Went to store this morning and had no problems. When out about 30 min. Later to work on brake lights and now the theft light is flashing and can't start up my truck any...
Forum: Modular V8 (4.6L, 5.4L) 01-15-2014, 05:47 PM
Replies: 256
Views: 114,159
Posted By silvman36
I have a 1998 expedition Eddie Bauer and it has...

I have a 1998 expedition Eddie Bauer and it has 265,000 miles on it and just now replacing parts. Everything I have replaced has been original parts.
Forum: Modular V8 (4.6L, 5.4L) 01-15-2014, 05:43 PM
Replies: 3
Views: 664
Posted By silvman36
Having same problem with my 1998 expedition and...

Having same problem with my 1998 expedition and have found out that the front Axel is not engaging. It is set up on a vacuum and it is not pulling the vacuum to lock it in. Try putting it in 4 wheel...
Forum: 1997-2006 Expedition & Navigator 01-04-2014, 12:24 AM
Replies: 15
Views: 1,682
Posted By silvman36
Ok sorry you all about taking so long getting...

Ok sorry you all about taking so long getting back but I got my blinkers fixed. I evidently blew the fuse for them wile working on them. And for the key switch it did work and has been working fine...
Forum: 1997-2006 Expedition & Navigator 03-06-2013, 02:20 PM
Replies: 15
Views: 1,682
Posted By silvman36
ok still trying to get this blinkers fixed I have...

ok still trying to get this blinkers fixed I have taken the multiswitch apart and cleaned every thing up in side and found the wiring for the blinker pigtail on the switch. still have no blinkers or...
Forum: 1997-2006 Expedition & Navigator 01-25-2013, 03:34 PM
Replies: 15
Views: 1,682
Posted By silvman36
I found that the ring around the key had three...

I found that the ring around the key had three wires that were pulled out so I soldered them back and put new silicone on them. hopping this works.
Forum: 1997-2006 Expedition & Navigator 01-24-2013, 07:05 PM
Replies: 15
Views: 1,682
Posted By silvman36
tried the socket and that was not it. tore apart...

tried the socket and that was not it. tore apart the multiswitch today and cleaned it all up and took a wire brush with my dremmel tool and that did not work eather. now my theft light is flashing...
Forum: 1997-2006 Expedition & Navigator 01-08-2012, 11:18 AM
Replies: 15
Views: 1,682
Posted By silvman36
1998 expidition Blinkers

I have a 1998 Expidition Eddie Bauer edition and my front drivers side blinker in the front does not blink. Put new bulb in and still not working. Does any body have any wiring diagrams or any...
Showing results 1 to 10 of 10

 
Forum Jump

All times are GMT -5. The time now is 08:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.