Ford Truck Enthusiasts Forums - Search Results



Showing results 1 to 14 of 14
Search took 0.16 seconds.
Search: Posts Made By: Crf45or1991
Forum: 1999 to 2016 Super Duty 03-12-2014, 01:16 PM
Replies: 11
Views: 793
Posted By Crf45or1991
This happened to me, I replaced my plugs and the...

This happened to me, I replaced my plugs and the cat, and it hasn't had any trouble since
Forum: 1999 to 2016 Super Duty 03-08-2014, 04:33 PM
Replies: 7
Views: 571
Posted By Crf45or1991
Yes the light went on after the unit was...

Yes the light went on after the unit was installed. I didn't splice any stock wires I bought an adapter and connected that to the new head unit. I'm going to take it all apart tomorrow and put the...
Forum: 1999 to 2016 Super Duty 03-07-2014, 08:17 PM
Replies: 7
Views: 571
Posted By Crf45or1991
It's a 2005 ford F-250 super duty, 5.4L the code...

It's a 2005 ford F-250 super duty, 5.4L the code is coming up as vehicle speed sensor. Iv replaced the VSS and the code doesn't go away. Sorry for the lack of info.
Forum: 1999 to 2016 Super Duty 03-07-2014, 06:15 PM
Replies: 7
Views: 571
Posted By Crf45or1991
Possibility of a radio install screwing with the vehicle speed sensor?

A few years back I installed a head unit and I think it may have triggered a check engine light for my VSS, and turned off the spedo and odo. It was so long ago that I don't recall if it happened...
Forum: 1999 to 2016 Super Duty 03-07-2014, 09:46 AM
Replies: 0
Views: 330
Posted By Crf45or1991
New head unit Vs. VSS

A few years back I installed a head unit and I think it may have triggered a check engine light for my VSS, and turned off the spedo and odo. It was so long ago that I don't recall if it happened...
Forum: 1999 to 2016 Super Duty 10-21-2011, 08:17 PM
Replies: 1
Views: 397
Posted By Crf45or1991
Speedometer related to head unit?

A little while back I bought a head unit for my truck I bought an adapter piece so I didn't have to cuz any stock wires. After that I think is when my speedometer,odometer,cruise control failed. I...
Forum: 1999 to 2016 Super Duty 10-06-2011, 09:14 AM
Replies: 4
Views: 3,919
Posted By Crf45or1991
Thanks guys the truck is a 2005 75k on it. I...

Thanks guys the truck is a 2005 75k on it. I bought a small magnet but the piece that fell in doesn't seem to be magnetic (I checked on a good plug) so I'm Going to try the vacume idea. And any idea...
Forum: 1999 to 2016 Super Duty 10-05-2011, 06:11 PM
Replies: 4
Views: 3,919
Posted By Crf45or1991
5.4l triton spark plug removal

Iv gotten to the point were 4 out of 8 spark plugs broke and iv gotten 3 out of 4 of the broken pieces out of the engine with the lisle tool. I have two questions

if the needle looking part. (...
Forum: 2004 - 2008 F150 10-05-2011, 09:10 AM
Replies: 35
Views: 18,124
Posted By Crf45or1991
4 out of 8 broke on my truck I'm going to give...

4 out of 8 broke on my truck I'm going to give the tool a shot today!!
Forum: 2004 - 2008 F150 10-05-2011, 08:45 AM
Replies: 12
Views: 3,862
Posted By Crf45or1991
On my truck there was a bad gasket between the...

On my truck there was a bad gasket between the throttle body and intake man
Forum: 2004 - 2008 F150 10-05-2011, 08:39 AM
Replies: 12
Views: 44,606
Posted By Crf45or1991
I just replaced my cat for 700 from my mechanic I...

I just replaced my cat for 700 from my mechanic I bought an eastern cat for 500 free shipping it's not that hard of a job so labor shouldn't be to much
Forum: Explorer, Sport Trac, Mountaineer & Aviator 10-03-2011, 01:19 PM
Replies: 1
Views: 390
Posted By Crf45or1991
2003 explorer bearings

I have a 2003 explorer sport 4wd. Im pretty sure the bearing are shot I was wonderig if anyone knows if I have to replace the whole hub assembly or if I can put new bearings in.

Thanks
Forum: 1999 to 2016 Super Duty 10-01-2011, 10:00 AM
Replies: 18
Views: 8,625
Posted By Crf45or1991
My truck did that and my catylitic converters...

My truck did that and my catylitic converters were shot
Forum: 1999 to 2016 Super Duty 10-01-2011, 09:56 AM
Replies: 8
Views: 5,779
Posted By Crf45or1991
My 5.4 was doing the same thing at first it was...

My 5.4 was doing the same thing at first it was misfiring when I really punched the gas. Eventually all that misfiring killed my cat and that's when it started sputtering much more around 3000 rpm....
Showing results 1 to 14 of 14

 
Forum Jump

All times are GMT -5. The time now is 09:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.