Ford Truck Enthusiasts Forums

Ford Truck Enthusiasts Forums (https://www.ford-trucks.com/forums/index.php)
-   2007 - 2014 Expedition & Navigator (https://www.ford-trucks.com/forums/forum174/)
-   -   2010 Expedition (https://www.ford-trucks.com/forums/1036199-2010-expedition.html)

Sportsmom 02-02-2011 11:51 PM

2010 Expedition
 
When I'm already in reverse backing up (parallel parking) I hear a clunk. You can hear it through out the car, but you can feel and hear it best when your in the 3rd row right side (passenger side). Ford has replaces some stuff in the rear suspension, checked the brakes and stuff with the brakes, replaced some parts in the drive shaft, also not the differential. The engineers are involved and seem to be stumped by this. Please I hope some out there can help. Endless hours spent on this using microphones and frankly wasting my time since they can never duplicate it unless I do it. I am about to throw the towel in and lemon law this. :(

I'm sorry if this is a duplicate of someone else's issue, but its late and I am meeting with Ford in the morning. I spend more time with them then I do with my family...UGH :)

chuck s 02-03-2011 06:35 PM

Are you in 4x4 ?

-- Chuck

Sportsmom 02-03-2011 10:49 PM

No, its a 2 wheel Eddie Bauer Edition. They did something with some bolts and replaced the throttle since the car was lagging, its didnt pass their tests. Still making the noise. The engineers have no clue, maybe time to do a buy back?


All times are GMT -5. The time now is 08:33 AM.