Ford Truck Enthusiasts Forums - View Profile: NAVTV_BM

Go Back  Ford Truck Enthusiasts Forums > Members
Reload this Page >

NAVTV_BM's Profile

Notices
NAVTV_BM is starting off with a positive reputation.

NAVTV_BM NAVTV_BM is offline

Freshman User

Visitor Messages

Showing Visitor Messages 1 to 8 of 8
  1. NAVTV_BM
    01-28-2019 09:28 AM - permalink
    Gretsloh,

    The forum is not allowing me to send you direct private messages. Email me at [email protected] and I'll take care of you.
  2. Gretsloh
    01-28-2019 08:34 AM - permalink
    Hi, would like to order the COD-F50 what is the discount code. Thank You
  3. NAVTV_BM
    01-17-2019 04:48 PM - permalink
    Hi Gretsloh,

    There is no discount at this time, no. There was one back in NOV/DEC of 2018 but it ended on DEC 31.


    EDIT: I apologize Gretsloh, things have changed. We are going to offer another discount soon so stay tuned!
  4. Gretsloh
    01-17-2019 08:46 AM - permalink
    Hi, is there still a discount for forum members? Thank You
  5. NAVTV_BM
    12-18-2018 01:45 PM - permalink
    Hey bud, Sorry, I haven't forgotten about you. At the moment we have just enough of these harnesses to fulfill orders, and are making them as the orders come in. Does the connector not stay put in the monitor?

    I'll see if I can grab one from a return from a different kit.
  6. sdetweil
    12-14-2018 10:13 AM - permalink
    did u have a chance to look for that apim large connector lock lever?
  7. sdetweil
    12-07-2018 08:37 PM - permalink
    correct, off your connector, not oem.

    i have opened these 100's of times.. no idea what happened here.. just need to fix it!
  8. sdetweil
    12-07-2018 06:47 PM - permalink
    i had a problem I wanted to talk about. when I installed firt time, I didn't get the camera module harness connected well.

    one the second pass, I wanted to disconnect the apim, so it wouldn't hang on the t cable.. but the swing lock connector wouldn't budge (holding down the lock of course)
    and I broke the lever off the connector itself.. one side still rotate locked in

    is there a way to get that swing arm and repair the connector, or do I need another harness

    pic at https://www.dropbox.com/s/h7qhbrlerf...ector.jpg?dl=0

About Me

  • About NAVTV_BM
    2 Letter State/Province (use "--" for outside USA/
    FL
    Country of Residence
    US
    Make
    Ford
    Model
    F-250
    Year
    2018
    Current Mileage
    Rather not say
    Miles per year
    Rather not say
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-13-2019 09:29 AM
  • Join Date: 12-01-2018
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.