Ford Truck Enthusiasts Forums - View Profile: ladyjae

Notices
ladyjae is starting off with a positive reputation.

ladyjae ladyjae is offline

New User

About Me

  • About ladyjae
    2 Letter State/Province (use "--" for outside USA/
    ok
    Country of Residence
    US
    Make
    Ford
    Model
    Explorer
    Year
    2005
    Current Mileage
    50,000 - 74,999
    Miles per year
    Rather not say
    Gender
    Male

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 06-29-2018 02:14 PM
  • Join Date: 06-01-2018
  • Referrals: 0

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. 06-01-2018 12:21 AM - permalink
    I have a 2005 Explorer with under 65K miles-Last summer, it started going into engine failsafe mode & quitting when I ran the AC-Summers in OK are miserable so I need cooling-I took it to 3 different places who all ran code scan but couldn't locate problem-This summer, it is already over 100 degrees and even though I did not turn the AC on, my truck went FS & quit-This happens while I am driving but it will restart after a few minutes-I've read many posts abt this same issue, but there seems to not be a fix-Any help would be greatly appreciated-I love this truck, and with low miles, I expect to keep driving it for many years if I can use AC-TY

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.