Ford Truck Enthusiasts Forums - View Profile: Tugly

Go Back  Ford Truck Enthusiasts Forums > Members
Reload this Page > Tugly's Profile
Notices
Tugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputationTugly has a superb reputation

Tugly Tugly is offline

Post Fiend

Visitor Messages

Showing Visitor Messages 1 to 10 of 113
  1. mrjustice1324
    04-17-2018 05:32 PM - permalink
    Hey Tugly, I'm having some trouble with some gauges on Torque and have tried everything to figure it out and I'm lost. Think you could help me out?
  2. BBslider001
    04-15-2018 07:25 AM - permalink
    Ah, ok. I didn't realize they disconnected like that . I was picturing having to splice into the current fuel line. When I got under there, I saw the line was not rubber like the 95-97 models, which I was used to. I'll do some reading. Thanks.
  3. BBslider001
    04-13-2018 01:45 PM - permalink
    Hey Rich, question. How did you cut the fuel line for the Racor filter? Did you have to flare the ends? I started to get after this project yesterday thinking I was going to be dealing with a rubber line, but as you know,it's not. Thanks!
  4. Luke10
    03-16-2018 05:14 PM - permalink
    hows going tugly so I have an 2000 f-350 7.3 and It was running and driving fine and then I changed my hpop because seal was bad at back while I was there I replaced my ipr sensor(2) actually first I went to advance and got one then was told I needed to go to ford and get oem one so I did still no help.. when I did get it to run on ether though my throttle had no response what so ever after I got it to idel.. so what could be the problem I also unhooked one hpop lines to make sure was pushing oil through which it was.. thanks in advance..
  5. lee00
    12-03-2017 03:25 PM - permalink
    Thank you.
  6. lee00
    11-08-2017 07:33 PM - permalink
    Question on your two EGT gauges...what difference in temp do you typically see? Mine are different by 20-40 degrees.
  7. Wesley Green
    10-15-2017 11:55 PM - permalink
    Ok. I was debating using blue 243 but it's break free hold is 40 ft# which is almost 3 times the torqued value of the hold down bolts and didn't want to shear the bolt upon future dissasembly. I think I'll try 222 on the bottom half of the hold down bolts which has a hold of 50 in#, and one or two threads of lightly applied 243 halfway up. Thanks tugly
  8. Wesley Green
    10-15-2017 02:16 AM - permalink
    So just curious, when you hot torque injectors you mentioned that you use a loctite, was it 222?
  9. Tugly
    05-12-2017 11:13 AM - permalink
    SrFox, I have seen reports that the TFT reads lower than the laser thermometer on some trucks, where the formula is dead-on with my truck. You can try the formula ((A*256)+B)/8.9 to see if that matches your laser thermometer more closely.
  10. SrFox
    05-11-2017 09:33 AM - permalink
    My email is [email protected] and one of my websites are Foxes Travel - Our Travel Photo Diaries, Road Grades, Clearances and information as we travel - US, Canada and Mexico and romamexico.com if you would like to see who I am. Thanks in advance for your time.
    Fox

About Me

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Today 08:04 AM
  • Join Date: 01-19-2011
  • Referrals: 0

Friends

Showing Friends 1 to 10 of 40

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.