Ford Truck Enthusiasts Forums - View Profile: #1FordTruckMan

Notices
#1FordTruckMan is starting off with a positive reputation.

#1FordTruckMan #1FordTruckMan is offline

New User

About Me

  • About #1FordTruckMan
    2 Letter State/Province (use "--" for outside USA/
    CA
    Country of Residence
    US
    Make
    Ford
    Model
    F-250
    Year
    1999
    Current Mileage
    125,000 - 149,999
    Miles per year
    10,000 - 14,999

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-30-2009 11:29 PM
  • Join Date: 04-05-2009
  • Referrals: 0

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. 03-01-2014 09:54 AM - permalink
    Hey I'm working on a 99 f250.yesterday the wires coming out of my shifter for the o.d. shorted out leaving me with no fuel gauge no speedo no amp .it knocked out every thing in my cluster except tach and oil pressure gauge.I checked all fuses and can find none bad and the od wires stil have power.can you tell me wher I might go from here to figure out why my cluster is not working? 425 492 0369.
  2. 12-30-2009 01:00 AM - permalink
    hey bud i am new to this site and am wondering how to post a message, need a little help. If you dont mind would you kindly email me the way to post a message to everybody. I am having a lot of trouble getting my 7.3 to start and run. I can get it to run on little sips of diesel but it will not run on diesel. I have changed the fuel filters and fuel pump and camshaft positioning sensor. Dont have an extra 1500.00 to take it to ford right now. Thanks James
  3. pjvoegerl
    04-07-2009 01:47 AM - permalink
    Hey I am new here, how do I start a new thread?

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.