Ford Truck Enthusiasts Forums - View Profile: RV_Tech

Notices
RV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputationRV_Tech has a superb reputation

RV_Tech RV_Tech is online now

Post Fiend

About Me

  • About RV_Tech
    2 Letter State/Province (use "--" for outside USA/
    tn
    Country of Residence
    US
    Make
    Ford
    Model
    F-350
    Year
    2002
    Current Mileage
    25,000 - 49,999
    Miles per year
    10,000 - 14,999
  • Signature
    RVDA/RVIA Master Certified RV Technician, back at it after briefly retiring
    You think you're confused?
    2012 F350 6.2 SRW Super Cab, 8-foot bed, box stock, bed liner, bed cover, Fab Four custom front and rear bumpers
    08 Copper Canyon fifth wheel with solar panels and inverter
    2019 Northstar Laredo SC

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 05:50 PM
  • Join Date: 01-01-2010
  • Referrals: 0

Friends

Showing Friends 1 to 6 of 6

Visitor Messages

Showing Visitor Messages 21 to 28 of 28
  1. Y2KW57
    07-17-2012 01:35 AM - permalink
    A belated Thanks for the reps!
  2. cmpd1781
    07-15-2012 07:40 PM - permalink
    No need to unsubscribe from the 'tipping point' thread, brother (and thanks for the reps). Jared showed up, and he's a reasonable sort....and things should level out. Lots of good potential for the thread.
  3. 06-28-2012 07:40 PM - permalink
    Maybe it is low voltage to the relay box is there a solonoid that switches power on an off to relays maybe thats faulty how can i test power at relays
  4. woodnthings
    06-27-2012 10:34 PM - permalink
    Thanks for the Reps!
  5. X_Hemi_Guy
    08-17-2011 09:11 AM - permalink
    THANKS for the reps!
  6. hanklin
    07-11-2011 07:08 AM - permalink
    I will give that a try when sun comes up. I have to haul 28 doors today and I hate to get a ticket.
    Thanks buddy
  7. hanklin
    07-10-2011 09:32 AM - permalink
    I have a ? if you don`t mind. My 12` aluminum flat trailer has working tail lights but not brake light on left side. Changed bulbs and everything is clean and no visible breaks in wires. Can you steer me in any directions? Please and Thanks
  8. 08-27-2010 10:15 AM - permalink
    In reading a reply that you posted you seem to have a lot of knowledge about these trucks. We are having a problem I would like to ask you about. Our 2006 F250 SD w/V10 threw a problem at us. The other day when towing our 5the wheel the truck said it was overheating and went in to limp mode, the engine light came on and it said to check codes. We took it to a shop and the engine code they said was for the cylinder head temp sensor. We had them replace it and they test drove it and no issues. We hooked back up and headed home, it ended up doing the same thing again, we tried pulling it without the electrical hooked up to make sure it was not the trailer but it still did it. If we drive it without the trailer it does not do it. We also have noticed that it sprayed out a little antifreeze after they fixed it. Any suggestions or ideas, I am taking it to my local Ford dealer but it wouldn't hurt to have some information to compare with what they say. Thanks!

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.