Ford Truck Enthusiasts Forums - View Profile: shorod

Go Back  Ford Truck Enthusiasts Forums > Members
Reload this Page >

shorod's Profile

Notices
shorod has a great reputation on FTE.shorod has a great reputation on FTE.shorod has a great reputation on FTE.shorod has a great reputation on FTE.

shorod shorod is offline

Postmaster

Visitor Messages

Showing Visitor Messages 51 to 60 of 92
  1. ChosenMedia
    03-27-2013 07:09 AM - permalink
    Hello, I'm having problems with my Explorer and was wondering if you could give me some input. Thanks.
  2. GIGGER
    12-01-2012 08:51 PM - permalink
    I was reading yer Expo door lock repair tip so I repped you & you got another rep bean, I love it when that happens, thx Rod
  3. jgray5_lssu
    11-29-2012 06:17 AM - permalink
    Sorry my internet has been down, snowstorm blew the power out. Thank god for wood stoves, stayed nice and toasty. lol I have the 99 explorer with the mirror issue (posting that because you seem to help a lot of people). [email protected] I was wondering if you could help me with another issue I am having, which is my front passenger window won't go down unless I push on the rear of it. The front of the window will drop somewhat then quit going or go really slow. Not sure if the repair place didn't put it in properly or if it's something that occurs every now and again, so I think fixing it myself would be best.
  4. a-10 warthog
    09-20-2012 12:24 PM - permalink
    That would be awesome if you could email me the climate seat diagram. My email is [email protected]
  5. Glenn Nall
    09-06-2012 08:46 AM - permalink
    thanks, Rod - yeah, i'd love a schematic (2005 Sport Trac Radio wiring) - you can email me at [email protected].

    left ya a couple of leftover questions in the post, along with some rhetoric that you're welcome to ignore. thanks if you can tie up those loose ends for me.

    i really greatly appreciate your help.

    Glenn
  6. Bowhunterchick
    08-03-2012 08:13 AM - permalink
    Thank you for helping me with this. My email is: [email protected] Please send me the PDF file on how to remove the subwoofer panel in my 2002 Mountaineer.
    I appreciate your help
    Wendy
  7. macblacklighting
    06-13-2012 07:51 AM - permalink
    Yes the fuel filter can only put on one way. The intake gasket's are a o-ring type. The wires to the coil pack 1-5, 2-6 , 3-4 all to the correct cylinders. but i did notice all the new plugs have a dry black sout on them. Thank you replying. , Matt ,
  8. macblacklighting
    06-12-2012 06:55 PM - permalink
    Hi i am new to this site. I'm working on my brothers 2003 Ford Explorer 4.0 L sohc, It had a value cover's leak so i put new ones on and new intake o-rings , plug's wires ,Fuel filter. The vehicle ran fine , but after these small repairs are done it will not start. I don,t have a fuel pressure gauge but it seem to be getting fuel pressure . I did and old school spark check all plug's are getting power . checked all the vac-line look good. Tryed a new cam-shaft sensor. No luck. It will fire up for a short period about a second or two but stall's and will not start in till i floor the gas and it will do the same start for a few second's and stall. when it did start for short time i got a error code of P2197 witch is a os. bank two os #1 stuck open. please do you have any ideas. Thank you.
  9. mntncat
    05-17-2012 02:48 PM - permalink
    I can't thank you enough! I have also been having a problem with the door ajar system for the past coupla years. I am disabled, so that kind of problem isn't one I can afford to fix. The new fuse appears to have fixed THAT problem too!!! I am so grateful that you replied to my question!
  10. sbranco
    04-26-2012 12:33 PM - permalink
    I'll see if i can get a more expensive/quality set of wires help... if it does I would be really happy since they will be the 3rd set bought for this truck in the last month > . <
    do you think that the coil pack could be damaged too? it is one thing I haven't changed that had been physically touched. especially since the second new set of wires are in the truck now for #1, 3, and 4.
    or should i just stick with wires and go from there?
    these are the new codes i got yesterday from auto zone... not much different than before
    P300
    P301
    P303
    P316

About Me

  • About shorod
    Location
    Cedar Rapids, IA
    Interests
    Bicycling, R/C Car racing, Consumer electronics repair, automotive repair
    2 Letter State/Province (use "--" for outside USA/
    IA
    Country of Residence
    US
    Make
    Lincoln
    Model
    Navigator
    Year
    2004
    Current Mileage
    0 - 24,999
    Miles per year
    1,000 - 4,999
    Gender
    Male

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Today 09:31 AM
  • Join Date: 06-22-2009
  • Referrals: 0

Friends

Showing Friends 1 to 9 of 9

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.