Ford Truck Enthusiasts Forums - View Profile: Mark Kovalsky



Mark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputation

Mark Kovalsky Mark Kovalsky is online now

Post Fiend

Visitor Messages

Showing Visitor Messages 1 to 10 of 678
  1. EO2SeaBee
    08-12-2017 02:16 PM - permalink
    EO2SeaBee
    Thank you for the reps and for providing insight to the group. I'm amazed at how hard headed some can be.
  2. tombo87
    08-07-2017 08:44 PM - permalink
    tombo87
    code 33 took egr off and cleaned and replaced gasket,with applied vacum I get continuity,late shift 3500 to 4000 rpm to 2nd? or 3rd unless I let up at 2500 and It will shift hunts between 3rd and forth,od on /off seems to make no difference.If I put my foot in throttle neutrals out high rpm no gear or slippage? Put foot on brake will turn tires.Pulled psom today looked good .I found brake light upper roof mount burnt out socket replaced same.Blown 25 amp fuse for trailer replaced and did not blow again. Thanks Mark
  3. tombo87
    08-06-2017 10:19 PM - permalink
    tombo87
    Hi Mark,I have used your advise and pulled codes on 1996 f250hd 5.8l 4x4 e4od 8-351 I have had multiple codes and replaced vss,mlps,map,tps,rebuilt acumulator with sonnax,and replaced shift solonoids also fluid and filter.Shifts manually fine.In Drive 3500 rpm before it shifts sometimes hunts and downshifts hard.Please lead me electrically what to do next.Thanks Tom
  4. Sara Byrd
    08-02-2017 03:05 PM - permalink
    Sara Byrd
    Will do picking one up now to replace.
  5. Sara Byrd
    08-02-2017 11:33 AM - permalink
    Sara Byrd
    Hey mark! Thank for info on my 7.3
    Was reviewing other threads you posted on and thing,I have issue pinpointed. It started just randomly shifting into neutral when driving.. Bad TRS sensor I believe! Going to get a new one when I go into town!
  6. schoo
    07-29-2017 06:26 PM - permalink
    schoo
    Thank you any way
  7. schoo
    07-29-2017 08:36 AM - permalink
    schoo
    Hi mark we have a thread over on the 48-56 forum and I was hoping you could add some to our discussion it's called Aod throttle valve adjustment by 56panelford any help would be appreciated
    Roy
  8. kelanthony1989
    07-22-2017 03:35 PM - permalink
    kelanthony1989

    Looks as if this would take care of the issue as well, and possibly be a little quicker/easier for me for about the same price...???
  9. Mark Kovalsky
    07-18-2017 10:22 PM - permalink
    Mark Kovalsky
    The bypass rebuild is REALLY easy to install. Just fill it and you're good.
  10. kelanthony1989
    07-18-2017 09:53 PM - permalink
    kelanthony1989
    Maybe that bypass spring being weak is why my temps weren't cooling as well either with the stock 7.3 cooler? Should I just add the rest of the fluid and call it good? I assume I got quite a bit of the old fluid out..

About Me

  • About Mark Kovalsky
    Biography
    Former Ford automatic transmission engineer.
    Location
    SE Florida
    Interests
    Flying, Antique cars and fire trucks.
    2 Letter State/Province (use "--" for outside USA/
    FL
    Country of Residence
    US
    Make
    Ford
    Model
    Econline or E-Series
    Year
    2002
    Current Mileage
    125,000 - 149,999
    Miles per year
    0 - 999
  • Signature
    Mark
    Former Ford Automatic Transmission Engineer 1988 - 2007

    Nobody has made MERCON since 2006. MERCON V replaced MERCON. Get over it.

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Today 08:52 AM
  • Join Date: 08-13-1999
  • Referrals: 1

Friends

Showing Friends 1 to 10 of 83

All times are GMT -5. The time now is 08:52 AM.