Ford Truck Enthusiasts Forums - View Profile: Mark Kovalsky

Go Back  Ford Truck Enthusiasts Forums > Members
Reload this Page >

Mark Kovalsky's Profile

Notices
Mark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputationMark Kovalsky has a superb reputation

Mark Kovalsky Mark Kovalsky is online now

Post Fiend

Visitor Messages

Showing Visitor Messages 1 to 10 of 714
  1. 1youngblood
    Yesterday 07:12 AM - permalink
    Mark seals and bushing are replaced.Transmission is back in the truck.Ready to install transfer case.Does the rubber line from the top of the transmission go to the transfer case ? I removed it when the trans was half way down and didn't get a good mental picture. Thanks Youngblood
  2. 1youngblood
    09-12-2018 08:01 AM - permalink
    Re. 2004 f150 4.6 transmission leak. Mark I inspected the bushing behind the pump seal it is scored. What is the best way of removing it with basic tools ? from the front side or removing the pump and tapping it out from the back side ? Thanks Youngblood
  3. black460
    08-15-2018 10:52 PM - permalink
    Hi Mark,

    Can you help confirm that mercon V is needed for a 2004 e450 with a V10?
  4. BigBlueIron
    08-15-2018 12:56 PM - permalink
    Mark,
    I appreciate any advice you can offer.
    Vehicle: 1995 F-Superduty 7.3 auto E4OD i believe.
    Complaint: no forward motion when selector is in D

    Trans was remaned several years ago estimate maybe 40k
    What I have found, when D is selected it feels like N the truck will slightly surge and a some noise from the trans can be heard. Shift down and away you go as if nothing is wrong. It will shift up and down normally including convertor lock. Until you slow to a stop then you have to pull it into 1st or 2nd. All gears are function. Shifts are firm but not harsh OD button works as it should, and does not flash indicating an issue. Only codes I have are for a exhaust back pressure and TPS. Also verified the (new) MLPS operation via scanner. New VSS

    Power to solenoids was verified and terminals cleaned.

    What operations are asked of the trans when D is selected? Possibly a faulty solenoid? Just seems really weird that it drives and shifts fine once rolling.
  5. billybobofkf
    06-18-2018 07:00 PM - permalink
    Thanks for your input on the 4R100 towing in overdrive question. Also, I went with your recommendation for a trans oil cooler setup and I'm impressed with the results. Thanks again!
  6. Travles with Barley
    05-30-2018 09:37 PM - permalink
    Success!!!!!

    I made it to the Boarder and back to where i was camping (4 1/2 Hrs each way). Today I took apart the Main valve body and found drill chips in the Solenoid Regulator piston, along with bits in other various circuits.. I cleaned it all up, blew it out and put it all back together and........ YES!!!! it is working as intended.

    Thank you so so much for responding to my messages. You truly are a lifesaver!

    Jeff
  7. Travles with Barley
    05-27-2018 10:23 AM - permalink
    Hi Mark,

    I have almost made it to the Border. When I began the trip yesterday, the OD was already flashing. So I left it in Limp mode thinking the added pressure would help from slipping. About 2/3 through the 270Km trip I reset the Fault and turned OD off. The Transmission still behaved the same, but didn't throw a code. (2nd Manual and 4th in D only)

    I don't know if i will have internet at the border so i wanted to ask you if I can remove the main valve body while the transmission is still in the truck? Will i have check ball falling in my face?

    Thanks again,

    Jeff
  8. Travles with Barley
    05-25-2018 09:50 PM - permalink
    Ah Ha... well further developments. I found out i need to cross the border by the 28th or they could impound my truck...,
    So I am "limping" this from the middle of Colombia to the Ecuador Border. I drove about 200 miles today in mostly flat tropical highways.
    Just in the last 20 miles it finally threw a code P1728 Slip...YIKES i hope i am not destroying my TC. the temp goes from 180 to an occasional 200. and the oil is in good shape.
    I don'[t really have much of a choice, I am trying my best to Baby it. is it better to drive it in Limp mode, or reset it and turn OD off??

    Thanks again.. you are my only lifeline right now..
    i appreciate your help

    Jeff
  9. Travles with Barley
    05-25-2018 07:58 PM - permalink
    Side Note:

    I'm not sure if this has anything to do with the problem, but a week or two ago I bought some gauges. The tranny temp gauge goes into the pressure port on the drivers side of the tranny. Well, the bolt was frozen and stripped out. I eventually had to drill and easy-out the bolt. I was really careful trying not to get any chips into the system, and even let a bit of fluid drip out hoping to carry and debris out with it. Everything had been working fine for a few trips back and forth to town. Perhaps a small chip worked its way into the system???? would this explain my symptoms?
  10. Travles with Barley
    05-25-2018 07:57 PM - permalink
    Thanks for getting back to me

    No, There is +12 v on pin 1 and 12, SS1 goes to ground when i am in park, reverse, and when I just start to drive. Then when I'm going like 10 mph SS1 and SS2 both go to ground (2nd) so the PCM seems to be working properly, but it never shifts.
    It also shows the coast clutch solenoid is energized.
    So, I'm getting power to the valve body, and the PCM is sending the right signal to the solenoids.
    Not in Limp mode (no OD blinking) and no faults

    I really appreciate your help with this, cause I am stuck.

About Me

  • About Mark Kovalsky
    Biography
    Former Ford automatic transmission engineer.
    Location
    SE Florida
    Interests
    Flying, Antique cars and fire trucks.
    2 Letter State/Province (use "--" for outside USA/
    FL
    Country of Residence
    US
    Make
    Ford
    Model
    Econline or E-Series
    Year
    2002
    Current Mileage
    125,000 - 149,999
    Miles per year
    0 - 999
  • Signature
    Mark
    Former Ford Automatic Transmission Engineer 1988 - 2007

    Nobody has made MERCON since 2006. MERCON V replaced MERCON. Get over it.

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: Today 07:23 AM
  • Join Date: 08-13-1999
  • Referrals: 1

Friends

Showing Friends 1 to 10 of 87

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.