Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Oil residue on filter..

 
  #1  
Old 06-22-2010, 05:57 AM
Liquid10Rider
Liquid10Rider is offline
Elder User
Thread Starter
Join Date: Apr 2009
Posts: 665
Liquid10Rider is gaining momentum as a positive member of FTE.
Oil residue on filter..

Hey guys I have noticed oil residue on the side of the oil filter. I had changed my oil about 2000 miles ago and had noticed the residue so I cleaned it off and figured I just didnt clean it that great when I finished changing the oil. I just looked under there again and noticed that the oil is back again. I have done plenty of oil changes on diesels before and never has this happened. I made sure the old filter ring was not stuck to the housing. And I made sure to oil the new seal and clean the housing. Is this normal on the 7.3?

-AJ
 
  #2  
Old 06-22-2010, 07:38 AM
Kwikkordead's Avatar
Kwikkordead
Kwikkordead is offline
Post Fiend
Join Date: Jun 2004
Location: North Seattle, WA.
Posts: 22,286
Kwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputationKwikkordead has a superb reputation
Not normal.
You have a leak somewhere.
 
  #3  
Old 06-22-2010, 07:41 AM
ChunderDownUnder's Avatar
ChunderDownUnder
ChunderDownUnder is offline
Posting Guru
Join Date: Apr 2009
Location: Man Cave
Posts: 2,129
ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.
I have the same problem. I very slight leak that runs down the side of the filter. Have gone through 4 filters since I have had the truck and they have all done it. I just live with it.
 
  #4  
Old 06-22-2010, 07:53 AM
Liquid10Rider
Liquid10Rider is offline
Elder User
Thread Starter
Join Date: Apr 2009
Posts: 665
Liquid10Rider is gaining momentum as a positive member of FTE.
Originally Posted by Kwikkordead View Post
Not normal.
You have a leak somewhere.
As I stated before the filter has residue on it. Its coming from right under the housing and rolling down the filter. Its not horrible but I have never had this problem on any of the vehicles that I have done oil changes to.
 
  #5  
Old 06-22-2010, 07:57 AM
Liquid10Rider
Liquid10Rider is offline
Elder User
Thread Starter
Join Date: Apr 2009
Posts: 665
Liquid10Rider is gaining momentum as a positive member of FTE.
Originally Posted by ChunderDownUnder View Post
I have the same problem. I very slight leak that runs down the side of the filter. Have gone through 4 filters since I have had the truck and they have all done it. I just live with it.
I was thinking maybe it could be the oil pressure but the guage seems to be reading normal pressure.

I checked if the filter came loose but it was tight and I ran it for a while then checked again and the residue came back. Ill just deal with it for now.
 
  #6  
Old 06-22-2010, 08:02 AM
ChunderDownUnder's Avatar
ChunderDownUnder
ChunderDownUnder is offline
Posting Guru
Join Date: Apr 2009
Location: Man Cave
Posts: 2,129
ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.ChunderDownUnder has a great reputation on FTE.
I met up with a bloke who had a 05 (we got em to 06) and he's did the exact same. I dont know if it is the same over there but there is a yellow dot on the oil filter housing on ours just were the filter buts up and thats the exact same place on both of ours where it weeps. the only option I see with my problem is to replace the filter housing or take it off and get it re machined. But as I said its only a slight weep and I really cant justify the cost.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.