1999 Navigator Blend Door Woes.... - Ford Truck Enthusiasts Forums



1997-2006 Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator Discussion

1999 Navigator Blend Door Woes....

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-28-2010, 03:30 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
1999 Navigator Blend Door Woes....

So it would appear that I have several problems right now. A: I am only getting hot air up front.The Vent/Max AC door does work. Everything works fine in the rear, hot, cold, etc... B: Im only getting air out of the defroster, will not change between vent/floor/etc. B is not really of concern to me, I can deal with that, but A is really starting to be a B****H! Im not really sure how to diagnose the problem either. Ive read in some posts about a code (1249 i think) but I dont have a check engine light on which I assume means the computer isnt throwing out a code?? Any help appreciated.
Reply With Quote
  #2  
Old 04-28-2010, 03:47 PM
rtg143 rtg143 is offline
Junior User
 
Join Date: Jan 2010
Location: Grants Pass, Or.
Posts: 53
rtg143 is starting off with a positive reputation.
The defrost only is probably due to a vacuum leak, With no vacuum, it defaults to defrost for safety reasons. Check under the hood for vacuum lines loose, off or broken. As for the heat only, the blend door could be defective. With the engine off and the key on, turn the control from heat to cool and back while listening for the door to move. It's not very loud but you can hear it if you listen closely.
Reply With Quote
  #3  
Old 04-28-2010, 03:51 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
no sound at all. silence.
Reply With Quote
  #4  
Old 04-28-2010, 03:57 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
then again....

On second inspection i noticed a couple VERY faint clicks when adjusting up from 60-68 degrees, nothing after that up to 90 degrees. When I adjust back down from 90 I hear the same EXTREMELY faint clicks at 68-60. Appears to be directly behind temp control panel. Could just be some sort of relay, no clue.
Reply With Quote
  #5  
Old 04-28-2010, 04:44 PM
rtg143 rtg143 is offline
Junior User
 
Join Date: Jan 2010
Location: Grants Pass, Or.
Posts: 53
rtg143 is starting off with a positive reputation.
There are no relays controled by the dial. It's probably the blend door motor. At least they are pretty easy to get to. It's in the center of thedash and behind the lower center panel and rear air duct.
Reply With Quote
  #6  
Old 04-28-2010, 05:08 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
DOH!!

HAHAHAHAH!!!! Upon FURTHER inspection..... A: The blend door is INFACT broken (Dremel'd a hole in the plenum to get to it, SOOOOO much easier than taking apart the dash!). B: There is NO BLEND DOOR ACTUATOR IN MY VEHICLE!!! WHAT??? Apparently the previous owner ripped it out in an attempt to solve the problem and then walked away from it. I realized this when I stuck my finger down the hole that the blend door sits in and my finger went through the bottom. Anyone got a part number for this thing?
Reply With Quote
  #7  
Old 04-28-2010, 06:14 PM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 12,907
alloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to behold
Reply With Quote
  #8  
Old 04-28-2010, 06:59 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
Yeah HeaterTreater is where I got the idea to cut into the plenum with a dremel. Problem is they only supply the door, which is an absolute ripoff for $120.00 You can get a replacement door on ebay with a steel ring where the problem area is for around $25.00. I still need the actual actuator box.
Reply With Quote
  #9  
Old 04-28-2010, 07:17 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
What the fripping heck?! I can find blend doors for this thing all day but I cant find the actuator!! AAARRRGH! Does anybody have a part number for the ACTUATOR/MOTOR ASSEMBLY?? PLEASE HELP!
Reply With Quote
  #10  
Old 04-28-2010, 09:50 PM
thecardoc thecardoc is offline
Senior User
 
Join Date: Jan 2006
Posts: 292
thecardoc is starting off with a positive reputation.
Blend door part # 660-1677 at NAPA actuator / motor # 655-1969 at NAPA
Reply With Quote
  #11  
Old 04-28-2010, 10:51 PM
illgorhythm illgorhythm is offline
Freshman User
Thread Starter
 
Join Date: Apr 2010
Posts: 38
illgorhythm is starting off with a positive reputation.
Quote:
Originally Posted by thecardoc View Post
Blend door part # 660-1677 at NAPA actuator / motor # 655-1969 at NAPA
So heres the issue Im having, only because I dont want to buy a part and it not work. The part number you listed for the actuator/motor is specifically for a 02-03 navigator. Any search on any site for an actuator for a 98-02 navigator will ONLY yeild results for the door itself, not the actuator, even Ford OEM Parts sites DO NOT show a part number for the actuator. Its should be noted as well that the Navs had a digital temperature adjust, not a ****/potentiometer like the Expys, so I can understand if there is a SLIGHT difference between the two, But I am completely dumbfounded at the thought that NO site on the entire internet lists a part number for any 98-02 Navigator actuator/motor. Only for the door itself. Is it possible that there is any difference between the Expy actuator and the Nav???? C'mon FORD!! WTF!!!! IM SICK OF THIS DUMBF*&^%*NG NAVIGATOR! I CAN FIND ANYTHING I F(*)^&NG WANT FOR AN EXPY BUT NOT A NAV?!?!?!?! WTF!?!?!?!?!
Reply With Quote
  #12  
Old 04-29-2010, 01:51 AM
alloro alloro is offline
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 12,907
alloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to beholdalloro is a splendid one to behold
Quote:
Originally Posted by illgorhythm View Post
C'mon FORD!! WTF!!!! IM SICK OF THIS DUMBF*&^%*NG NAVIGATOR!
First off, ease up on the caffeine, second Ford doesn't make the Navigator Lincoln does. Third, I found an actuator listed on my first attempt just by clicking the link to this forum's sponsor ...Y2KFORDPARTS.

www.partsguyed.com
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rear Air Door Help cwilkins002 1968-2013 Full Size Vans 6 10-20-2016 10:15 PM
Which fuse is the vacuum pump on? Need help diagnosing electrical... Studawg Excursion - King of SUVs 6 08-18-2015 07:31 PM
Air blowing hot out of vents when cool outside 2003xcrsn4x4 Excursion - King of SUVs 9 05-29-2014 03:27 AM
Vacuum line FAQ f100beatertruck 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 11 07-29-2013 07:41 PM
1998 F-150 Vent problem Chemja Cooling, Heating, Ventilation & A/C 3 07-29-2004 07:21 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
1978, 1999, 2003, actuator, blend, change, defrost, door, expedition, lincoln, location, navigator, navigtor, stuck, vacuum

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:17 AM.