Go Back  Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Reload this Page >

Stupid light...is something wrong or just a short?

Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Stupid light...is something wrong or just a short?

 
  #1  
Old 11-12-2008, 01:11 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Stupid light...is something wrong or just a short?

Charging system light still comes on and off after Ive done the following...
-replaced harness plug (the one that has 2 wires going to alt)
-taped all wires going to and from alternator including the harness ontop of the VC
-checked voltage(while running) of both batteries, 14.34
-unplugged 2 wire harness and the light goes off, plug it back in and comes back on

What else is there to do? Am I missing a wire that might be chaffed or something? Im going on a 13 hour trip in a week or so and I really dont want to stare at that light coming on and off and not KNOWING if my alt is going to die on me halfway through it or not!

If there is a wire that causes it does anyone know the color of it?!
Im ticked off and tried everything I can think of!
 
  #2  
Old 11-12-2008, 01:17 PM
SpringerPop's Avatar
SpringerPop
SpringerPop is offline
Too old to be too smart
Join Date: Jan 2002
Location: La La Land
Posts: 17,633
SpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputationSpringerPop has a superb reputation
Have you checked the wear length of the field brushes?

Pop
 
  #3  
Old 11-12-2008, 01:23 PM
bkcowboss
bkcowboss is offline
Posting Guru
Join Date: Nov 2006
Location: Herndon KY
Posts: 1,059
bkcowboss is gaining momentum as a positive member of FTE.
When I had that issue, alternator was bad (advance rebuild) but voltage showed good, I had to take it off of the truck and into the auto parts store for the test to show up bad, rest of the time the test showed good.

edit: replaced alternator good to go now for 12 months
 
  #4  
Old 11-12-2008, 01:32 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Originally Posted by SpringerPop View Post
Have you checked the wear length of the field brushes?

Pop
You might as well be talking a different language! This alternator is less than 2 years old IIRC. Ive done everything except take it completely off and check anything. Ill be honest with you, Im not afraid to poke around with anything, except the alternator!
 
  #5  
Old 11-12-2008, 01:37 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Bryan,
Whats the difference in testing it on the truck vs. off the truck?
 
  #6  
Old 11-12-2008, 01:43 PM
zx250's Avatar
zx250
zx250 is offline
Of the next Riffraff East
Join Date: Oct 2004
Location: Concord NC
Posts: 8,679
zx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant future
Age don't always mean much. It sounds like an alternator going bad, although it could be something else. Next time it's off, load the system, lights, fans, ect and see if you can make it come on. If I were leaving on a long trip, I would at the very least buy one to carry with me, If you don't use it, you can return it when you get back, if you need it, you can change it on the side of the road with mimimal tools.
 
  #7  
Old 11-12-2008, 01:49 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
What I dont understand is the light coming on then off. On a 45 minute trip it might come on and off 10 times and sometimes it just comes on randomly and stays on...wouldnt the light STAY on if something was truly wrong, or am I giving Ford too much credit?
 
  #8  
Old 11-12-2008, 01:59 PM
bkcowboss
bkcowboss is offline
Posting Guru
Join Date: Nov 2006
Location: Herndon KY
Posts: 1,059
bkcowboss is gaining momentum as a positive member of FTE.
Originally Posted by triskit16 View Post
Bryan,
Whats the difference in testing it on the truck vs. off the truck?

What you are describing was my exact issue, went on for several months light would come on sometimes, sometimes not.....I asked the auto store guy cause he tested it several times on the truck including the day that I pulled it off and took it in and it tested bad. He said maybe cause their tester was really built to test with one battery, or that the machine does a more thorough job, either way my alt was bad after just over a year. Good luck I spent months pulling my hair out because of that freakin "nuisance" light
 
  #9  
Old 11-12-2008, 02:06 PM
bdrummonds's Avatar
bdrummonds
bdrummonds is offline
Post Fiend
Join Date: Sep 2006
Location: Millbrook Alabama
Posts: 5,584
bdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud of
Originally Posted by triskit16 View Post
What I dont understand is the light coming on then off. On a 45 minute trip it might come on and off 10 times and sometimes it just comes on randomly and stays on...wouldnt the light STAY on if something was truly wrong, or am I giving Ford too much credit?
the voltage regulator is going bad. If it is a chain store alt witha lifetime replacement warranty, pull it off take it to the store and tell them its fried, the'yll check it on their inside machine and then youll get a new one.
 
  #10  
Old 11-12-2008, 02:09 PM
zx250's Avatar
zx250
zx250 is offline
Of the next Riffraff East
Join Date: Oct 2004
Location: Concord NC
Posts: 8,679
zx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant futurezx250 has a brilliant future
Originally Posted by triskit16 View Post
What I dont understand is the light coming on then off. On a 45 minute trip it might come on and off 10 times and sometimes it just comes on randomly and stays on...wouldnt the light STAY on if something was truly wrong, or am I giving Ford too much credit?
Once it comes on and stays, you better be close to where you want to be. If like most, it will start to come on more ofter and for longer periods of time.
 
  #11  
Old 11-12-2008, 02:21 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Well looks like I have a nice job to do tomorrow. Good thing Ive got the ol reliable Mustang to take me to the store. Anyone recommend a good place to get one from? The one in there now is from NAPA but It was put on at a shop(shops gone outta business) and Ive heard bad things about the Auto Zone alternators as far as lasting. I really dont wanna have to change the alt out every other couple of months.

Edit...I know about DB's but I need to get it tomorrow. No time to wait on delivery
 
  #12  
Old 11-12-2008, 02:27 PM
Ponyboychris's Avatar
Ponyboychris
Ponyboychris is offline
Hit it!
Join Date: Jan 2007
Location: Centennial CO
Posts: 6,707
Ponyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud ofPonyboychris has much to be proud of
My light blinked on and off for a short trip and didn't come on for a week then all in the sudden, came on again and stayed on until I swapped out the alternator. I think your truck is telling you something...

On edit: My new unit is a NAPA. Very easy to swap.
 
  #13  
Old 11-12-2008, 02:45 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Stupid question....the other "plug" (im assuming the important one)...how do you take that off when you take the alternator off?
 
  #14  
Old 11-12-2008, 02:54 PM
bdrummonds's Avatar
bdrummonds
bdrummonds is offline
Post Fiend
Join Date: Sep 2006
Location: Millbrook Alabama
Posts: 5,584
bdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud ofbdrummonds has much to be proud of
Originally Posted by triskit16 View Post
Stupid question....the other "plug" (im assuming the important one)...how do you take that off when you take the alternator off?
Its not a plug, its a terminal covered with a cap. 8mm nut , and then the 12v wire is loose.(disconnect both batts before removing this wire.)
 
  #15  
Old 11-12-2008, 03:10 PM
triskit16's Avatar
triskit16
triskit16 is offline
Postmaster
Thread Starter
Join Date: Sep 2008
Location: VA
Posts: 3,220
triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.triskit16 has a very good reputation on FTE.
Thank yall very much!

Ill be headin down your way for Thanksgiving, Brandon. Gonna catch up with all the family!
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.