Go Back  Ford Truck Enthusiasts Forums > Diesel > 1999 - 2003 7.3L Power Stroke Diesel
Reload this Page >

The Australian saga it's finally running BUT!!!!

Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

The Australian saga it's finally running BUT!!!!

 
  #1  
Old 08-15-2008, 05:39 PM
Ratkat's Avatar
Ratkat
Ratkat is offline
Senior User
Thread Starter
Join Date: Jul 2008
Location: Australia
Posts: 188
Ratkat is gaining momentum as a positive member of FTE.
The Australian saga it's finally running BUT!!!!

Well the title says it she's alive with the new powerstroke from Michigan, purred like a kitten for 5 minutes and then did # 3 injector [ # 2 started the problem that killed my last engine] feel sorry for the guys working on it as it is not there fault. The engine was run in on the dyno at ford in the U.S. if only they had run it for another 5 minutes!!! It has shown an electrical fault on # 3.

This is the 2nd injector I have had go in this way in a very short period of time. Is there a common fault that will cause this or was it just rotten luck
 
  #2  
Old 08-15-2008, 05:46 PM
ron's power stroke's Avatar
ron's power stroke
ron's power stroke is offline
Post Fiend
Join Date: Jun 2006
Location: White Mnt's,New Hampshire
Posts: 9,716
ron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud ofron's power stroke has much to be proud of
did they check the harness from the IDM to each VC ??? also ohm out the 9 pin at each VC..sounds like a short some place..here is the pin out and spec's

Pin Out
G G I I C I I G G
G=Glow Plug +
I = Injector +
C= Injector Common
***The injectors fire with a 115VDC signal from the IDM do not pierce to wires to test.***
Ohm between "I" and "C" to test the injectors, should be less than 5.0 Ohms
To check glow plugs Ohm between "G" and battery ground should be between 0.1 and 2.0 Ohms
 
  #3  
Old 08-15-2008, 07:45 PM
F350-6's Avatar
F350-6
F350-6 is offline
Post Fiend
Join Date: Mar 2007
Location: Texas
Posts: 26,927
F350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputation
An interesting fact I stumbled across today (thanks Rick) is that even if your injectors OHM out less than 5 ohms, watch for any variance in the #3 injector. Apparently a weak injector solenoid will give you an OHM reading 0.8 - 0.9 lower than the rest of the injectors on that bank. I had an issue with one of the work trucks today where the OHM test showed this drop, and it was confirmed with the injector buzz test.

I'd guess you've just got rotten luck since you're problems seem to jump to different cylinders. You can try swapping the #3 & #5 injectors. See if the problem follows the injector or stays in the same spot. That should tell you if you have an injector or wiring issue.

My issue today with the #4 injector caused the IDM to shut down the entire bank of injectors. Is your fault only showing up on 1 injector or did the IDM shut down the whole side?
 
  #4  
Old 08-15-2008, 08:00 PM
guitarpicr's Avatar
guitarpicr
guitarpicr is offline
Posting Guru
Join Date: Apr 2007
Location: St. Louis, Mo.
Posts: 2,319
guitarpicr has a very good reputation on FTE.guitarpicr has a very good reputation on FTE.guitarpicr has a very good reputation on FTE.
Hate to hear that Tim. - Hope they get you fixed up and running shortly. Good Luck
 
  #5  
Old 08-15-2008, 08:27 PM
Ratkat's Avatar
Ratkat
Ratkat is offline
Senior User
Thread Starter
Join Date: Jul 2008
Location: Australia
Posts: 188
Ratkat is gaining momentum as a positive member of FTE.
Chris
I wasn't there but I would think it was only missing on 1 injector. I will ask the question Monday.
 
  #6  
Old 08-15-2008, 08:40 PM
F350-6's Avatar
F350-6
F350-6 is offline
Post Fiend
Join Date: Mar 2007
Location: Texas
Posts: 26,927
F350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputation
Keep in mind your fitter (I picked that one up from some other Australian members) doesn't work with the 7.3 every day, so as long as he's not the big ego type, there's a chance that we can help point him in the right direction on what to check next.

Try to get him to pass on all the information on what tests he's done and the results he's gotten. I've had to suggest repairs to diesel mechanics here in the States based on trouble codes and diagnostics when we didn't have time to work on the trucks ourself.
 
  #7  
Old 08-15-2008, 10:13 PM
Ratkat's Avatar
Ratkat
Ratkat is offline
Senior User
Thread Starter
Join Date: Jul 2008
Location: Australia
Posts: 188
Ratkat is gaining momentum as a positive member of FTE.
Chris you are right the fitters dont know alot at all. The Ford motor company sends them for a 2 day course and that is the extent of their training. I dont know about you but sounds like a lot to take in in 2 days to me. Also the fact that only 9000 units were sold Australia wide deisel & gas means they are well behind the 8 ball in experience. FTE has been invaluable to me and they are quite willing to listen to any ideas. I have a reco injector in the old motor that has only done 250 miles so I want them to just change the tops over. But they want to call the engine importer first to get the ok from a waranty point of view. I'll post more on monday when I know
 
  #8  
Old 08-29-2008, 03:21 AM
Ratkat's Avatar
Ratkat
Ratkat is offline
Senior User
Thread Starter
Join Date: Jul 2008
Location: Australia
Posts: 188
Ratkat is gaining momentum as a positive member of FTE.
Originally Posted by F350-6 View Post
An interesting fact I stumbled across today (thanks Rick) is that even if your injectors OHM out less than 5 ohms, watch for any variance in the #3 injector. Apparently a weak injector solenoid will give you an OHM reading 0.8 - 0.9 lower than the rest of the injectors on that bank. I had an issue with one of the work trucks today where the OHM test showed this drop, and it was confirmed with the injector buzz test.

I'd guess you've just got rotten luck since you're problems seem to jump to different cylinders. You can try swapping the #3 & #5 injectors. See if the problem follows the injector or stays in the same spot. That should tell you if you have an injector or wiring issue.

My issue today with the #4 injector caused the IDM to shut down the entire bank of injectors. Is your fault only showing up on 1 injector or did the IDM shut down the whole side?
Hey Chris the truck has just clicked over 1000 kilometers and guess what another injector gone this time it has shut down the whole bank . What did you find with your truck after the whole bank shut down
 
  #9  
Old 08-29-2008, 05:36 AM
F350-6's Avatar
F350-6
F350-6 is offline
Post Fiend
Join Date: Mar 2007
Location: Texas
Posts: 26,927
F350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputationF350-6 has a superb reputation
Originally Posted by Ratkat View Post
Hey Chris the truck has just clicked over 1000 kilometers and guess what another injector gone this time it has shut down the whole bank . What did you find with your truck after the whole bank shut down
The bad injector caused the whole bank to shut down. We replaced the single injector and haven't had any issues since.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mjtpolice76
1999 - 2003 7.3L Power Stroke Diesel
2
05-23-2014 08:27 AM
spanky350
6.0L Power Stroke Diesel
12
04-27-2014 04:25 PM
bobbyrjw
1999 - 2003 7.3L Power Stroke Diesel
7
03-26-2011 08:56 AM
geborenzuschaukeln
1987 - 1996 F150 & Larger F-Series Trucks
14
04-08-2005 10:54 AM
diver1dude
Bronco II
8
08-07-2003 12:12 PM


Thread Tools
Search this Thread
Quick Reply: The Australian saga it's finally running BUT!!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.