predator not backing up stock tune????? - Ford Truck Enthusiasts Forums

Notices
Modular V10 (6.8l)  
Sponsored by:
Sponsored by:

predator not backing up stock tune?????

 
  #1  
Old 06-12-2008, 08:59 PM
twce023587
twce023587 is offline
New User
Thread Starter
Join Date: Jun 2008
Posts: 14
twce023587 is starting off with a positive reputation.
predator not backing up stock tune?????

Has anyone had this problem? I have talked to the owner before me and he bought the truck new, no tunes at all. No chips, or anything like that. ECM has never been changed, etc. The tuner will not save the stock tune. Called Diablo and talked to tech support, everything with model number, etc is correct. Was told another tune was on there, previous owner said there was not. I hate to spend 90.00 at the dealer to reflash stock and the tuner may give me the same problem then as well. What to do????
 
  #2  
Old 06-14-2008, 04:30 PM
V10'nr
V10'nr is offline
Junior User
Join Date: Sep 2006
Location: Canton,MI
Posts: 65
V10'nr is starting off with a positive reputation.
I would spend the $90 and try again. This way you can call the tech support people and tell them that it was reflashed, and you are still having the same problems.
 
  #3  
Old 06-16-2008, 07:03 PM
Heavy_Metal
Heavy_Metal is offline
Elder User
Join Date: May 2008
Posts: 559
Heavy_Metal is gaining momentum as a positive member of FTE.
Did you buy the diablo new?
 

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.