Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Replaced hydro-boost now have soft brakes

 
  #16  
Old 07-09-2019, 08:47 PM
'88 E-350
'88 E-350 is offline
Posting Guru
Join Date: Jul 2010
Location: Los Angeles, Ca.
Posts: 1,206
'88 E-350 has a very good reputation on FTE.'88 E-350 has a very good reputation on FTE.'88 E-350 has a very good reputation on FTE.
I've been a mechanic for decades and don't use any special tools or a helper to bleed brakes. Gravity is your friend, just gotta use it right. Once the master is bled by putting it at the right angle, the rest of the system will gravity bleed while you sip a congratulatory beer.
 
  #17  
Old 07-10-2019, 05:17 AM
jhobbs26
jhobbs26 is offline
Senior User
Thread Starter
Join Date: Jul 2004
Location: Halstead, KS
Posts: 172
jhobbs26 is starting off with a positive reputation.
i gravity bled to get the fluid started after replacing the rubber lines then proceded with a mightyvac. i'll give the LH side on a slope method a try. BTW, this is on my 08 6.4L, there just isn't as many people posting/replying on that forum so I asked over here, should have stated that first. I wasn't aware that you cannot remove the master out of the way on the 7.3 like you can on the 6.4. Sorry for some of the confusion.

*edit* I depressed the brake pedal with a 2x4 pressed against the seat to prevent continuous fluid flow while I was replacing the lines, removed the 2x4 gravity bled then used the mightyvac.
 
  #18  
Old 07-10-2019, 05:36 AM
FordTruckNoob's Avatar
FordTruckNoob
FordTruckNoob is online now
A Prairie Home PSD
Join Date: Jan 2005
Location: Eden Prairie, MN
Posts: 894
FordTruckNoob has a good reputation on FTE.FordTruckNoob has a good reputation on FTE.FordTruckNoob has a good reputation on FTE.
I don't know if it's the same on the '08 6.4 as the 99-04 7.3s but did you check the condition of the flex hose running from the frame to the top of the rear axle?
 
  #19  
Old 07-11-2019, 05:58 AM
jhobbs26
jhobbs26 is offline
Senior User
Thread Starter
Join Date: Jul 2004
Location: Halstead, KS
Posts: 172
jhobbs26 is starting off with a positive reputation.
Originally Posted by FordTruckNoob View Post
I don't know if it's the same on the '08 6.4 as the 99-04 7.3s but did you check the condition of the flex hose running from the frame to the top of the rear axle?

No, I plan on replacing the fronts and the one on top of the axle. I just replaced the rears because I knew the RR was bad by how it bled (or more like didn't bleed).

on a side note, I noticed my join date. July 18 2004. 15years ago. Man the knowledge I've gained from this site! love it.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.