Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

Oil leak 08 6.4

 
  #1  
Old 05-03-2019, 01:41 PM
lukekuldoxley
lukekuldoxley is offline
New User
Thread Starter
Join Date: May 2019
Posts: 4
lukekuldoxley is starting off with a positive reputation.
Oil leak 08 6.4






Anyone have any idea what itís caused from/where itís at?
 
  #2  
Old 05-03-2019, 01:43 PM
lukekuldoxley
lukekuldoxley is offline
New User
Thread Starter
Join Date: May 2019
Posts: 4
lukekuldoxley is starting off with a positive reputation.
The truck also smokes more than normal when it is cold started. Typically is white and sometimes has a tone of blue.
 
  #3  
Old 05-03-2019, 02:59 PM
DieselDenny
DieselDenny is offline
Posting Guru
Join Date: Nov 2005
Location: East Tawas, MI
Posts: 1,894
DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.
Take a gallon of simple green, scrub the crap out of the engine, let it dry, top off the oil. Afterwards, start her up and start searching from the bottom up until you find it. It's hard to diagnose a leak with a very wet and dirty engine. Could be several factors in play above the starter.

Denny
 
  #4  
Old 05-03-2019, 05:30 PM
lukekuldoxley
lukekuldoxley is offline
New User
Thread Starter
Join Date: May 2019
Posts: 4
lukekuldoxley is starting off with a positive reputation.
-

Anything on the smoking?
 
  #5  
Old 05-04-2019, 08:49 AM
Fefanatic
Fefanatic is offline
Elder User
Join Date: Jan 2016
Posts: 730
Fefanatic is starting off with a positive reputation.
If it's not burning all fuel when cold then that could be your smoke. White generally would be coolant. Are you losing coolant?
 
  #6  
Old 05-04-2019, 10:27 AM
lukekuldoxley
lukekuldoxley is offline
New User
Thread Starter
Join Date: May 2019
Posts: 4
lukekuldoxley is starting off with a positive reputation.
Originally Posted by Fefanatic View Post
If it's not burning all fuel when cold then that could be your smoke. White generally would be coolant. Are you losing coolant?
No, coolant level is good. I did some researching and it said possibly a bad injector? The truck only has 86,000 miles and had new turbos put on it 6,000 miles ago but has never had the injectors replaced. When itís started itíll start smoking real bad if I donít give it some gas and if I just let it idle itíll start running really rough and misfiring.
 
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: