Notices
2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

2010 EATC Fan and Other Issue

 
  #1  
Old 05-02-2019, 08:04 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
2010 EATC Fan and Other Issue

The EATC seems to be doing whatever it wants. With the system on (either auto or manual) the fan does not respond to the control. The graduated bars for fan speed do move, just no response in air flow. If you try to turn the system off, the fan kicks up to high and remains unresponsive to the control. If you turn the key off with the system in what should be off, it will remain off when you restart. It goes right back to acting up when you turn the system on. Thoughts?
 
  #2  
Old 05-03-2019, 11:32 AM
gwcloud
gwcloud is offline
Senior User
Join Date: May 2014
Posts: 188
gwcloud is starting off with a positive reputation.
The EATC will do a self test and display a trouble code. I don't remember which buttons and sequence to push them. However you can google it.
Good luck,
Richard
 
  #3  
Old 05-03-2019, 08:54 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
Thanks. I had tried that earlier, found a test that was supposed
to initiate by pushing off and defrost at the same
time, followed by auto that didn’t do anything. I’ll give it another look.
 
  #4  
Old 05-04-2019, 01:43 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
Got it to run diagnostics. All 8’s as the result so it doesn’t think anything is wrong. Fan speed control?
 
  #5  
Old 05-05-2019, 11:02 AM
gwcloud
gwcloud is offline
Senior User
Join Date: May 2014
Posts: 188
gwcloud is starting off with a positive reputation.
In my 2007 service manual wiring diagram it shows: An EATC module and a Heater Blower Control module
I don't know enough to say the problem is or is not the Fan Speed Control.
Your guess is as good as mine.
Good luck,
Richard
 
  #6  
Old 05-05-2019, 02:22 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
Thanks for looking. I suspect if it was the EATC module the self test would have found it, leaving the blower control. I am certainly open to more suggestions. Conveniently right next to this one in the garage is the other one, I can steal the part from there to test it. If this is it, they can be had on Amazon for $25 for an aftermarket part to $60 for the Motorcraft part.
 
  #7  
Old 05-05-2019, 05:19 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.
It was the blower control. Went with the $60 part. Had both out and swapped in 15 minutes, then back to their original positions.

For those following along who might have a similar problem, the control is Motorcraft part YH-1829 and it is located behind the right side of the glove box on the plenum. If you flip the glove box all the way open by moving it past it’s stops, it will be right in front of you. Two 8mm nuts and one electrical connector.
 
  #8  
Old 05-06-2019, 11:52 AM
gwcloud
gwcloud is offline
Senior User
Join Date: May 2014
Posts: 188
gwcloud is starting off with a positive reputation.
Congrats! Thanks for posting the fix.
I have learned a little more about my car from this.
I almost always use Motorcraft parts too.

Richard
 
  #9  
Old 05-08-2019, 07:41 PM
alwaysfords41's Avatar
alwaysfords41
alwaysfords41 is offline
Posting Guru
Thread Starter
Join Date: Feb 2008
Posts: 2,319
alwaysfords41 is gaining momentum as a positive member of FTE.alwaysfords41 is gaining momentum as a positive member of FTE.

It is the beige box you can just see through the lower corner of the glove box opening.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: