Notices
Transit Connect 2010+ Ford Transit Connect

Engine management light not coming on

 
  #1  
Old 04-14-2019, 11:39 AM
RiverTowy
RiverTowy is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 3
RiverTowy is starting off with a positive reputation.
Engine management light not coming on

2006 Connect T220L SWB 1.8 Diesel. No engine management light on when key turned in ignition on starting. It doesn't come on when there is a fault either, e.g. cooland sensor failure.
I have run the cluster self test and the EML does illuninate, so the LED is good. All other dials/guages/LEDS work fine.
 
  #2  
Old 04-15-2019, 02:17 AM
RiverTowy
RiverTowy is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 3
RiverTowy is starting off with a positive reputation.
It has been suggested on another forum, that the problem is probably a processor communication to the CEL fault/malfunction.


I cannot afford to pay £150+ to take it to a Ford garage to be put on a diagnostic tool.


How would I go about getting this investigated?
 
  #3  
Old 04-15-2019, 03:12 AM
seville009
seville009 is offline
Postmaster
Join Date: Nov 2004
Posts: 3,057
seville009 has a good reputation on FTE.seville009 has a good reputation on FTE.seville009 has a good reputation on FTE.
Sometimes you simply have to spend money if you need to get something done


on the other hand, if you donít have any actual problems other than the light itself, just leave it as is
 
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: