Notices
2015 + Expedition & Navigator 2015 + Ford Expedition and Lincoln Navigator

Rear AC not blowing cold

 
  #1  
Old 04-13-2019, 10:58 AM
Rdtay
Rdtay is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 4
Rdtay is starting off with a positive reputation.
Rear AC not blowing cold

First warm day here in VA and I turned on the AC. Front feels cold, maybe not ice cold but cold. Rear is definitely not refrigerated air. When I turn the rear temp up, it blows hot. But when I turn it to cold, it is just kinda warm. Any ideas before I head to the Ford dealer? 2017 Exped Limited with 58k miles. Out of warranty. Thanks
 
  #2  
Old 04-13-2019, 10:59 AM
alloro
alloro is offline
Post Fiend
Join Date: Apr 2008
Location: 0,0,1
Posts: 15,571
alloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud of
Is the compressor running constantly or is it going on and off?
 
  #3  
Old 04-13-2019, 11:24 AM
Rdtay
Rdtay is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 4
Rdtay is starting off with a positive reputation.
Originally Posted by alloro View Post
Is the compressor running constantly or is it going on and off?
I don't know. I will go check.
Thanks
 
  #4  
Old 04-13-2019, 11:34 AM
Rdtay
Rdtay is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 4
Rdtay is starting off with a positive reputation.
Originally Posted by alloro View Post
Is the compressor running constantly or is it going on and off?
The compressor is running constantly. I have it on Max AC. The front is alot colder than the rear, but the front doesn't seem as cold as I remember.
 
  #5  
Old 04-15-2019, 09:19 AM
alloro
alloro is offline
Post Fiend
Join Date: Apr 2008
Location: 0,0,1
Posts: 15,571
alloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud of
If the issue was with just the front or rear I would've said a blend door issue, but since the front and rear are both warmer than usual it's most likely the system needs a shot of refrigerant.
 
  #6  
Old 04-15-2019, 09:23 PM
Rdtay
Rdtay is offline
New User
Thread Starter
Join Date: Apr 2019
Posts: 4
Rdtay is starting off with a positive reputation.
Originally Posted by alloro View Post
If the issue was with just the front or rear I would've said a blend door issue, but since the front and rear are both warmer than usual it's most likely the system need a shot of refrigerant.
Ok, thank you. I will go for the recharge.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: