Notices
2017+ Super Duty The 2017+ Ford F250, F350, F450 and F550 Super Duty Pickup and Chassis Cab
Sponsored by:
Sponsored by:

NEED HELP- LED lights in bed not working

 
  #1  
Old 03-14-2019, 08:10 PM
enlogik's Avatar
enlogik
enlogik is offline
New User
Thread Starter
Join Date: Mar 2019
Location: Miami
Posts: 22
enlogik is starting off with a positive reputation.
NEED HELP- LED lights in bed not working

Hello Guys,

Installed some additional LED lights in the bed of my 2019 F250 today and tapped into the line that feeds one out of the two lights in the bed. They lit up and worked as normal via the factory switch and after some testing went ahead and started to permanently attach the led diodes while they were lit. After about 10 minutes they cut out and I can not figure out how to get them back on. Checked the manual for fuses etc... but still no luck. Note- the lights on the back of the cab overlooking the bed do work as normal via the switch.

Any help is much appreciated.
 
  #2  
Old 03-15-2019, 04:33 AM
kry226
kry226 is offline
Elder User
Join Date: Dec 2016
Location: Kentucky
Posts: 770
kry226 is starting off with a positive reputation.
I think your aftermarket LED lights are looking for 12v, but your OEM LED light circuit is only providing 6v, IIRC. Do a search as this has come up before.
 
  #3  
Old 03-15-2019, 07:15 AM
enlogik's Avatar
enlogik
enlogik is offline
New User
Thread Starter
Join Date: Mar 2019
Location: Miami
Posts: 22
enlogik is starting off with a positive reputation.
Thanks for the reply... At this point I just want to figure out how to get them back on? What did I blow and how do I find it?
 
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.