Go Back  Ford Truck Enthusiasts Forums > Diesel > 1994.5 - 1997 7.3L Power Stroke Diesel
Reload this Page >

Cruise control wont work.... again.

Notices
1994.5 - 1997 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Cruise control wont work.... again.

 
  #1  
Old 02-17-2019, 12:56 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
Cruise control wont work.... again.

Ok so where do i start with this stupid thing? 97 Obs extended cab 7.3 auto 4x4. Cruise stopped working. Checked fuses. Checked all lights. Now what?
 
  #2  
Old 02-17-2019, 01:28 PM
Hussler's Avatar
Hussler
Hussler is offline
Postmaster
Join Date: Sep 2007
Location: Medford Oregon
Posts: 4,109
Hussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to behold
What fixed it the first time? You indicated again.
 
  #3  
Old 02-17-2019, 01:31 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
First time was fuse #4 or 5 under the hood. Both light up as working when tested. Do you normally have a buzzer when you open the door with the key in or the light on?
 
  #4  
Old 02-17-2019, 01:47 PM
Hussler's Avatar
Hussler
Hussler is offline
Postmaster
Join Date: Sep 2007
Location: Medford Oregon
Posts: 4,109
Hussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to beholdHussler is a splendid one to behold
Yes, buzzer (chime) sounds with key in and door open or lights ON with key out and door open on my 97.
 
  #5  
Old 02-17-2019, 01:53 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
Originally Posted by Hussler View Post
Yes, buzzer (chime) sounds with key in and door open or lights ON with key out and door open on my 97.
interesting. Mine does not
 
  #6  
Old 02-17-2019, 02:28 PM
fordman67's Avatar
fordman67
fordman67 is offline
Post Fiend
Join Date: Dec 2005
Location: evansville in
Posts: 12,467
fordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to all
First thing is cruise deactivation switch on master. If that switch is "open" no cruise and they tend to be failure prone. Check inside switch connector on switch for brake fluid.. also do you have the recall harness at said deactivation switch?
do brake lights including third lamp operate?
 
  #7  
Old 02-17-2019, 02:30 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
My ebrake indicator light wont come on when iys engaged as well
 
  #8  
Old 02-17-2019, 02:35 PM
fordman67's Avatar
fordman67
fordman67 is offline
Post Fiend
Join Date: Dec 2005
Location: evansville in
Posts: 12,467
fordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to all
Mine has not worked either lol
 
  #9  
Old 02-17-2019, 02:37 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
Originally Posted by fordman67 View Post
First thing is cruise deactivation switch on master. If that switch is "open" no cruise and they tend to be failure prone. Check inside switch connector on switch for brake fluid.. also do you have the recall harness at said deactivation switch?
do brake lights including third lamp operate?
3rd brake lamp works. There is fluid in the switch connector at the mc
 
  #10  
Old 02-17-2019, 02:40 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.

 
  #11  
Old 02-17-2019, 02:41 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.

Lots of fluid
 
  #12  
Old 02-17-2019, 02:44 PM
fordman67's Avatar
fordman67
fordman67 is offline
Post Fiend
Join Date: Dec 2005
Location: evansville in
Posts: 12,467
fordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to allfordman67 is a name known to all
those harnesses have a fuse. When the switch gets wet that's what burned trucks down. Hence the jumper harness with fuse. I believe you have found your issue
 
  #13  
Old 02-17-2019, 02:44 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
Bumper side brake lights work as well
 
  #14  
Old 02-17-2019, 02:45 PM
97-psd's Avatar
97-psd
97-psd is offline
Posting Guru
Join Date: Mar 2007
Location: knoxville, tn
Posts: 2,003
97-psd has a good reputation on FTE.97-psd has a good reputation on FTE.
That one is broken.
 
  #15  
Old 02-17-2019, 02:47 PM
Ezalycasaid's Avatar
Ezalycasaid
Ezalycasaid is offline
Elder User
Thread Starter
Join Date: May 2015
Location: State of Delusion.
Posts: 673
Ezalycasaid is starting off with a positive reputation.
Originally Posted by fordman67 View Post
those harnesses have a fuse. When the switch gets wet that's what burned trucks down. Hence the jumper harness with fuse. I believe you have found your issue
Ok. So how do i go about fixing this? New harness (mine says there isnt a fuse in that harness.) Do i need a new switch since this ones leaking? Lol help me out here. Im about as electronics savvy as a cave man.
 

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: