Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

Roar from behind the dash at boost.

 
  #1  
Old 02-06-2019, 01:02 PM
Notthd's Avatar
Notthd
Notthd is offline
Junior User
Thread Starter
Join Date: Aug 2007
Posts: 55
Notthd is starting off with a positive reputation.
Roar from behind the dash at boost.

Hey all,
moved up into a new to me truck from a 6.0 to my 2008 F250. Love the truck, its EGR deleted, several up graded pipes, and chipped I assume because it builds up to 40PSI of boost if jumped on. I live in AZ and took it up skiing for the first time. Noticed 2 things, The heat started acting funny, would not blow hot or seem like in the right places. At the same time when on boost it sounded like a ton of air getting into the duct system.

Back home a couple of weeks and the roar is getting louder on boost. Still has power but had tripped up or lagged boost a couple of pulls with the camper. I'm heading out to mexico with the rig tomorrow and yesterday picking up the toy hauler has me concerned.

I figured I'd ask here so my search is purposeful under the hood tonight.

Any ideas?

Cheers, Mike
 
  #2  
Old 02-07-2019, 09:47 AM
speakerfritz's Avatar
speakerfritz
speakerfritz is online now
Postmaster
Join Date: Jul 2013
Posts: 4,514
speakerfritz has a good reputation on FTE.speakerfritz has a good reputation on FTE.
check all the intercooler air plumbing
 
  #3  
Old 02-08-2019, 12:59 PM
Notthd's Avatar
Notthd
Notthd is offline
Junior User
Thread Starter
Join Date: Aug 2007
Posts: 55
Notthd is starting off with a positive reputation.
First off thank you, Checked all the hoses for the intercooler and did not find any leaks or loose. Noticed Coolant low so topped it off, not sure if they are related. Decided to go for it. Pulled the hauler to Mexico 250 miles over the mountains. Made it just fine as far as pulling goes but up one hill when I pulled out to pass a slower motor home ,boost came up noise roared, ran fine but suddenly saw a hint of smoke coming from the dash around the glove bow and windshield vents on the passenger side. It had an odd smell, not like coolant nor oil burning. Not electrical also. I know what all those smell like.

Still a mystery, got off the gas, back to 1800 to 2000 rpms and 20lbs boost it stopped.

Thoughts?

Cheers, Mike
 
  #4  
Old 04-09-2019, 12:27 PM
Notthd's Avatar
Notthd
Notthd is offline
Junior User
Thread Starter
Join Date: Aug 2007
Posts: 55
Notthd is starting off with a positive reputation.
Found the issue returning home - A cracked crossover pipe from pass exhaust manifold to the turbo.

As the condition got worse the roar got louder and eventually started filling the cab with diesel smoke and sut. As the crack grew the turbo lost intake pressure and the ECU ran the motor very, very rich making coal smoke even stronger. I was not breaking down in mexico and ran it 75 miles to the border and across. This is what I found.

On the passenger side it melted everything plastic around and including the condenser for the AC (I assume that is what the black canister bolted to the firewall there is) And the plastic around the lines going through the firewall. I think this is how diesel smoke came into the cab.
The heat on the metal melted the evaporator assembly inside the cab. Once that happened anything smoke and sut wise that entered through the firewall would come out the ducts.

Some pics of under the hood and interior. I pulled back the carpet and removed the pass side wheel well and snapped these photos.








Hope this makes sense. Open for any ideas. I am taking out the glove box this week to peak under the dash, The cover for the fuse box melted some and you can see melted black plastic at the base of the pass side dash in the foot well.

Cheers, Mike
 
  #5  
Old 04-10-2019, 11:14 AM
73fan's Avatar
73fan
73fan is offline
Elder User
Join Date: Dec 2012
Location: Alberta
Posts: 947
73fan has a good reputation on FTE.73fan has a good reputation on FTE.
Wow, that is some serious damage!
 
  #6  
Old 04-10-2019, 01:05 PM
Notthd's Avatar
Notthd
Notthd is offline
Junior User
Thread Starter
Join Date: Aug 2007
Posts: 55
Notthd is starting off with a positive reputation.
Insurance Totaled the truck. I am going to replace the Evaporator assembly and attempt to get it clean. It still runs great. I've got over 10K in mods and a brand new less than 5K miles billet trans in the thing. Not to mention wheels and add ons. Did not want to let them take it. I'll post some of her restored when I get there....

Cheers, Mike
 
  #7  
Old 04-10-2019, 09:13 PM
Firefighter 1406's Avatar
Firefighter 1406
Firefighter 1406 is offline
Postmaster
Join Date: Mar 2004
Location: Northern Indiana
Posts: 4,904
Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.
Wow. As crazy as it sounds I think you were Lucky. I have heard of the same thing happening and it burning the truck to the ground. Look forward to seeing you get it back on the road.
 
  #8  
Old 05-09-2019, 10:16 AM
DieselDenny
DieselDenny is offline
Posting Guru
Join Date: Nov 2005
Location: East Tawas, MI
Posts: 1,892
DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.DieselDenny has a great reputation on FTE.
Mike what progress did you make, and what was the buy back price??

Denny
 
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: