2000 F350 V10 looses power after a few minutes of running - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > 1999 to 2016 Super Duty
Reload this Page >

2000 F350 V10 looses power after a few minutes of running

Notices
1999 to 2016 Super Duty 1999 to 2016 Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines

2000 F350 V10 looses power after a few minutes of running

 
  #1  
Old 01-21-2019, 03:38 PM
Dogukankubat
Dogukankubat is offline
New User
Thread Starter
Join Date: Jan 2019
Posts: 2
Dogukankubat is starting off with a positive reputation.
2000 F350 V10 looses power after a few minutes of running

Hey there!!

This is is my first time posting as I am a new member. I have several Ford trucks. 2000 F350 V10, 2005 F250 6.0, 2016 F250 6.2.

My 2000 F350 has only 44,000 miles. Bought it from a school that only used it to plow their parking lot. Since I purchased it, I have done a numerous things.

Recently the the truck started loosing power after running for a few minutes and being under load.

Things i have changed since it started:

Fuel pump
Fuel filter
Fuel tank (it needed to be changed)
TPS
Some older fuel lines
Air filter
checked and replaced non working coil packs
Even cracked the bolts on the converter and muffle as a buddy of mine said his plugged up once.

Still no luck... any recommendations?
 
  #2  
Old 01-21-2019, 04:47 PM
Colorado350's Avatar
Colorado350
Colorado350 is offline
Postmaster
Join Date: Nov 2015
Location: Colorado Springs
Posts: 2,948
Colorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to beholdColorado350 is a splendid one to behold
Welcome to FTE.

Do you have a fuel pressure gauge? Does it Idle fine then die when accelerating? Any codes?
 
  #3  
Old 01-21-2019, 04:58 PM
Dogukankubat
Dogukankubat is offline
New User
Thread Starter
Join Date: Jan 2019
Posts: 2
Dogukankubat is starting off with a positive reputation.
Thanks!!

I donít have a pressure gauge, I can say that when I turn the key to the ON position you hear the pump kick on. It idles perfectly fine. No codes
 

Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.