Heater not throwing much heat on 2015 Navigator - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2015 + Expedition & Navigator
Reload this Page >

Heater not throwing much heat on 2015 Navigator

Notices
2015 + Expedition & Navigator 2015 + Ford Expedition and Lincoln Navigator

Heater not throwing much heat on 2015 Navigator

  #1  
Old 12-15-2018, 08:27 AM
mbryson
mbryson is offline
Junior User
Thread Starter
Join Date: May 2005
Location: Woods Cross, UT (north of
Posts: 78
mbryson is starting off with a positive reputation.
Heater not throwing much heat on 2015 Navigator

We live in Utah and our recently purchased 40k mile Navigator is apparently not heating up enough in a 15-17 minute commute for the heater to give any semblance of heat. Iíll be confirming that in a few minutes with a test drive but was browsing the forums for any other issues. Doesnít seem like a common thing.

Anyone have issues with with how long the EB takes to give warmth to passengers?
 
  #2  
Old 12-15-2018, 12:18 PM
alloro
alloro is offline
Post Fiend
Join Date: Apr 2008
Location: 0,0,1
Posts: 15,267
alloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud of
Is the engine coming up the operating temperature and there's no heat, or is the engine still cold after the commute?
 
  #3  
Old 12-16-2018, 07:46 AM
mbryson
mbryson is offline
Junior User
Thread Starter
Join Date: May 2005
Location: Woods Cross, UT (north of
Posts: 78
mbryson is starting off with a positive reputation.
Originally Posted by alloro View Post
Is the engine coming up the operating temperature and there's no heat, or is the engine still cold after the commute?

it is coming up to operating temp. Turns out my coolant was a little over two quarts low. Iíll have to keep an eye on the ďwhyĒ part of that. Thatís a bit alarming to me on a 45k mile rig
 


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: