GP Resistance Ribbon Loose? - Ford Truck Enthusiasts Forums

Notices
Pre-Power Stroke Diesel (7.3L IDI & 6.9L) Diesel Topics Only

GP Resistance Ribbon Loose?

  #1  
Old 12-05-2018, 06:59 PM
crowandcactus
crowandcactus is offline
New User
Thread Starter
Join Date: Nov 2017
Posts: 9
crowandcactus is starting off with a positive reputation.
GP Resistance Ribbon Loose?

Been fighting my glow plug system since the beginning of man. Tried tightening nut on the Z shaped resistance arm and it just twisted around on meóthe nut is stuck on its post that comes up from the controller and itís loose enough to allow the Z arm to move when I try to tighten it. Can I test the resistance here to see if itís working somehow? Do I need to get this connection more secure or is it supposed to have give?

More fun issues: At the large + terminal (2 ylw wires) on GP selinoid my reading is about 2v less than battery poweróaround 10.4 when battery reads 12.6. Possible culprit? Problem? And smaller post reads same with key on. Do I have a draw?

Also just changed my GPs with an OEM set off ebay. Im getting resistance of around 7-8 ohms on these, but on the one ZD-9 I put in (stripped one OEM) itís more like .2. Are the OEMís just crappier? Are they crappier enough for me to want to change them out asap for all zd-9s? Am I so dumb and cheap that I need to overhaul my overhaul?

Some glorious day I will stop wrestling this issue, or learn to tackle it in the summer when my hands wont freeze to my ratchet. Until then, please help.
 
  #2  
Old 12-05-2018, 09:24 PM
PlumCrazy7
PlumCrazy7 is online now
Elder User
Join Date: Dec 2013
Posts: 803
PlumCrazy7 is gaining momentum as a positive member of FTE.
ZD-9/Beru plugs are the only oem. If they don't say Beru get rid of them.

Check the connection between the engine and fender, that plug is notorious for overheating, corroding, etc.

I would also replace the controller or rig up your own stud, a loose connection will have resistance all over the place.
 
  #3  
Old 12-07-2018, 06:15 AM
tjc transport's Avatar
tjc transport
tjc transport is offline
i ain't rite
Join Date: Mar 2005
Location: Marlboro Mental Hospital
Posts: 47,834
tjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputationtjc transport has a superb reputation
agreed. oem glow plugs are motorcraft/beru ZD-9's and the only ones to put in a ford 7.3 IDI .
if the stud in the controller is spinning so you can not tighten it up, my bet is the connection on the bottom inside the controller is broken off the stud and the controller will no longer work.
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.