2011 F250 6.2l stalls? - Ford Truck Enthusiasts Forums

Notices
1999 to 2016 Super Duty 1999 to 2016 Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines

2011 F250 6.2l stalls?

  #1  
Old 11-08-2018, 08:13 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
2011 F250 6.2l stalls?

Hello, i have been trying to fix a stalling issue with my truck for a few weeks now. If i disconect the battery for a while, the truck fires up and idles about 8 minutes and then dies immediately with no stumbling. After this happens its hard to start and takes many attempts. If i throttle it slightly i can keep it running and driving completely fine until i let off. No CEL or codes.
******THINGS I HAVE DONE ****
*PCM REPROGRAMMED
*ALL GROUNDS CLEANED
*ALL FUSES CHECKED
*FUEL PUMP RELAY REPLACED
*THROTTLE BODY CLEANED
*CANISTER PURGE VALVE SOLENOID
*REPLACED WIX OIL FILTER WITH MOTORCRAFT

ANY HELP OR IDEAS ARE GREATLY APPRECIATED
 
  #2  
Old 11-09-2018, 08:29 AM
99150's Avatar
99150
99150 is online now
Postmaster
Join Date: Oct 2006
Location: AZ
Posts: 3,483
99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation99150 has a superb reputation
Originally Posted by Plowtruck2011 View Post
Hello, i have been trying to fix a stalling issue with my truck for a few weeks now. If i disconect the battery for a while, the truck fires up and idles about 8 minutes and then dies immediately with no stumbling. After this happens its hard to start and takes many attempts. If i throttle it slightly i can keep it running and driving completely fine until i let off. No CEL or codes.
******THINGS I HAVE DONE ****
*PCM REPROGRAMMED
*ALL GROUNDS CLEANED
*ALL FUSES CHECKED
*FUEL PUMP RELAY REPLACED
*THROTTLE BODY CLEANED
*CANISTER PURGE VALVE SOLENOID
*REPLACED WIX OIL FILTER WITH MOTORCRAFT

ANY HELP OR IDEAS ARE GREATLY APPRECIATED
Just a guess here. What kind of pressure is your fuel pump putting out? Might need to check that, and see if it is in spec.
Now, I donít know what that is supposed to be.....naybe someone that knows can chime in here; or you can look up thespecs yourself and verify what you have.
Good luck.
 
  #3  
Old 11-09-2018, 12:36 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
Originally Posted by 99150 View Post

Just a guess here. What kind of pressure is your fuel pump putting out? Might need to check that, and see if it is in spec.
Now, I donít know what that is supposed to be.....naybe someone that knows can chime in here; or you can look up thespecs yourself and verify what you have.
Good luck.
I Don't see a test port anywhere, i must have to buy a special adapter. Thanks for the response

 
  #4  
Old 11-15-2018, 12:37 PM
hot.hogs
hot.hogs is offline
Freshman User
Join Date: Jul 2008
Posts: 49
hot.hogs is starting off with a positive reputation.
I had a similar issue a few years ago on my 2011, turned out to be a dirty MAF sensor. it would stall out at stop lights and be a pain to get restarted.
 
  #5  
Old 11-15-2018, 03:30 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
I did pull the MAF sensor and clean it but it is possible its not getting power
 
  #6  
Old 11-15-2018, 03:35 PM
Turk2k5's Avatar
Turk2k5
Turk2k5 is offline
New User
Join Date: Jul 2018
Posts: 13
Turk2k5 is starting off with a positive reputation.
Check your throttle position sensor. My old truck had this problem unless I was holding the gas down, it would stall. Its a cheap replacement part also.
 
  #7  
Old 11-17-2018, 11:28 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
Update





Truck no longer starts up. It will crank and stumble then all power shuts off once it fails to run. This happens every attempt to start. It will not continuously crank. I will try to attach pictures of engine dead live data pids i found suspicious
 
  #8  
Old 11-19-2018, 05:12 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
PCM nothing looks burnt or out of place. Going to save up for a PCM any how


 
  #9  
Old 11-19-2018, 07:36 PM
82_F100_300Six's Avatar
82_F100_300Six
82_F100_300Six is online now
Posting Guru
Join Date: Jun 2008
Posts: 2,345
82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.
I don't know much but it couldn't it be something simple like a MAP (MAF?) sensor or a throttle body part?
 
  #10  
Old 11-19-2018, 08:00 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
I have completely rebuilt the throttle body, even after my scanner shows it responding fine. The maf sensor is clean has voltage and is responsive to air flow even on the limited cranking.
However i did find many of my relays and power distribution box very coroded. Cleaned what i could as i cant find a replacement even online.
 
  #11  
Old 11-19-2018, 08:22 PM
82_F100_300Six's Avatar
82_F100_300Six
82_F100_300Six is online now
Posting Guru
Join Date: Jun 2008
Posts: 2,345
82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.82_F100_300Six has a very good reputation on FTE.
Sounds like you are definitely on top of it so good luck. I'm wanting to buy a high mileage 11-16 gasser and I'm starting to realize they all may have some issues to deal with.
 
  #12  
Old 11-19-2018, 08:34 PM
Plowtruck2011
Plowtruck2011 is offline
New User
Thread Starter
Join Date: Nov 2018
Posts: 9
Plowtruck2011 is starting off with a positive reputation.
Thanks , yeah mine is at 152k and had the living **** kicked out of it plowing and being used for a railway. The 6.2l with the torque shift 6 is mechanically very tough. When mine ran it was smooth and shifted like day one. And im telling you it was driven VERY HARD. But always had electrical related issues since day one. Almost killed me and other co workers on many occasions when it would die driving along cliff sides.
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.