Go Back  Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > 2017+ Super Duty
Reload this Page >

Service AdvanceTrac, Hill Start Assist Not Available and Hill Descent Control Fault messages.

Notices
2017+ Super Duty The 2017+ Ford F250, F350, F450 and F550 Super Duty Pickup and Chassis Cab
Sponsored by:
Sponsored by:

Service AdvanceTrac, Hill Start Assist Not Available and Hill Descent Control Fault messages.

 
  #31  
Old 03-14-2019, 03:54 PM
swlakingranch's Avatar
swlakingranch
swlakingranch is offline
Senior User
Thread Starter
Join Date: Aug 2017
Location: Sulphur, La
Posts: 184
swlakingranch is starting off with a positive reputation.
Originally Posted by soonerstroker View Post
I'm having the same issues. Did the Pittman nut solve your problem?
Yes. The light has not come on since I replaced the nut
 
  #32  
Old 03-14-2019, 04:11 PM
Lumberman12
Lumberman12 is offline
Freshman User
Join Date: Jan 2014
Posts: 48
Lumberman12 is starting off with a positive reputation.
My 18' srw 350 did the same thing , I had a ready lift sst lift put on and after taking it back several times ,replacing the steering sensor in the column, ended up being the traction bar bracket that was put on wasn't tighten and had worked loose !!
 
  #33  
Old 03-14-2019, 06:35 PM
billybadd
billybadd is offline
New User
Join Date: Jan 2009
Posts: 22
billybadd is starting off with a positive reputation.
My issue was loose pinch bolts on my bds track bar.
 
  #34  
Old 03-14-2019, 08:58 PM
soonerstroker
soonerstroker is offline
Freshman User
Join Date: Nov 2017
Posts: 34
soonerstroker is starting off with a positive reputation.
Has anyone ever had this problem? After my lift the steering wheel was turned to the right so I figured I'd get an alignment and straighten out the steering wheel But I noticed the following if I made a left hand turn then the wheel would be off to the left and when I made a right hand turn then the steering wheel would straighten out. I guess I 'll find out more this weekend.
 
  #35  
Old 03-15-2019, 07:27 AM
Spoojr
Spoojr is online now
Senior User
Join Date: Sep 2016
Posts: 225
Spoojr is starting off with a positive reputation.
I have had the service advance trac and hill descent control fault messages popping up about once a month. As I hit ok to clear them, they go away. A couple time I also got the collision assistance fault and adaptive cruise faults in conjunction, and those wouldnít go away without a restart.

My truck is completely stock, so I donít know what could be causing it. Iíve already added electrical grease to all the plugs referenced earlier, and no corrosion or water intrusion were seen. The truck doesnít save any fault codes for the dealer either. The next time it happens, I plan on driving to the dealer while the faults are present to see if that helps.

It is pretty frustrating, but I suppose this is the penance you pay for a fully electronic vehicle. I would love to find the resolution. I may crawl under and look for loose steering parts as described by others.
 
  #36  
Old 03-17-2019, 10:13 PM
Spoojr
Spoojr is online now
Senior User
Join Date: Sep 2016
Posts: 225
Spoojr is starting off with a positive reputation.
Errors popped again today, but this time added pre-collision avoidance fault and advance trac light stayed on until restart. Couldnít take it to the dealer with it being Sunday...of course. Iíve been making a note of when it happens, as well as the time and weather to see if I can find a common theme. Itís a pain to drop it off at the dealer and they say there are no codes and they canít duplicate it. At least itís in the service notes I suppose, so when the truck is out of warranty and the part causing the problem finally fails completely, maybe it will be covered.
 
  #37  
Old 03-20-2019, 04:48 AM
flumpydog
flumpydog is offline
Junior User
Join Date: Nov 2018
Posts: 83
flumpydog is starting off with a positive reputation.
Originally Posted by Spoojr View Post
Errors popped again today, but this time added pre-collision avoidance fault and advance trac light stayed on until restart. Couldnít take it to the dealer with it being Sunday...of course. Iíve been making a note of when it happens, as well as the time and weather to see if I can find a common theme. Itís a pain to drop it off at the dealer and they say there are no codes and they canít duplicate it. At least itís in the service notes I suppose, so when the truck is out of warranty and the part causing the problem finally fails completely, maybe it will be covered.
I had all these same issues and am still dealing with the fallout. In my case, the main wiring harness 20 pin connector, located at the back of the truck, up beside the spare tire, had water intrusion and was all corroded. This caused just about every system on the truck to do something funky, it was crazy, and and still dealing with it with my dealer.
 
  #38  
Old 03-20-2019, 09:07 AM
Spoojr
Spoojr is online now
Senior User
Join Date: Sep 2016
Posts: 225
Spoojr is starting off with a positive reputation.
Thatís a real bummer. That 20 pin connector on my truck is dry as a bone with zero corrosion. Iím at a complete loss.
 
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.