6.7 Hard start/no throttle issues - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Reload this Page >

6.7 Hard start/no throttle issues

Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

6.7 Hard start/no throttle issues

  #1  
Old 06-13-2018, 08:45 PM
VALLEYPOWERSTROKES
VALLEYPOWERSTROKES is offline
New User
Thread Starter
Join Date: Jun 2018
Posts: 7
VALLEYPOWERSTROKES is starting off with a positive reputation.
6.7 Hard start/no throttle issues

2008 F350 6.7L came to me with a shop telling the customer it needs a new engine. I turned the engine over and heard a knocking from the passenger side of the engine. Pulled the valve cover and found number 3 exhaust rocker ball retainer broke and the rocker was causing the knocking noise. I inspected the other rockers/pushrods etc.. and replaced #3 exhaust rocker, pushrod, plastic retainer and rocker bridge. I tried to start it after the repair and it was still hard start long crank. When it would start there was no throttle. Rail pressure was 5000-6000psi at idle and low pressure fuel psi at the fuel cooler was 7psi. Fuel trim for 5 of the 8 injectors were -15 to -30. I pulled all 8 injectors and found #3 injector tip looked like something smooshed the nipple at the end of the nozzle.
I replaced all 8 injectors and fuel lines. Bled the air out of the fuel and tried to start it. Same thing, no throttle response and it runs like its not getting fuel. I pulled the EGR valve and the truck smokes like its on fire but I have throttle response and it actually runs decent. I tested the EGR valve from 0% to 100% with scan tool and it opens and closes all the way when commanded. EBP sensor read 14.5psi and desired EBP was only 5. So I removed sensor and tube and cleaned it out, then reinstalled. Same symptoms. Any Ideas? DPF is deleted. The driver drove the truck with lack of power until they lost throttle response then took it to a shop. ANy Ideas on where to look next? Im stumped! Why does it run so well with the egr valve removed?
 
  #2  
Old 06-13-2018, 11:13 PM
VALLEYPOWERSTROKES
VALLEYPOWERSTROKES is offline
New User
Thread Starter
Join Date: Jun 2018
Posts: 7
VALLEYPOWERSTROKES is starting off with a positive reputation.
Got a code for number 3 glow plug. I should probably pull that plug. I wonder if thats what hit my injector, a piece of that glow plug. Still doesn't explain why the engine wont run worth a heck.
 
  #3  
Old 06-14-2018, 09:22 AM
Rudiak
Rudiak is offline
Senior User
Join Date: Mar 2010
Location: Atlanta
Posts: 351
Rudiak is starting off with a positive reputation.
Are you sure it's a 6.7? The 2008 came with a 6.4.
 
  #4  
Old 06-14-2018, 09:25 AM
VALLEYPOWERSTROKES
VALLEYPOWERSTROKES is offline
New User
Thread Starter
Join Date: Jun 2018
Posts: 7
VALLEYPOWERSTROKES is starting off with a positive reputation.
Haha I meant 6.4. Thanks.

Im gonna check for exhaust restriction this morning. I dont remember seeing any smoke out the tailpipe. This truck has been one thing after another. I guess thats what happens when you run something til it quits.
 
  #5  
Old 06-14-2018, 12:11 PM
speakerfritz's Avatar
speakerfritz
speakerfritz is offline
Postmaster
Join Date: Jul 2013
Posts: 3,778
speakerfritz has a good reputation on FTE.speakerfritz has a good reputation on FTE.
Originally Posted by VALLEYPOWERSTROKES View Post
2008 F350 6.7L came to me with a shop telling the customer it needs a new engine. I turned the engine over and heard a knocking from the passenger side of the engine. Pulled the valve cover and found number 3 exhaust rocker ball retainer broke and the rocker was causing the knocking noise. I inspected the other rockers/pushrods etc.. and replaced #3 exhaust rocker, pushrod, plastic retainer and rocker bridge. I tried to start it after the repair and it was still hard start long crank. When it would start there was no throttle. Rail pressure was 5000-6000psi at idle and low pressure fuel psi at the fuel cooler was 7psi. Fuel trim for 5 of the 8 injectors were -15 to -30. I pulled all 8 injectors and found #3 injector tip looked like something smooshed the nipple at the end of the nozzle.
I replaced all 8 injectors and fuel lines. Bled the air out of the fuel and tried to start it. Same thing, no throttle response and it runs like its not getting fuel. I pulled the EGR valve and the truck smokes like its on fire but I have throttle response and it actually runs decent. I tested the EGR valve from 0% to 100% with scan tool and it opens and closes all the way when commanded. EBP sensor read 14.5psi and desired EBP was only 5. So I removed sensor and tube and cleaned it out, then reinstalled. Same symptoms. Any Ideas? DPF is deleted. The driver drove the truck with lack of power until they lost throttle response then took it to a shop. ANy Ideas on where to look next? Im stumped! Why does it run so well with the egr valve removed?
did you check rocker push rods to see if they were bent?

how is the oil level....the correct check is a mid way on the guage...seeing a full oil guage becusse the oil covers everything is misleading. Wipe the dip stick down a check a few times by backing out the dip stick a few inches.

your power problems has all the indications of diluted oil which is now overfilled.

 
  #6  
Old 06-14-2018, 02:09 PM
73F700's Avatar
73F700
73F700 is offline
Senior User
Join Date: Dec 2017
Location: Ontario, Canada
Posts: 296
73F700 is gaining momentum as a positive member of FTE.73F700 is gaining momentum as a positive member of FTE.
It runs better with the EGR valve removed... This does two things, open up the exhaust and the intake. If the exhaust has been deleted I would focus on the intake. I assume you have already covered the filter. Open the lower intercooler boot close to the rad - see what you find. Should be dry, could be full of oil.

EBP of 14.5 psi is normal I think as the sensor isn't calibrated to your atmospheric pressure.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fludoc
1999 - 2003 7.3L Power Stroke Diesel
2
04-19-2015 03:17 PM
towelcam
6.0L Power Stroke Diesel
4
10-30-2012 09:28 PM
Derrick Moore
6.0L Power Stroke Diesel
24
08-20-2011 12:21 PM
nascar88ford
2004 - 2008 F150
1
10-29-2009 11:51 PM
explorerdad
Explorer, Sport Trac, Mountaineer & Aviator
1
09-05-2001 06:39 PM


Thread Tools
Search this Thread
Quick Reply: 6.7 Hard start/no throttle issues


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: