1990 E350 cruise control switches? - Ford Truck Enthusiasts Forums

Notices
1968-2013 Full Size Vans Econolines. E150, E250, E350, E450 and E550

1990 E350 cruise control switches?

Reply

 
 
 
  #1  
Old 06-12-2018, 09:41 PM
Maillemaker
Maillemaker is online now
Freshman User
Thread Starter
Join Date: Jan 2013
Posts: 29
Maillemaker is starting off with a positive reputation.
1990 E350 cruise control switches?

My mechanic says the reason my cruise control is not working is due to the switches in the steering wheel. Anyone know where I can obtain those? Or a complete steering wheel?

Steve
 
Reply With Quote
  #2  
Old 06-16-2018, 08:42 PM
NumberDummy's Avatar
NumberDummy
NumberDummy is online now
Ford Parts Specialist
Join Date: Nov 2006
Location: Simi Valley, CA
Posts: 77,117
NumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputationNumberDummy has a superb reputation
Originally Posted by Maillemaker View Post
My mechanic says the reason my cruise control is not working is due to the switches in the steering wheel. Anyone know where I can obtain those? Or a complete steering wheel?

Steve
Speed Control switch only furnished with horn pad.
 
Reply With Quote
  #3  
Old Yesterday, 05:35 PM
frenchie9
frenchie9 is offline
New User
Join Date: Jan 2016
Posts: 9
frenchie9 is starting off with a positive reputation.
if this can be of any help, mine is a 1998 and cruise cnt. doesn't work, and the reason is clock spring. I guess your horn doesn't work either ???
 
Reply With Quote
  #4  
Old Yesterday, 08:50 PM
Maillemaker
Maillemaker is online now
Freshman User
Thread Starter
Join Date: Jan 2013
Posts: 29
Maillemaker is starting off with a positive reputation.
Horn works fine. I initially discovered that the braided cable crimp bead had come off on one end of the assembly. I replaced the braided cable and re-crimped it, but still no cruise. Mechanic says the problem is in the switches in the steering wheel, but I do not know exactly where the fault might be. I guess I need to disassemble the steering wheel and do some troubleshooting.

Steve
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.