2008 F350 6.4 Diesel EGR delete chipped. - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Reload this Page >

2008 F350 6.4 Diesel EGR delete chipped.

Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

2008 F350 6.4 Diesel EGR delete chipped.

  #1  
Old 05-16-2018, 02:37 PM
Mulsanne
Mulsanne is offline
New User
Thread Starter
Join Date: May 2018
Posts: 4
Mulsanne is starting off with a positive reputation.
2008 F350 6.4 Diesel EGR delete chipped.

Driving on a hot day and cruising around 70mph, the coolant temp gauge goes to hot and reduced power message is displayed. If I sit off road in park, with the motor running the gauge returns fairly quickly (you can see the needle fall) to normal and the trunk drives well again. The engine temperature does not appear hot nor has it puked out any coolant. I changed the thermostats with no change. The coolant level is correct and the fan is turning.

Can anyone help?

Thank you, Martyn
 
  #2  
Old 05-16-2018, 05:02 PM
Firefighter 1406's Avatar
Firefighter 1406
Firefighter 1406 is offline
Postmaster
Join Date: Mar 2004
Location: Northern Indiana
Posts: 4,712
Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.Firefighter 1406 has a great reputation on FTE.
Possibly bad thermostats. Seems like I have read about them over extending I think. Which can cause over heating issues. Just a thought.
 
  #3  
Old 05-16-2018, 05:09 PM
Mulsanne
Mulsanne is offline
New User
Thread Starter
Join Date: May 2018
Posts: 4
Mulsanne is starting off with a positive reputation.
Originally Posted by Mulsanne View Post
Driving on a hot day and cruising around 70mph, the coolant temp gauge goes to hot and reduced power message is displayed. If I sit off road in park, with the motor running the gauge returns fairly quickly (you can see the needle fall) to normal and the trunk drives well again. The engine temperature does not appear hot nor has it puked out any coolant. I changed the thermostats with no change. The coolant level is correct and the fan is turning.

Can anyone help?

Thank you, Martyn
As a footnote to the above, I took the truck on a road test with a SnapOn scanner plugged in. When the fault occurred, the readings for the water temp were 197 and didn't move and the oil temp was 259 and steady. There were no codes stored, nor did it show a code with the fault.

Martyn
 
  #4  
Old 05-16-2018, 08:26 PM
JoshC017's Avatar
JoshC017
JoshC017 is offline
Senior User
Join Date: Jun 2016
Posts: 235
JoshC017 is starting off with a positive reputation.
Your oil cooler is plugged up. At 259* on the oil, you're waaaaaaay out of spec. Anything about 20* above coolant temp is bad. You need to get that looked at asap.
 
  #5  
Old 05-17-2018, 09:11 AM
speakerfritz's Avatar
speakerfritz
speakerfritz is offline
Postmaster
Join Date: Jul 2013
Posts: 3,791
speakerfritz has a good reputation on FTE.speakerfritz has a good reputation on FTE.
and what are the codes that were pulled from the odbc port?
 
  #6  
Old 05-17-2018, 09:39 AM
Mulsanne
Mulsanne is offline
New User
Thread Starter
Join Date: May 2018
Posts: 4
Mulsanne is starting off with a positive reputation.
Thanks Speakerfritz and JoshCO17

There were no codes for some reason and I have taken the truck in to get the oil cooler sorted. I had previously changed the thermostats thinking that it was the coolant temp that was causing the issue. I didn't realize that the oil temp triggered the gauge on the dash.

Thanks Guys for your input and will keep you posted as to the results.

Martyn
 
  #7  
Old 05-19-2018, 05:11 PM
JoshC017's Avatar
JoshC017
JoshC017 is offline
Senior User
Join Date: Jun 2016
Posts: 235
JoshC017 is starting off with a positive reputation.
I had a 6.0 that I just got rid of that did the same thing last summer. Cruising along pulling the camper and boom, all the sudden the dash starts beeping at me and the coolant temp gauge goes from normal to max in an instant. Later discovered that it was my oil cooler. Good luck with the fix. Report back when you get some good numbers.
 
  #8  
Old 05-22-2018, 11:12 AM
Mulsanne
Mulsanne is offline
New User
Thread Starter
Join Date: May 2018
Posts: 4
Mulsanne is starting off with a positive reputation.
Thanks Guys

I'll report back with the news.

Martyn
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Musher
6.4L Power Stroke Diesel
6
12-28-2016 09:54 PM
BillyBoo
General Diesel Discussion
2
04-13-2015 10:43 PM
newbie250
1999 to 2016 Super Duty
2
12-08-2013 12:15 PM
BobsF350
6.0L Power Stroke Diesel
0
01-23-2008 07:38 PM
eric777
6.0L Power Stroke Diesel
12
01-17-2008 10:06 PM


Thread Tools
Search this Thread
Quick Reply: 2008 F350 6.4 Diesel EGR delete chipped.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: