NEWB with a 3.8l V6 - Ford Truck Enthusiasts Forums

Notices

NEWB with a 3.8l V6

 
  #1  
Old 04-14-2018, 04:25 PM
dziwei
dziwei is offline
Senior User
Thread Starter
Join Date: Jun 2017
Posts: 281
dziwei is starting off with a positive reputation.
NEWB with a 3.8l V6

Working on a 2000 Windstar, vehicle has run for years with only putting in fluids, filters and plugs. Just a grocery getter really but never hesitated to take it out of town with 4ppl & weekend bags and it does great.

It has run rough intermittently for years, every 3rd week or so it would threaten to stall at a stop light. Last winter it would idle rough here and there and threaten to stall most days. Now that the warm weather is here its not improved (not really any worse after running like this for six months though either).

Help! I usually would try some simple stuff (fresh fuel filter, look at the plugs, air filter, etc.) but all that was done end of last summer...

Any ideas would be greatly appreciated! If this is off topic (not performance related) is there a forum I missed that could help?


THANKS
 
  #2  
Old 02-02-2019, 11:24 PM
dziwei
dziwei is offline
Senior User
Thread Starter
Join Date: Jun 2017
Posts: 281
dziwei is starting off with a positive reputation.
UPDATE: Eventually got misfire codes on a single cylinder (scanner did not report that in the previous year of stumbles) and that plug was significantly worse than others (all the same age), replacing the plug helped right away but only for a few drives and then misfires and rough idling would occur several times if you drove for 20 mins. Changed out the wire for a known good wire but no change. Finally guessed it might be a bad injector and ordered one and put it in, that has made it idle smooth and no more misfires for 2 weeks now. Strange that the symptoms were so intermittent with a bad injector, on some days it would drive back and forth to the supermarket without a hiccup...
 
  #3  
Old 02-05-2019, 12:33 AM
Fifty150's Avatar
Fifty150
Fifty150 is offline
Elder User
Join Date: Oct 2007
Posts: 623
Fifty150 has a good reputation on FTE.Fifty150 has a good reputation on FTE.Fifty150 has a good reputation on FTE.
Almost a year went by, and nobody responded to your initial post. I can only guess that nobody owns a 2000 Freestar anymore. Except for you. As for maintenance, you might want to replace all of those plugs, since Ford MotorCraft plugs are inexpensive. Get a set of new wires. Maybe replace the ignition coil. I've also heard that Techron or Lucas Oil may help with cleaning out all those years of buildup. It's almost 20 years old & still running. Good for you.
 
  #4  
Old 02-05-2019, 08:24 AM
70f100longbed's Avatar
70f100longbed
70f100longbed is offline
Posting Guru
Join Date: Aug 2002
Location: Raleigh USA
Posts: 1,603
70f100longbed has a great reputation on FTE.70f100longbed has a great reputation on FTE.70f100longbed has a great reputation on FTE.70f100longbed has a great reputation on FTE.
I had a 2000 Windstar. The EGR ports are bad for clogging 4-5 of them and leaning out the other cylinder causing a misfire. Also the upper intake gaskets and isolator bolts fail and cause lean codes.
 
  #5  
Old 02-23-2019, 01:14 PM
dziwei
dziwei is offline
Senior User
Thread Starter
Join Date: Jun 2017
Posts: 281
dziwei is starting off with a positive reputation.
Thanks ppl. All good advice! I had done the upper intake gaskets and bolts per a TSB to see if that was causing me trouble, the ports were black & shiny but not clogged, also did the valve cover & valve/tube that go into it PCV? (can't remember what its called) per another TSB. The plugs look good now (a month or so) and with the new injector it runs as good as before. 17mpg mixed 200mi of driving. I hate to get rid of a car that starts every damn time in all weather and has never left me on the side of the road but as you mention 'It's 20yrs old" hehe.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kmnremtp
New Member Introductions
3
07-30-2013 05:24 PM
fatnbald1
Audio & Video Systems, Navigation, Satellite Radio & Mobile Electronics
8
07-31-2003 07:53 PM
AlabamaBronco
Audio & Video Systems, Navigation, Satellite Radio & Mobile Electronics
6
05-29-2003 01:50 PM
hossman77
New Member Introductions
3
04-14-2003 12:42 AM
DSMonster
New Member Introductions
2
03-27-2003 06:09 PM


Thread Tools
Search this Thread
Quick Reply: NEWB with a 3.8l V6


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.