Early 99 7.3 No low end torque. - Ford Truck Enthusiasts Forums

Notices
1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Early 99 7.3 No low end torque.

Reply

 
 
 
  #1  
Old 03-19-2018, 10:43 AM
Early99_7.3
Early99_7.3 is offline
New User
Thread Starter
Join Date: Mar 2018
Posts: 16
Early99_7.3 is starting off with a positive reputation.
Early 99 7.3 No low end torque.

I have a Early 99 7.3, has 230,000 miles on it which I had bought with 215k on it and from the original owner everything stock. Since Iíve had it 3 years now, I have put 4in exhaust straight back along with the 4 in downpipe, new exhaust manifolds, new HPOP, new IPR, all reman AB injectors, new UVCH and glow plugs, new ICP Sensor, new EBPS and tube. Oil is motorcraft 10w 30 since itís winter here in Michigan, has new fuel filter and fuel pump, brand new sending unit in tank and filters also, high flow fittings in the heads and have changed the transmission fluid in the 4r100 3 times now always clean and put a new accumulator valve body in. Has new turbo with wicked wheel 2 and al new silicon on tubes.
Problem im having is the truck has no torque at all, it will get up in the high rpm range but just has no power to the road and about 10 times worse with my 9k lb fifth wheel behind it. Truck will hold up hill about 55mph at almost 3k rpm towing soon as you crest the hill Iíll be doing 25mph rpm will start dropping off and sometimes it will lug the trans. Now Iíve changed up pipes and seals 3 times now and it says under a load Iím getting 68 psi fuel pressure, I have no codes and no flashing from the stick either. If truck is in stock mode it constantly downshifts but on 80hp tune or 120hp tune it seems to not as much or at all. Injectors are extremely loud as well more then any of my friends with the same truck so Iím not sure if this is FUEL related or transmission related any light on this would be appreciated.
 
Reply With Quote
  #2  
Old 03-19-2018, 11:24 AM
StrokinHer01's Avatar
StrokinHer01
StrokinHer01 is offline
Senior User
Join Date: Jan 2018
Posts: 301
StrokinHer01 is starting off with a positive reputation.
I can tell you you would get way more knowledge and responses in the 7.3 forums.. some of us drift over here every now and then but youíre best off relocating this thread there
 
Reply With Quote
  #3  
Old 03-19-2018, 12:09 PM
redford's Avatar
redford
redford is offline
Moderator
Join Date: Sep 2000
Location: Stephensville WI
Posts: 19,043
redford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputationredford has a superb reputation
Moved to 7.3L PSD forum.
 
Reply With Quote
  #4  
Old 03-19-2018, 12:13 PM
AllaboutMPG's Avatar
AllaboutMPG
AllaboutMPG is offline
Postmaster
Join Date: Oct 2011
Location: Locust Grove, GA
Posts: 2,562
AllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to behold
What kind of air filter are you running? Are you seeing lots of black smoke? Are you monitoring EGT's? What tuner are you running?
 
Reply With Quote
  #5  
Old 03-19-2018, 12:18 PM
Jaime74656's Avatar
Jaime74656
Jaime74656 is offline
Another cautionary tale
Join Date: Apr 2011
Location: Lexington
Posts: 4,492
Jaime74656 is a name known to allJaime74656 is a name known to allJaime74656 is a name known to allJaime74656 is a name known to allJaime74656 is a name known to allJaime74656 is a name known to all
Sounds like you have a gear set that is too large, sounds almost like to large of a gear ratio, as for the loud part Hutch and harpoon the tank should help quiet things down some, also I think for #8 cylinder you should have an ab or ad (I canít remember what it was) the rest shou be different as #8 is a long lead
 
Reply With Quote
  #6  
Old 03-19-2018, 12:24 PM
SaintITC
SaintITC is offline
Posting Guru
Join Date: Jul 2003
Location: Springfield, PA
Posts: 1,153
SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.
Can you measure boost, or is there a boost fooler on it or in the tunes? Not sure if a 120HP tune truly exists for stock equipment and AB injectors - injectors just aren't capable of it. Otherwise if you can use Torque Pro or such to give us actual data while climbing the hill, that would me much more helpful.
 
Reply With Quote
  #7  
Old 03-19-2018, 12:25 PM
SaintITC
SaintITC is offline
Posting Guru
Join Date: Jul 2003
Location: Springfield, PA
Posts: 1,153
SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.SaintITC has a great reputation on FTE.
On an e99, the #8 would only have been switched out for a long lead if done as part of a TSB and customer complaint for noise. In which case it would be an AF.
 
Reply With Quote
  #8  
Old 03-19-2018, 04:51 PM
Colorado350's Avatar
Colorado350
Colorado350 is offline
Posting Guru
Join Date: Nov 2015
Location: Colorado Springs
Posts: 1,332
Colorado350 has a great reputation on FTE.Colorado350 has a great reputation on FTE.Colorado350 has a great reputation on FTE.Colorado350 has a great reputation on FTE.Colorado350 has a great reputation on FTE.
Is your torque converter locking up?
 
Reply With Quote
  #9  
Old 03-19-2018, 05:48 PM
Early99_7.3
Early99_7.3 is offline
New User
Thread Starter
Join Date: Mar 2018
Posts: 16
Early99_7.3 is starting off with a positive reputation.
First of all thank you for moving me to the 7.3 section kinda new to this site. I know I need to EGT gauge I do have a boost gauge and cruising on flat ground I am hitting around 4 pounds of boost at 55 to 60mph. I do have a mechanical wastegate and also have a boost fuller but havenít really needed to use it, if Iím on 120 HP tune and punch it it will max out around 30 psi boost . Gearing in the truck is 373 gears and while watching the torque converter it really doesnít slip past 10 rpm when locked Not sure on the towing if itís slipping I have not monitored that yet fluid is always bright red and sweet smelling so itís not burnt but I can never really get the truck to ever smoke black at all even on 140 setting is just a little Haye not sure on the towing if itís slipping I have not monitor that yet fluid is always bright red and sweet smelling so itís not burnt but I can never really get the truck to ever smoke black at all even on 140 setting is just a little Hazz which worries me if maybe Iím not getting enough fuel even though Iíve redone the whole fuel system. For a chip I am using a power hungry performance at hydra chip.
 
Reply With Quote
  #10  
Old 03-19-2018, 06:39 PM
Early99_7.3
Early99_7.3 is offline
New User
Thread Starter
Join Date: Mar 2018
Posts: 16
Early99_7.3 is starting off with a positive reputation.
Truck seems to knock louder on the passenger side and when the converter does lock it does not seem like there is much pull. If it downshifts in stock mode on a hill there is no speed gain and if I put it to the floor itís a slow rise in speed. I even changed the TPS still no change, this had me so confused and have been fighting this for 2 years and have had it to 4 shops with no answers. I hate to give up on it since of always wanted a 7.3.
 
Reply With Quote
  #11  
Old 03-19-2018, 06:41 PM
AllaboutMPG's Avatar
AllaboutMPG
AllaboutMPG is offline
Postmaster
Join Date: Oct 2011
Location: Locust Grove, GA
Posts: 2,562
AllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to beholdAllaboutMPG is a splendid one to behold
Have you ever done a compression test?
 
Reply With Quote
  #12  
Old 03-19-2018, 06:54 PM
Walleye Hunter
Walleye Hunter is online now
Postmaster
Join Date: Mar 2014
Location: Douglassville, PA
Posts: 4,483
Walleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to all
Have you tried removing the chip and seeing how it acts? It could be in the tuning.
 
Reply With Quote
  #13  
Old 03-19-2018, 07:19 PM
Early99_7.3
Early99_7.3 is offline
New User
Thread Starter
Join Date: Mar 2018
Posts: 16
Early99_7.3 is starting off with a positive reputation.
The injectors quite down a bit on stock setting just absolutely no power and constantly downshifting and as for a compression test no. I had a shop do a realitive compression test and they said it was great and there was no reason to do a mechanical test. There is no pressure from the oil cap and no thump from the intake. One last weird thing is with doing a boost leak test and pressuring the system I hear a leak but itís under the valve cover and I can hear it through the CCV pipe is that normal??
 
Reply With Quote
  #14  
Old 03-19-2018, 07:58 PM
Walleye Hunter
Walleye Hunter is online now
Postmaster
Join Date: Mar 2014
Location: Douglassville, PA
Posts: 4,483
Walleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to allWalleye Hunter is a name known to all
Mine lets air out somewhere too when I conduct that test, I couldn't figure out where it's going though.
 
Reply With Quote
  #15  
Old 03-19-2018, 08:41 PM
z31freakify's Avatar
z31freakify
z31freakify is offline
Post Fiend
Join Date: Dec 2012
Location: Las Cruces New Mexico
Posts: 5,652
z31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to allz31freakify is a name known to all
Can you post a oicture of your engine compartment? Specially the turbo? Also check for boost leaks and up pipe leaks.
 
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.