oddness... trans, turbo, both? - Ford Truck Enthusiasts Forums

Notices
2009 - 2014 F150 Discuss the 2009, 2010, 2011, 2012, 2013 and 2014 Ford F150
Sponsored by:
Sponsored by:

oddness... trans, turbo, both?

Reply

 
 
 
  #1  
Old 02-12-2018, 06:50 AM
cleanLX
cleanLX is offline
Elder User
Thread Starter
Join Date: Mar 2003
Location: Phoenix Az, by way of Fre
Posts: 541
cleanLX is starting off with a positive reputation.
oddness... trans, turbo, both?

2012 with 3.5eco and 6speed.
~110k miles... serviced every 5k miles.
Truck has been flawless and has shown no signs of "issues" until yesterday.
Driving with windows down, heard an odd "hissing" noise, and truck felt sluggish.
Rolled into the throttle just a little, and rev's "jumped" up to around 2500rpm (from ~1800rpm), but, nothing really happened in the "go" department.

Where would you guys start looking first?
 
Reply With Quote
  #2  
Old 02-12-2018, 07:31 AM
Robbgt's Avatar
Robbgt
Robbgt is offline
Postmaster
Join Date: Oct 2004
Location: CT
Posts: 3,631
Robbgt is a splendid one to beholdRobbgt is a splendid one to beholdRobbgt is a splendid one to beholdRobbgt is a splendid one to beholdRobbgt is a splendid one to beholdRobbgt is a splendid one to beholdRobbgt is a splendid one to behold
Sounds like maybe a boost leak of some kind?

Might be worth checking your plumbing for leaks. Any check engine light?
 
Reply With Quote
  #3  
Old 02-12-2018, 07:34 AM
cleanLX
cleanLX is offline
Elder User
Thread Starter
Join Date: Mar 2003
Location: Phoenix Az, by way of Fre
Posts: 541
cleanLX is starting off with a positive reputation.
no check engine light.
 
Reply With Quote
  #4  
Old 02-13-2018, 09:46 PM
Tom's Avatar
Tom
Tom is online now
Moderator
Join Date: Aug 2003
Location: Isanti, MN
Posts: 23,407
Tom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputationTom has a superb reputation
Just to clarify, this is a continuous issue? Or something that happened and is now running normally?

I'd agree with Robb, sounds like a boost leak of some flavor. Not all codes will set the check engine light either, I'd get it scanned and see what comes up.
 
Reply With Quote
  #5  
Old 02-14-2018, 06:24 AM
WXboy's Avatar
WXboy
WXboy is offline
Posting Guru
Join Date: Sep 2002
Location: Central KY
Posts: 2,497
WXboy has a good reputation on FTE.WXboy has a good reputation on FTE.
Hissing and low power points to a CAC hose failure. Check the plumbing to and from the turbos/intercooler for slits or tears.
 
Reply With Quote
  #6  
Old 02-15-2018, 08:41 AM
cleanLX
cleanLX is offline
Elder User
Thread Starter
Join Date: Mar 2003
Location: Phoenix Az, by way of Fre
Posts: 541
cleanLX is starting off with a positive reputation.
Thanks guys.
Happened on Sunday, and, I've been driving my Jeep since then... 'till i have time to look at it, or, probably just take it to Ford. Cracked 100k miles a few weeks ago, so, time for an overlook anyways I should imagine.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Oldanvilyoungsmith
1999 - 2003 7.3L Power Stroke Diesel
3
11-15-2017 05:44 PM
Tarster
Computer Chips & Tuners
4
08-08-2017 04:28 AM
hivoltj
2004 - 2008 F150
4
04-05-2017 08:49 AM
Datavirtue
1999 to 2016 Super Duty
7
10-21-2016 11:08 AM
Januch09
6.7L Power Stroke Diesel
11
04-29-2016 04:56 PM


Thread Tools
Search this Thread
Quick Reply: oddness... trans, turbo, both?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: