I'm new! 08 F350 V10 questions! - Page 3 - Ford Truck Enthusiasts Forums

Notices
Modular V10 (6.8l)  
Sponsored by:
Sponsored by:

I'm new! 08 F350 V10 questions!

  #31  
Old 01-02-2018, 10:59 AM
Krewat's Avatar
Krewat
Krewat is offline
Super Moderator
Join Date: Jul 2002
Location: Long Island USA
Posts: 38,923
Krewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputationKrewat has a superb reputation
Those 35x codes, are circuit malfunction? The PCM might read a circuit malfunction when the COP misfires. So if the spring and boot, or plug, are causing a misfire bad enough, the PCM could think that's a circuit problem.

As people can tell here, I am leery of telling people to just replace coils for no reason. If they aren't verified bad, why replace them until you have to? I'd pull those coils out (pull them all, as a matter of fact) and make sure the boots are clean and the springs are not corroded.
 
  #32  
Old 01-02-2018, 12:45 PM
johnfist
johnfist is offline
Senior User
Thread Starter
Join Date: Dec 2017
Posts: 268
johnfist is starting off with a positive reputation.
Yeah I'm going to do the plugs anyway so i'll have a good look at them all. The 35x codes are ignition malfunction codes if i remember correctly. I'd have to pull it again to get the wording correct.
 
  #33  
Old 01-04-2018, 10:55 PM
johnfist
johnfist is offline
Senior User
Thread Starter
Join Date: Dec 2017
Posts: 268
johnfist is starting off with a positive reputation.
Okay, had some time to work on the truck this afternoon. Pulled a few more plugs and replaced them, most looked decent in terms of wear, probably less than 100k on them. So far none have looked as bad as #6 did. The seems to be staying off now, however it flashes intermittently if I go over 50-55mph. There's no stored codes but pending codes are 300 and 306. #6 must have something going on for that plug to look as bad as it did, and for that to be the recurring misfire. Anyone have any thoughts?

Most of the COP/boots/springs are in great shape. Just dirty. I don't think they're all the correct version though. I know there's brown and black ones, and I thought the brown ones were for older models but I could have that wrong.

Also, took a pic of the exhaust manifold on the driver side. I think I know where my ticking noise is coming from.


Leak on #10?
https://imgur.com/a/hNQDI

On the up side, I should be able to get it inspected tomorrow finally, and there's a good power increase since the last time I worked on it.
 
  #34  
Old 05-21-2018, 03:32 PM
johnfist
johnfist is offline
Senior User
Thread Starter
Join Date: Dec 2017
Posts: 268
johnfist is starting off with a positive reputation.
Small update -- as I'll be doing as I slowly bring this beast back to order.

I changed the oil, soon to be sent off for testing.
Cleaned the battery negative terminal, as it had a LOT of neon blue/green corrosion on it. I've never seen a battery with this much gunk on the terminal. I don't believe it was this bad when I changed the plugs, not sure why it would have developed.

After doing these two items, I took it for a ride (approx 40 miles each way). On my first trip my CEL stayed off until I hit highway speeds, then it dropped the 300 and 306 codes on me again. Blasted #6. I'll need to pull it out and reinspect everything again. On the way home after resetting the CEL, it popped right back with 300 and 306.

Is it possible voltage is my problem? I only ask due to the unusual corrosion on the battery terminal.

Thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
nstueve
Modular V10 (6.8l)
2
02-21-2014 02:42 PM
bosanci28
1999 to 2016 Super Duty
2
04-18-2010 11:31 AM
nicebenz68
Modular V10 (6.8l)
19
03-05-2009 06:24 PM
V10RANDY
Modular V10 (6.8l)
9
04-04-2007 01:21 PM
blackjack8900
1999 to 2016 Super Duty
2
02-05-2006 06:16 PM


Thread Tools
Search this Thread
Quick Reply: I'm new! 08 F350 V10 questions!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.