OBD Code (P0451 - Evap Sensor) - Ford Truck Enthusiasts Forums

Notices
2009 - 2014 F150 Discuss the 2009, 2010, 2011, 2012, 2013 and 2014 Ford F150
Sponsored by:
Sponsored by:

OBD Code (P0451 - Evap Sensor)

Reply

 
 
 
  #1  
Old 11-14-2017, 06:22 PM
640 CI Aluminum FORD
640 CI Aluminum FORD is offline
Posting Guru
Thread Starter
Join Date: Nov 2003
Posts: 1,200
640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.
OBD Code (P0451 - Evap Sensor)

Anyone had this issue arise yet? Started with my check engine light illuminating a few days ago. Had a diagnostic's test run on it today and P0451 was the code that was pulled. The guy at the parts store said he'd never seen the code before and that it was an evap sensor issue. I had him check the computer and they don't even carry the part.

I'm going to take it to a trusted mechanic this weekend and let him look over it and give me his take. But I'm just curios if anyone else had this issue come up with your truck? If so, what was the fix and how much $$ was it?

Also, the truck is a 2011 F-150 with the 5.0L V8.

Thanks!
 
Reply With Quote
  #2  
Old 11-14-2017, 06:40 PM
fastback89
fastback89 is offline
Senior User
Join Date: Nov 2011
Posts: 163
fastback89 is starting off with a positive reputation.
I just did a quick lookup on this and it could be a canister purge sol but I would have a shop check it out before buying the wrong part happens.
 
Reply With Quote
  #3  
Old 11-15-2017, 09:26 PM
Siberexpress's Avatar
Siberexpress
Siberexpress is offline
Senior User
Join Date: Jan 2005
Location: Clinton TN.
Posts: 214
Siberexpress is starting off with a positive reputation.
It could actually just be dirt in the Capless fuel flap, go put some gas in it and see if you can see anything on the flap.
 
Reply With Quote
  #4  
Old 11-16-2017, 05:39 AM
tseekins's Avatar
tseekins
tseekins is offline
Moderator
Join Date: Jan 2008
Location: Maine, Virginia
Posts: 28,137
tseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputation
I've had a 442 code come up on my 2004 Expedition a couple of times that read small evap leak. After taking it to my trusted mechanic, he found vacuum lines that were cracked and leaking and an evap line that was doing the same.

I really wouldn't have known where to begin with this had it not been for him and his people looking at it.
 
Reply With Quote
  #5  
Old 11-16-2017, 09:47 AM
Olytlr
Olytlr is offline
Elder User
Join Date: Dec 2007
Posts: 739
Olytlr has a good reputation on FTE.Olytlr has a good reputation on FTE.
Originally Posted by Siberexpress View Post
It could actually just be dirt in the Capless fuel flap, go put some gas in it and see if you can see anything on the flap.
This would be my first thing I would check. Watch Ford Tech Maculoco's video on the capless filler maintenance.
 
Reply With Quote
  #6  
Old 11-17-2017, 09:25 PM
640 CI Aluminum FORD
640 CI Aluminum FORD is offline
Posting Guru
Thread Starter
Join Date: Nov 2003
Posts: 1,200
640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.640 CI Aluminum FORD has a great reputation on FTE.
Awesome! Thanks for the replies guys!
 
Reply With Quote
  #7  
Old 11-18-2017, 06:38 AM
projectSHO89
projectSHO89 is online now
Post Fiend
Join Date: Jan 2004
Location: St Louis
Posts: 14,264
projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.
A P0451 is not going to be related to the cap-less filler system, it's an electrical circuit fault. The filler system fault will cause DTCs relate to evaporative emissions leaks which this is not.

This *might* be covered under the 8/80 federal emissions performance warranty, if you're still eligible. If you're not over 80K miles (70K in California), it's something to check into.
 
Reply With Quote
  #8  
Old 02-01-2018, 12:14 AM
sendit
sendit is offline
Freshman User
Join Date: Dec 2017
Location: Bend, OR
Posts: 38
sendit is starting off with a positive reputation.
Originally Posted by 640 CI Aluminum FORD View Post
Anyone had this issue arise yet? Started with my check engine light illuminating a few days ago. Had a diagnostic's test run on it today and P0451 was the code that was pulled. The guy at the parts store said he'd never seen the code before and that it was an evap sensor issue. I had him check the computer and they don't even carry the part.

I'm going to take it to a trusted mechanic this weekend and let him look over it and give me his take. But I'm just curios if anyone else had this issue come up with your truck? If so, what was the fix and how much $$ was it?

Also, the truck is a 2011 F-150 with the 5.0L V8.

Thanks!
Did you ever figure this out?
 
Reply With Quote
  #9  
Old 06-14-2018, 12:09 AM
amtpdb1
amtpdb1 is offline
New User
Join Date: Apr 2012
Posts: 7
amtpdb1 is starting off with a positive reputation.
I would be interested if this was figured out as my 04 5.4l is throwing the same code . The sensor on mine is in the vent line and not in the tank and Ford wants 300 + for the sensor as it comes with fuel vent lines that they seem to be real proud of. Did it get figured out?
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigtimehunter123
2004 - 2008 F150
16
03-18-2018 04:27 PM
jwalker_52
2009 - 2014 F150
0
10-04-2017 07:37 PM
redbull660
Modular V10 (6.8l)
6
11-26-2012 08:03 PM
ranger 319
1997 - 2003 F150
4
06-09-2009 06:12 AM
R6elmo
Ranger & B-Series
2
06-11-2004 08:32 PM


Thread Tools
Search this Thread
Quick Reply: OBD Code (P0451 - Evap Sensor)


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: