6.4 temp gauge and limp mode - Page 2 - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Diesel > 6.4L Power Stroke Diesel
Reload this Page >

6.4 temp gauge and limp mode

Notices
6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis

6.4 temp gauge and limp mode

 
  #16  
Old 12-30-2017, 02:34 PM
73F700's Avatar
73F700
73F700 is offline
Senior User
Join Date: Dec 2017
Location: Ontario, Canada
Posts: 296
73F700 is gaining momentum as a positive member of FTE.73F700 is gaining momentum as a positive member of FTE.
I have had these symptoms with a clogged oil cooler... Wrench with no codes. If there is to large a difference between oil and coolant temp the computer throws the wrench and limp mode with no engine code.

Could be a faulty sensor on either oil or coolant, or it could be the oil cooler clogging. Can't really tell without gauges to monitor.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Webtoaster
1999 to 2016 Super Duty
3
02-27-2018 11:10 AM
niceguyeddie
1999 to 2016 Super Duty
43
04-29-2014 07:54 PM
hasteranger
6.0L Power Stroke Diesel
26
08-04-2012 04:12 PM
tolewis
1999 to 2016 Super Duty
4
02-19-2008 09:00 PM
bulletcamp
Pre-Power Stroke Diesel (7.3L IDI & 6.9L)
6
03-25-2006 07:23 PM


Thread Tools
Search this Thread
Quick Reply: 6.4 temp gauge and limp mode


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: