expedition el limited won't crank - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

expedition el limited won't crank

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-07-2017, 08:58 PM
charlesmoody67 charlesmoody67 is offline
New User
Thread Starter
 
Join Date: Jul 2017
Posts: 3
charlesmoody67 is starting off with a positive reputation.
expedition el limited won't crank

2007 Ford Expedition EL Limited
shows traction light
shows wrench
flashing security light
Power good, all lights, power lift gate, windows etc. work
Key turns all the way and all you get is a single click from the starter relay in Master junction control box
Reply With Quote
  #2  
Old 07-09-2017, 10:07 AM
alloro alloro is online now
Post Fiend
 
Join Date: Apr 2008
Location: 0,0,1
Posts: 13,765
alloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud ofalloro has much to be proud of
Did you try starting it in neutral? Could just be a bad starter. You would need to test each terminal on the starter for power while attempting to crank it before you can diagnose it any further.
Reply With Quote
  #3  
Old 07-10-2017, 05:58 PM
projectSHO89 projectSHO89 is offline
Post Fiend
 
Join Date: Jan 2004
Location: St Louis
Posts: 13,261
projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.projectSHO89 has a spectacular reputation.
Quote:
...flashing security light...
If you're referring to the THEFT light in the cluster, then that's why it won't crank. It's not supposed to when PATS is triggered.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
fuel pump driver module on a 2007 limited expedition el Haines25 2007 - 2014 Expedition & Navigator 4 06-09-2017 09:04 AM
2013 Ford Expedition EL Limited Expedition EL fan 2007 - 2014 Expedition & Navigator 0 05-25-2017 04:33 PM
rear tailgate glass jawdoc 2015 + Expedition & Navigator 4 05-03-2017 09:29 AM
2016 Expedition EL Limited Is it Possible to Disable Rear Audio Controls jdmspec55 2015 + Expedition & Navigator 8 02-17-2017 05:35 AM
Headrest monitor Help 2015 expeditin el xlt Txfamilyman 2015 + Expedition & Navigator 0 06-08-2016 06:36 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 10:25 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: