Sync 3 2.2 Update killed my APIM - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2015+ F150
Reload this Page >

Sync 3 2.2 Update killed my APIM

Notices
2015+ F150 Discuss the 2015 Ford F150
Sponsored by:
Sponsored by:

Sync 3 2.2 Update killed my APIM

 
  #1  
Old 06-08-2017, 07:50 PM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Sync 3 2.2 Update killed my APIM

As the title says... My truck updated via WiFi from v1.1 to v2.2. After the update Sync progressively became worse and worse.

Touchscreen would lock up or have extremely slow, delay response.
NAV would drop GPS, the screen would go white or black.
Backup camera was delayed or non-functional
Bluetooth was unresponsive
USB was glitchy
Clock would always revert back one hour... that was weird.

and on and on and on...

Dealer verified the APIM is toast and a new module is on order. should arrive Monday or Tuesday.

Josh
 
  #2  
Old 06-09-2017, 07:05 AM
GABAR's Avatar
GABAR
GABAR is online now
Posting Guru
Join Date: Dec 2016
Posts: 2,249
GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.
Originally Posted by Bullitt390 View Post
As the title says... My truck updated via WiFi from v1.1 to v2.2. After the update Sync progressively became worse and worse.

Touchscreen would lock up or have extremely slow, delay response.
NAV would drop GPS, the screen would go white or black.
Backup camera was delayed or non-functional
Bluetooth was unresponsive
USB was glitchy
Clock would always revert back one hour... that was weird.

and on and on and on...

Dealer verified the APIM is toast and a new module is on order. should arrive Monday or Tuesday.

Josh
Sorry to hear about the problems that you had after the OTA update but i`m glad to hear that you`re getting a new APIM.

Hopefully the new unit will solve all of the issues you were having.

Keep us up to date.
 
  #3  
Old 06-11-2017, 09:52 PM
Big-Red-Lariat's Avatar
Big-Red-Lariat
Big-Red-Lariat is offline
Posting Guru
Join Date: Feb 2004
Location: Ottawa, Ontario Canada
Posts: 1,067
Big-Red-Lariat is gaining momentum as a positive member of FTE.
Is there any adverse impact of just staying with SYNC Version 1 and to hell with the update? My phone, contacts, NAV, Sync voice commands and USB music all work great and after reading this, I just don't have time for all that bs. When I update my laptop, something always breaks and sometimes takes weeks to find and fix the bug.
 
  #4  
Old 06-11-2017, 10:13 PM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Originally Posted by Big-Red-Lariat View Post
Is there any adverse impact of just staying with SYNC Version 1 and to hell with the update? My phone, contacts, NAV, Sync voice commands and USB music all work great and after reading this, I just don't have time for all that bs. When I update my laptop, something always breaks and sometimes takes weeks to find and fix the bug.
My opinion would be to avoid updating if you can. On the other forum there are now several who are getting new APIMs after the 2.2 update.

coincidence? Highly doubtful.

I wanted the update to try Apple CarPlay. Turns out that is a complete joke and a horrible waste of time (and money for the new USB module)

Oh well. Dealer diagnosed the APIM quickly and Ford approved the warranty repair swiftly too. Just have to wait for the module to come in.

The real boneheads are the guys with v2.0 trying to load 2.2 and then frying the APIM and Ford denying the repair under warranty 😂

Josh
 
  #5  
Old 06-12-2017, 01:45 AM
GlueGuy's Avatar
GlueGuy
GlueGuy is online now
Postmaster
Join Date: May 2015
Location: San Francisco Bay Area
Posts: 3,074
GlueGuy has a great reputation on FTE.GlueGuy has a great reputation on FTE.GlueGuy has a great reputation on FTE.GlueGuy has a great reputation on FTE.
Sage advice. Mine is a 2015, so I'm guessing it is what it is. It works most of the time, but occasionally gets a wild hair. General solution is what people in the Windows world call the three finger salute.
 
  #6  
Old 06-13-2017, 09:21 AM
GABAR's Avatar
GABAR
GABAR is online now
Posting Guru
Join Date: Dec 2016
Posts: 2,249
GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.
Originally Posted by Big-Red-Lariat View Post
Is there any adverse impact of just staying with SYNC Version 1 and to hell with the update? My phone, contacts, NAV, Sync voice commands and USB music all work great and after reading this, I just don't have time for all that bs. When I update my laptop, something always breaks and sometimes takes weeks to find and fix the bug.
Embrace the update and stop listening to all of the problems that SOME and NOT ALL F150 owners are having. Yes, it`s unfortunate and frustrating that many F150 owners are having problems with said 2.2 update but that number is minute compared to the successful 2.2 updates.

You said that you updated your laptop and yes, they also sometimes have problems after an update but are you saying that since you had issues with your computer after an update, you`ve never updated your computer again?

You want to remain on SYNC 1.0?

Would you rather be using a 10 year old version of Windows or would you rather be using a more current version of Windows.

I highly doubt it.
 
  #7  
Old 06-13-2017, 09:49 AM
xr7gt390's Avatar
xr7gt390
xr7gt390 is offline
Postmaster
Join Date: Jul 2009
Location: North West Indiana
Posts: 2,524
xr7gt390 has a great reputation on FTE.xr7gt390 has a great reputation on FTE.xr7gt390 has a great reputation on FTE.xr7gt390 has a great reputation on FTE.
It's really only worth the update if you use CarPlay. Version 2.2 has some bug fixes that should make CarPlay work better. Streaming Blue Tooth or USB should be working in all versions. I gave up on the update and renewed my Sirius Subscription for 6 months. Hopefully I'll get the update by then.
 
  #8  
Old 06-13-2017, 09:52 AM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Originally Posted by GABAR View Post
Embrace the update and stop listening to all of the problems that SOME and NOT ALL F150 owners are having. Yes, it`s unfortunate and frustrating that many F150 owners are having problems with said 2.2 update but that number is minute compared to the successful 2.2 updates.

You said that you updated your laptop and yes, they also sometimes have problems after an update but are you saying that since you had issues with your computer after an update, you`ve never updated your computer again?

You want to remain on SYNC 1.0?

Would you rather be using a 10 year old version of Windows or would you rather be using a more current version of Windows.

I highly doubt it.
I would rather have Windows XP running smooth than Windows 10 running glitchy.

And FYI, my dealer has currently replaced, as the the SA said, 20+ F150 APIMs since the update.

Josh
 
  #9  
Old 06-13-2017, 11:09 AM
CR172
CR172 is offline
Elder User
Join Date: Feb 2017
Location: N. Texas
Posts: 755
CR172 has a good reputation on FTE.CR172 has a good reputation on FTE.
Kinda off topic, but...... After playing with the missus 2017 Edge Navigation and Sync 3, I think I'll save the few hundred $$'s when it comes to getting the retirement truck. It doesn't work as well as I hoped it would. Too much of a PITA in my opinion....
 
  #10  
Old 06-14-2017, 11:36 AM
GABAR's Avatar
GABAR
GABAR is online now
Posting Guru
Join Date: Dec 2016
Posts: 2,249
GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.
Originally Posted by Bullitt390 View Post
I would rather have Windows XP running smooth than Windows 10 running glitchy.

And FYI, my dealer has currently replaced, as the the SA said, 20+ F150 APIMs since the update.

Josh
How about Windows 7 instead of XP.

You failed to fully understand the point I was trying to make but no harm no foul.

Also, 20+ APIMS is still very minute compared to successful updates.

How many of those said 20+ APIMS were already on version 2.0 and tried to update to 2.2 and afterwards they needed a new APIM. I highly doubt all of them were 1.0 APIMS.

The info on the Ford Owner website clearly states what year F150 and version the 2.2 update is for so if people on 2.0 tried to do the update then it`s totally their fault.

Also, people who downloaded the unofficial release of 2.2 and then ungraded to the official 2.2 update only to find they`re also having problems then again, they have no one to blame but themselves.

I`m not saying that you did any of the above but lets mention the whole story/saga of this update and the people that are having problems.

Have a great day.
 
  #11  
Old 06-14-2017, 12:11 PM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Originally Posted by GABAR View Post
How about Windows 7 instead of XP.

You failed to fully understand the point I was trying to make but no harm no foul.

Also, 20+ APIMS is still very minute compared to successful updates.

How many of those said 20+ APIMS were already on version 2.0 and tried to update to 2.2 and afterwards they needed a new APIM. I highly doubt all of them were 1.0 APIMS.

The info on the Ford Owner website clearly states what year F150 and version the 2.2 update is for so if people on 2.0 tried to do the update then it`s totally their fault.

Also, people who downloaded the unofficial release of 2.2 and then ungraded to the official 2.2 update only to find they`re also having problems then again, they have no one to blame but themselves.

I`m not saying that you did any of the above but lets mention the whole story/saga of this update and the people that are having problems.

Have a great day.
I had v1.1.

Guys updating from 2.0 to 2.2 won't be covered under warranty if the APIM fails.
 
  #12  
Old 06-16-2017, 12:14 AM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Got my truck back today. New APIM installed and seems to be working perfectly fine.

Curiously, I am now on v2.0...



Needless to say, I won't make any effort to update to 2.2

Josh
 
  #13  
Old 06-16-2017, 01:47 PM
GABAR's Avatar
GABAR
GABAR is online now
Posting Guru
Join Date: Dec 2016
Posts: 2,249
GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.GABAR has a good reputation on FTE.
Originally Posted by Bullitt390 View Post
Got my truck back today. New APIM installed and seems to be working perfectly fine.

Curiously, I am now on v2.0...



Needless to say, I won't make any effort to update to 2.2

Josh
Glad to hear the new APIM is working well for you.

Just turn on Automatic Updates and forget about using the USB for any current or future updates.
 
  #14  
Old 06-16-2017, 07:47 PM
Bullitt390's Avatar
Bullitt390
Bullitt390 is offline
Certified Thread Hijacker
Thread Starter
Join Date: Aug 2001
Posts: 14,095
Bullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant futureBullitt390 has a brilliant future
Originally Posted by GABAR View Post
Glad to hear the new APIM is working well for you.

Just turn on Automatic Updates and forget about using the USB for any current or future updates.
My old one updated via WiFi... needless to say, Automatic Updates is OFF

Josh
 
  #15  
Old 06-17-2017, 03:07 PM
Big-Red-Lariat's Avatar
Big-Red-Lariat
Big-Red-Lariat is offline
Posting Guru
Join Date: Feb 2004
Location: Ottawa, Ontario Canada
Posts: 1,067
Big-Red-Lariat is gaining momentum as a positive member of FTE.
my father always said "if it ain't broke, don't fix it". Never went wrong following his advice, so I will keep version 1 unless someone can tell me about some extremely cool new features in v2 that I just can't live without.
 

Thread Tools
Search this Thread
Quick Reply: Sync 3 2.2 Update killed my APIM


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: