Kenwood DDX774BH Receiver Questions - Ford Truck Enthusiasts Forums

Notices

Kenwood DDX774BH Receiver Questions

Reply

 
 
 
  #1  
Old 05-21-2017, 01:02 AM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
Kenwood DDX774BH Receiver Questions

For: 2016 F350.
with Steering wheel controls, SYNC, Bluetooth, SirusXM, rearview camera, stock am/fm/cd radio, w/o sub.

Kenwood DDX774BH
SiriusXM SXV300 Tuner adapter
Maestro Ar ADS-MRR idatalink
Maestro FO1 Installation Wiring Harness
Metra 95-5812 Radio install kit (Radio mount bracket, extension for AM/FM Antenna)
This entire system was not bought through Crutchfield.

While having all of this spread over the dining room table it really doesn't look to be a challenge to install. The needed wire connections for the speakers are completed. The Wiring Diagram for the Maestro iDatalink is straight forward and shows all of the plugs to be installed clearly.

Connected the Reverse Sensor wire (Purple w/white stripe) to the Maestro wiring harness.
Connected the Ground, 12v power, ign and illumination wires to the Maestro wiring harness.
installed Butt ends to end wires not used in this application.
Next the iDatalink Module needs to be Flashed (online homepage for iDatalink)
Disconnect 12v Battery connection at the Battery then remove stock Radio.

Questions:
SiriusXM, can the Ford Installed Sirius XM Antenna be used with the Kenwood or does the new included SiriusXM Antenna needed to be used?

Can the already installed Ford Mic be used with the Kenwood or does the New Mic need to be wired in?

Does the Ford rear view camera wire plug directly into the back of the Kenwood Receiver or are any additional cables needed to make it work with the Kenwood? ( to view the rear Camera from the stock rear view Mirror to the larger Kenwood screen )

What purpose is the Parking Sensor wire? (light Green Wire)
 
Attached Images   
Reply With Quote
  #2  
Old 06-11-2017, 09:02 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
I haven't been able to get back to this project but I did find the required Sirus XM adapter at around $13(ordered). I'm having no luck though with retaining the backup camera connector to plug into the rear deck of the Kenwood but the Audio install shop says it can be done.
The Bluetooth Mic that is stock in the Ford can Not be used with the Kenwood, a new Mic is included with the install kit and shouldn't be a issue to install it above the drivers sun visor at the top of the windshield.
I would still prefer to do the install myself but if need be, I can have the unit installed for appox $190 or less.
As the project progresses I will update but now I'm getting ready for a upcoming 2 week flyfishing trip, that comes 1st.
 
Reply With Quote
  #3  
Old 06-11-2017, 09:19 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
The parking sensor wiring is not a issue for me as I am not going to be watching a DVD while driving, talk about a distraction.
 
Reply With Quote
  #4  
Old 07-06-2017, 09:46 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
ok, the Kenwood is now installed, I did have a audio shop install it. Everything works perfect, I'll post up some pic's tomorrow.
 
Reply With Quote
  #5  
Old 07-07-2017, 07:59 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
Seems my Ph doesn't work with this Kenwood but I'm not surprised, this ph has been needing to be replaced for some time now. Not a issue to deal with right away as this SD is not my everyday vehicle.
 
Attached Images        
Reply With Quote
  #6  
Old 07-30-2017, 02:07 PM
DeeDubz's Avatar
DeeDubz
DeeDubz is offline
Senior User
Join Date: Jan 2012
Posts: 442
DeeDubz is starting off with a positive reputation.
nicely done whats PH? Id like to install myself. Is this something that wayyyy over my head?
 
Reply With Quote
  #7  
Old 07-30-2017, 04:07 PM
ManfredVonRichtofen's Avatar
ManfredVonRichtofen
ManfredVonRichtofen is offline
Postmaster
Join Date: Nov 2009
Location: SE Georgia
Posts: 3,065
ManfredVonRichtofen has a great reputation on FTE.ManfredVonRichtofen has a great reputation on FTE.ManfredVonRichtofen has a great reputation on FTE.ManfredVonRichtofen has a great reputation on FTE.ManfredVonRichtofen has a great reputation on FTE.
Just remember if you have a S6 and newer Samsung Galaxy...it cant hook up to HDML...these phones dont support MHL. There is an adapter though.
 
Reply With Quote
  #8  
Old 07-31-2017, 01:28 AM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
Originally Posted by DeeDubz View Post
nicely done whats PH? Id like to install myself. Is this something that wayyyy over my head?
My (PH) Phone was the issue, once upgraded everything works perfect with bluetooth.
Other than the rear view camera hookup I would of installed this Kenwood myself. The Kenwood was a gift, if say it was all bought through Crutchfield then maybe I could of figured out the rear view wiring issue with the help of their Tech section.
 
Reply With Quote
  #9  
Old 07-31-2017, 05:33 PM
DeeDubz's Avatar
DeeDubz
DeeDubz is offline
Senior User
Join Date: Jan 2012
Posts: 442
DeeDubz is starting off with a positive reputation.
Originally Posted by SWV10 View Post
My (PH) Phone was the issue, once upgraded everything works perfect with bluetooth.
Other than the rear view camera hookup I would of installed this Kenwood myself. The Kenwood was a gift, if say it was all bought through Crutchfield then maybe I could of figured out the rear view wiring issue with the help of their Tech section.
thats the only thing stopping me right now. I dunno might go get one at best buy and have their goons install. Looks pretty good. did you add a sub or amp?
 
Reply With Quote
  #10  
Old 08-26-2017, 01:15 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
Originally Posted by DeeDubz View Post
thats the only thing stopping me right now. I dunno might go get one at best buy and have their goons install. Looks pretty good. did you add a sub or amp?
No, I did not install the sub or amp.
 
Reply With Quote
  #11  
Old 12-28-2017, 08:27 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
I have noticed some glare on the Kenwood screen, found nothing for aftermarket so I made one. I used Velcro above the unit to attach a shade, this way I can remove the shade when I take in the SD for service. I used a piece of dark firm foam, trimmed it to size I wanted.
The glare in the Pic is from the flash from the camera when taking the pic.
 
Attached Images  
Reply With Quote
  #12  
Old 01-02-2018, 08:19 PM
Mastertinner
Mastertinner is offline
Junior User
Join Date: Oct 2017
Posts: 92
Mastertinner is starting off with a positive reputation.
I just installed the kenwood dnx574s with a backup camera off amazon in my 2016 f250. Everything works great. I did not hook up the factory xm antenna, but I was able to use the factory mic.
 
Reply With Quote
  #13  
Old 01-04-2018, 10:12 AM
auburngrad
auburngrad is offline
Senior User
Join Date: Mar 2015
Posts: 333
auburngrad is starting off with a positive reputation.
Thanks for this write up.

I am looking at this exact unit for my 2015 250. Not sure when I'll bite the bullet. I would like to save the 200 dollar install and do it myself. I've done others before. This will be the most complicated, as adding the miestro box will be new to me. And I plan on running a back up camera also.
 
Reply With Quote
  #14  
Old 01-04-2018, 02:00 PM
SWV10's Avatar
SWV10
SWV10 is offline
Senior User
Thread Starter
Join Date: Nov 2003
Location: New Mexico
Posts: 339
SWV10 is gaining momentum as a positive member of FTE.
I wanted to do the install myself too but couldn't find any helpful info on the rear camera hookup, youtube only gave me more confusion than the answer I was looking for, so not to screw it up I had the Audio shop install it. The Kenwood Receiver was a gift so paying for the install didn't hurt that much.
 
Reply With Quote
  #15  
Old 01-20-2018, 09:48 AM
itat
itat is offline
Freshman User
Join Date: Aug 2016
Location: Ontario, Canada
Posts: 26
itat is starting off with a positive reputation.
Originally Posted by Mastertinner View Post
I just installed the kenwood dnx574s with a backup camera off amazon in my 2016 f250. Everything works great. I did not hook up the factory xm antenna, but I was able to use the factory mic.
How did you get the factory mic to work with your Kenwood HU?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Kenwood DDX774BH Receiver Questions


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.