I didn't like the answers from my last thread, so I'm starting a new one - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1987 - 1996 F150 & Larger F-Series Trucks
Reload this Page >

I didn't like the answers from my last thread, so I'm starting a new one

Notices
1987 - 1996 F150 & Larger F-Series Trucks 1987 - 1996 Ford F-150, F-250, F-350 and larger pickups - including the 1997 heavy-duty F250/F350+ trucks

I didn't like the answers from my last thread, so I'm starting a new one

Reply

 
 
 
  #1  
Old 05-20-2017, 07:02 PM
'89F2urd's Avatar
'89F2urd
'89F2urd is offline
Postmaster
Thread Starter
Join Date: May 2011
Posts: 4,414
'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.
I didn't like the answers from my last thread, so I'm starting a new one

Need help with truck, it doesn't work. Everything is new, I've tried everything. No one can figure it out. Any advice???

I think the recent thread board is much larger than it really is, and that if I post a new thread with my same problems, I must be able to get all new opinions from more competent people that didn't notice my first thread.
 
Reply With Quote
  #2  
Old 05-20-2017, 07:17 PM
My4Fordtrucks's Avatar
My4Fordtrucks
My4Fordtrucks is online now
Posting Guru
Join Date: Jun 2015
Posts: 1,542
My4Fordtrucks is gaining momentum as a positive member of FTE.
I can give you different advice although I think the last advice I gave you was better. Did that help?
 
Reply With Quote
  #3  
Old 05-20-2017, 07:23 PM
'89F2urd's Avatar
'89F2urd
'89F2urd is offline
Postmaster
Thread Starter
Join Date: May 2011
Posts: 4,414
'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.
I did not heed your advice in its entirety in my last thread, I left out bits because I don't understand or am lazy.

I like amsoil. They make good products.
 
Reply With Quote
  #4  
Old 05-20-2017, 07:36 PM
raytasch's Avatar
raytasch
raytasch is online now
Old guy with old toys
Join Date: Jun 2004
Location: W. Central FL.
Posts: 6,424
raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.raytasch has a spectacular reputation.
Originally Posted by '89F2urd View Post
Need help with truck, it doesn't work. Everything is new, I've tried everything. No one can figure it out. Any advice???

I think the recent thread board is much larger than it really is, and that if I post a new thread with my same problems, I must be able to get all new opinions from more competent people that didn't notice my first thread.
Having been on the FTE forum for more than a few years, I can assure you the quality of the answer received is usually directly proportional to the quality of the question presented.

[I]Need help with truck, it doesn't work. Everything is new, I've tried everything. No one can figure it out. Any advice[/I]

This is not much of a question. Or, am I missing something?
 
Reply With Quote
  #5  
Old 05-20-2017, 07:38 PM
NotEnoughTrucks2014's Avatar
NotEnoughTrucks2014
NotEnoughTrucks2014 is offline
Posting Guru
Join Date: Mar 2014
Location: Saskatchewan Canada
Posts: 1,403
NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.
I must have missed something good here?????

Or maybe I am lucky I missed it!
 
Reply With Quote
  #6  
Old 05-20-2017, 07:40 PM
Scndsin's Avatar
Scndsin
Scndsin is online now
Du Nawt Seek The Treasure
Join Date: May 2006
Location: Central Mississippi
Posts: 7,190
Scndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputation
Just pour some ATF in it. That'll fix it.

Oh & get rid of the EFI.
 
Reply With Quote
  #7  
Old 05-20-2017, 07:47 PM
raystankewitz's Avatar
raystankewitz
raystankewitz is offline
Elder User
Join Date: May 2010
Location: Fremont, CA
Posts: 999
raystankewitz has a good reputation on FTE.raystankewitz has a good reputation on FTE.
Originally Posted by '89F2urd View Post
Need help with truck, it doesn't work. Everything is new, I've tried everything. No one can figure it out. Any advice???

I think the recent thread board is much larger than it really is, and that if I post a new thread with my same problems, I must be able to get all new opinions from more competent people that didn't notice my first thread.
Man, I'm sure you didn't do this just to make things harder. Now, for anyone to help you out, they have to find the old thread and read it in its entirety. the bad; that thread will get shuffled off into the board in a hurry, making finding it for someone that doesn't know or understand searches pretty difficult.

That, or you can make a concise list of what was the original problem, what we suggested to do, and what the outcome was.

Sorry if I'm coming across as an @$$ but this wasn't the best way to get further help.
 

Last edited by raystankewitz; 05-20-2017 at 07:48 PM. Reason: Typos
Reply With Quote
  #8  
Old 05-20-2017, 07:50 PM
'89F2urd's Avatar
'89F2urd
'89F2urd is offline
Postmaster
Thread Starter
Join Date: May 2011
Posts: 4,414
'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.
Yes I think you're right, I'll carb it.

I've never pulled codes because I don't know what a paper clip looks like.
 
Reply With Quote
  #9  
Old 05-20-2017, 07:52 PM
My4Fordtrucks's Avatar
My4Fordtrucks
My4Fordtrucks is online now
Posting Guru
Join Date: Jun 2015
Posts: 1,542
My4Fordtrucks is gaining momentum as a positive member of FTE.
Originally Posted by Scndsin View Post
Oh & get rid of the EFI.
I would like to second this thought! I would also like to add that you should go back to points and get rid of those newfangled 'lectonic ignition systems. They are just too darn complicated to bother figuring out what the problem is.
 
Reply With Quote
  #10  
Old 05-20-2017, 07:56 PM
'89F2urd's Avatar
'89F2urd
'89F2urd is offline
Postmaster
Thread Starter
Join Date: May 2011
Posts: 4,414
'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.
Fuel pressure is good, I can hear the pump running.
 
Reply With Quote
  #11  
Old 05-20-2017, 07:58 PM
NotEnoughTrucks2014's Avatar
NotEnoughTrucks2014
NotEnoughTrucks2014 is offline
Posting Guru
Join Date: Mar 2014
Location: Saskatchewan Canada
Posts: 1,403
NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.NotEnoughTrucks2014 has a very good reputation on FTE.
I think I have it figured out, but I'm sure you are waiting for the "right" answer, so I will shut up.
 
Reply With Quote
  #12  
Old 05-20-2017, 07:59 PM
dieselss
dieselss is offline
Freshman User
Join Date: Mar 2017
Posts: 32
dieselss is starting off with a positive reputation.
Hearing a pump running doesn't mean it got good psi.
 
Reply With Quote
  #13  
Old 05-20-2017, 08:00 PM
Scndsin's Avatar
Scndsin
Scndsin is online now
Du Nawt Seek The Treasure
Join Date: May 2006
Location: Central Mississippi
Posts: 7,190
Scndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputationScndsin has a superb reputation
Originally Posted by raystankewitz View Post
...Sorry if I'm coming across as an @$$ but this wasn't the best way to get further help.
Nah, you're just late to the party...

2urd has been having a bout of ...

...when it comes to the instant gratification generation. That HE'S been trying to help
 
Reply With Quote
  #14  
Old 05-20-2017, 08:00 PM
'89F2urd's Avatar
'89F2urd
'89F2urd is offline
Postmaster
Thread Starter
Join Date: May 2011
Posts: 4,414
'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.'89F2urd has a very good reputation on FTE.
It turns over but doesn't crank.
 
Reply With Quote
  #15  
Old 05-20-2017, 08:01 PM
raystankewitz's Avatar
raystankewitz
raystankewitz is offline
Elder User
Join Date: May 2010
Location: Fremont, CA
Posts: 999
raystankewitz has a good reputation on FTE.raystankewitz has a good reputation on FTE.
Originally Posted by '89F2urd View Post
Fuel pressure is good, I can hear the pump running.
Is that the pump in the empty tank?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: I didn't like the answers from my last thread, so I'm starting a new one


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.