Do I just keep cranking? New HPOP and Injectors - Page 14 - Ford Truck Enthusiasts Forums



1999 - 2003 7.3L Power Stroke Diesel  
Sponsored by:
Sponsored by:

Do I just keep cranking? New HPOP and Injectors

Reply
 
 
 
Thread Tools Search this Thread
  #196  
Old 06-19-2017, 10:44 AM
JenC JenC is offline
Freshman User
 
Join Date: Nov 2014
Posts: 32
JenC is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by Sous View Post
JenC, correct me if I am wrong, but you are with/represent Diesel Site right?

6_myles bought a T500 and not an Adrenaline pump, but it is good to hear from other vendors sometimes.
Yep - I saw. But a pump is a pump and I thought I would share since I'm sure all the re-builders experience the same things.
Reply With Quote
  #197  
Old 06-19-2017, 11:29 AM
Sous's Avatar
Sous Sous is offline
Postmaster
 
Join Date: May 2014
Location: Lake Hartwell, GA
Posts: 4,687
Sous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud of
Quote:
Originally Posted by JenC View Post
Yep - I saw. But a pump is a pump and I thought I would share since I'm sure all the re-builders experience the same things.
Agreed, just wanted the thread to be clear about who you were and represent. Not stating anything pro or con about either HPOP available to the consumer though.

Thanks for your input and sharing your experiences on "DOA" pumps.
Reply With Quote
  #198  
Old 06-22-2017, 06:37 AM
6_Myles 6_Myles is offline
Senior User
Thread Starter
 
Join Date: Feb 2007
Posts: 146
6_Myles is starting off with a positive reputation.
Thanks all, sorry to disappear for a bit...work/family has been crazy lately. Waiting to get my pump back from Terminator.

JenC, i would agree that IPR would be the vastly more common problem but I used the same IPR that I've been running around on the borrowed HPOP with.

Still chasing this P1273 code. Swapped solenoids, double checked UVCH and looked for wire chafes and can't seem to find any...any other ideas?
Reply With Quote
  #199  
Old 07-05-2017, 11:28 PM
crwln73 crwln73 is offline
New User
 
Join Date: Nov 2003
Location: CALI.
Posts: 16
crwln73 is starting off with a positive reputation.
Wow I'm going thru the exact same issues. Waiting now for my pump to come back. Did your truck ever run with the T500 pump?
Reply With Quote
  #200  
Old 07-06-2017, 09:28 AM
6_Myles 6_Myles is offline
Senior User
Thread Starter
 
Join Date: Feb 2007
Posts: 146
6_Myles is starting off with a positive reputation.
i got the replacement pump about a week ago and to be honest, I haven't worked up the nerve to install it yet.

I've been finding lots of reasons not to 'have time' to do it right now. I think i'm going to do it this weekend.

Sorry you are dealing with it too. I got a whole new housing for the 3rd pump, meaning he kept mine as a core.
Reply With Quote
  #201  
Old 07-06-2017, 11:00 AM
Sous's Avatar
Sous Sous is offline
Postmaster
 
Join Date: May 2014
Location: Lake Hartwell, GA
Posts: 4,687
Sous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud of
Quote:
Originally Posted by crwln73 View Post
Wow I'm going thru the exact same issues. Waiting now for my pump to come back. Did your truck ever run with the T500 pump?
Did you purchase a T500 as well or another aftermarket HPOP?

Was the HPOP purchased in new/remanufactured or used condition?

Is your vendor/source working with you or giving you the cold shoulder?
Reply With Quote
  #202  
Old 07-06-2017, 11:02 AM
Sous's Avatar
Sous Sous is offline
Postmaster
 
Join Date: May 2014
Location: Lake Hartwell, GA
Posts: 4,687
Sous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud of
Quote:
Originally Posted by 6_Myles View Post
i got the replacement pump about a week ago and to be honest, I haven't worked up the nerve to install it yet.

I've been finding lots of reasons not to 'have time' to do it right now. I think i'm going to do it this weekend.

Sorry you are dealing with it too. I got a whole new housing for the 3rd pump, meaning he kept mine as a core.
Most of us understand this 100%. Something like this really takes the wind out of your sails to complete the job. One of the things I hate the most in this world is doing my best to make something better, and end up having it turn out worse than what it was.

We are all pulling for you to get the pump installed and it fires right up!
Reply With Quote
  #203  
Old 07-06-2017, 12:43 PM
crwln73 crwln73 is offline
New User
 
Join Date: Nov 2003
Location: CALI.
Posts: 16
crwln73 is starting off with a positive reputation.
Sous
I bought a T500 pump also. I truly believe that Terminator has a quality product and it's just a unfortunate coincidence. Joey rechecked my pump and put new internals in it just to make sure.
6_Myles
I understand the frustration. Hope it works when you do decide to put it on. Mine should be here today. I plan on putting it on this evening.
Reply With Quote
  #204  
Old 07-07-2017, 02:37 PM
6_Myles 6_Myles is offline
Senior User
Thread Starter
 
Join Date: Feb 2007
Posts: 146
6_Myles is starting off with a positive reputation.
Quote:
Originally Posted by Sous View Post
Did you purchase a T500 as well or another aftermarket HPOP?

Was the HPOP purchased in new/remanufactured or used condition?

Is your vendor/source working with you or giving you the cold shoulder?
I purchased a T500 through DP Tuner. I sent mine in as a core. It was working fine, i was getting upgraded injectors and wanted my HPOP to match them.

DP has been great, they let Joey (at terminator) and I communicate to try and solve the problem but when it reached a level of frustration on my part they stepped in and have been doing whatever it takes to get it done.

Yes, I'm hoping to do it this weekend. I've just had too many other cars needing attention too.
Reply With Quote
  #205  
Old 09-04-2017, 10:17 PM
6_Myles 6_Myles is offline
Senior User
Thread Starter
 
Join Date: Feb 2007
Posts: 146
6_Myles is starting off with a positive reputation.
So my name is Myles, I am just not meant to have a t500 pump on my truck

To be honest, I needed a break from working on the truck....so I've been running on Jim's borrowed HPOP (words cannot describe how thankful i am)

So today, I'm in a great mood. Casually remove the borrowed pump this morning, and get everything ready for this evening.

Install the 3rd T500 pump and button everything up.

And. It's. Not. Cranking. Again.

Let me tell you amazing my attitude is right now.
Reply With Quote
  #206  
Old 09-04-2017, 10:32 PM
crwln73 crwln73 is offline
New User
 
Join Date: Nov 2003
Location: CALI.
Posts: 16
crwln73 is starting off with a positive reputation.
Quote:
Originally Posted by 6_Myles View Post
So my name is Myles, I am just not meant to have a t500 pump on my truck

To be honest, I needed a break from working on the truck....so I've been running on Jim's borrowed HPOP (words cannot describe how thankful i am)

So today, I'm in a great mood. Casually remove the borrowed pump this morning, and get everything ready for this evening.

Install the 3rd T500 pump and button everything up.

And. It's. Not. Cranking. Again.

Let me tell you amazing my attitude is right now.
Hang in there. I've been trying to get my truck running right for over a year. I just want to drive the thing.
Reply With Quote
  #207  
Old 09-05-2017, 10:04 AM
Sous's Avatar
Sous Sous is offline
Postmaster
 
Join Date: May 2014
Location: Lake Hartwell, GA
Posts: 4,687
Sous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud ofSous has much to be proud of
Quote:
Originally Posted by 6_Myles View Post
So my name is Myles, I am just not meant to have a t500 pump on my truck

To be honest, I needed a break from working on the truck....so I've been running on Jim's borrowed HPOP (words cannot describe how thankful i am)

So today, I'm in a great mood. Casually remove the borrowed pump this morning, and get everything ready for this evening.

Install the 3rd T500 pump and button everything up.

And. It's. Not. Cranking. Again.

Let me tell you amazing my attitude is right now.
When I first say you had re-posted to this thread, I was glad to see it. Then, when I read the first line I thought well that was funny and of good nature, hope things went well. Then, the ending came around and once again it is filled with disappointment.

If I were you Myles, I would call it quits on the T500 and get your money back. I would then talk to Diesel Site about your concerns and see how you feel about their HPOP. If you are not happy with what they are telling you, get an OEM HPOP and just be done with it.

Keep us updated Myles, and we are all very thankful for Jim and what he has done to help you and us out over the time he has been here.
Reply With Quote
  #208  
Old 09-05-2017, 10:16 AM
SaintITC SaintITC is offline
Elder User
 
Join Date: Jul 2003
Location: Springfield, PA
Posts: 908
SaintITC has a very good reputation on FTE.SaintITC has a very good reputation on FTE.SaintITC has a very good reputation on FTE.
I was surprised as well. It seems fairly obvious that you are now quite familiar and experienced installing an HPOP, so why does a used OEM one work and not the T500? There are some differences between the two, but are those differences what's causing the issue? For example, an HPO crossover pipe generally aids a stock system, yet I understand it's redundant with a T500. I just wonder if there's something different about your truck that prevents a T500 from working? Has it been the same physical pump every time, or have they sent you other T500's?
Reply With Quote
  #209  
Old 09-05-2017, 01:15 PM
Bonanza35 Bonanza35 is offline
Post Fiend
 
Join Date: Sep 2005
Location: Norco,CA
Posts: 7,020
Bonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to beholdBonanza35 is a splendid one to behold
I'd call it quits for sure. Buy another brand. They must keep sending the same pump back to you and have no idea why it's not working.
Reply With Quote
  #210  
Old 09-05-2017, 09:26 PM
jhl3's Avatar
jhl3 jhl3 is offline
Posting Guru
 
Join Date: Sep 2014
Location: Asheville-where weird is
Posts: 2,281
jhl3 is a splendid one to beholdjhl3 is a splendid one to beholdjhl3 is a splendid one to beholdjhl3 is a splendid one to beholdjhl3 is a splendid one to beholdjhl3 is a splendid one to beholdjhl3 is a splendid one to behold
The offer for another set of eyes to look at this and hands to turn wrenches is still open.

Give me a call if you want.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
P1273 Code - Ran all the normal tests 6_Myles 1999 - 2003 7.3L Power Stroke Diesel 16 09-28-2017 08:59 AM
ICP slow to 500 on cranking Icicle 1999 - 2003 7.3L Power Stroke Diesel 6 02-20-2016 01:37 AM
Fuel Sending Unit - Random Thought 6_Myles Excursion - King of SUVs 1 02-16-2016 09:56 PM
Injector and HPOP Combo deals? 6_Myles 1999 - 2003 7.3L Power Stroke Diesel 1 02-10-2016 05:28 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.