91 runs and dies - Ford Truck Enthusiasts Forums



1978 - 1996 Big Bronco  
Sponsored by:
Sponsored by:

91 runs and dies

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-31-2017, 04:22 PM
Tnhill Tnhill is offline
New User
Thread Starter
 
Join Date: Mar 2016
Posts: 3
Tnhill is starting off with a positive reputation.
91 runs and dies

I have a 91 with a 302 injected. It runs fine going down the road but at an idle it might run for a half hour then die or it might die right away. Sometimes it dies when i put it in gear. I can put some gas in it and put it in gear and its fine. It used to fire right back up till last night it died and i had to let it sit over night then it fired right up. I changed inline fuel filter and scraped the distributor cap. But it died again on me for the 3rd time today. The first time it fired ack up right after the the second it took ab hour And now im dead in a parking lot. I was thinking fuel pump. My bro says its an idle problem. I does run a low idle and when cold and randomly will jump between 500 and 1300rpm...any thoughts?
Reply With Quote
  #2  
Old 01-31-2017, 05:26 PM
Tnhill Tnhill is offline
New User
Thread Starter
 
Join Date: Mar 2016
Posts: 3
Tnhill is starting off with a positive reputation.
Threw a o2 sensor code so i replaced that...now im dead at the parts store
Reply With Quote
  #3  
Old 01-31-2017, 06:59 PM
rla2005's Avatar
rla2005 rla2005 is offline
Post Fiend
 
Join Date: Oct 2005
Location: Illinois
Posts: 12,648
rla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud ofrla2005 has much to be proud of
Quote:
Originally Posted by Tnhill View Post
Threw a o2 sensor code so i replaced that...now im dead at the parts store
Rent a fuel pressure gauge and spark tester. Verify what is dropping out. No sense throwing parts at the problem. Diagnose it.

You may have to purchase the spark tester. Alternative is to pull a spark plug, ground the electrode, then crank. Requires a helper or a jumper lead to crank the starter from under the hood.

BTW...that O2 sensor code is a sign of another issue. Not a no start condition.
Reply With Quote
  #4  
Old 02-01-2017, 05:42 PM
Bubba Jones's Avatar
Bubba Jones Bubba Jones is offline
Posting Guru
 
Join Date: Dec 2006
Location: Fort McDowell, AZ
Posts: 1,440
Bubba Jones has a good reputation on FTE.Bubba Jones has a good reputation on FTE.Bubba Jones has a good reputation on FTE.
Yeah testing fuel pressure is definitely something you'll want to do to try and check that off the list.

Your problem sounds similar to when my pickup coil was failing and finally totally failed however. That is something inside the distributor so it's easier just to replace the entire distributor if that sensor is bad. When that starts to go, it messed up the signal to send spark to the plugs so you won't get spark. It can happen intermittently, then all of a sudden fail completely. You'll want to do some testing though before throwing parts at is like rla2005 said.

Other things to check would be idle air control valve, throttle position sensor, checking for vacuum (probably some vacuum leaks are present if you've never checked that). I would definitely start by testing fuel pressure though.

If by chance you do happen to need a new distributor, don't get one from O'Reilly's DON'T DO IT!

I've had two fail on my Bronco, one on my Camaro, and one of my friend's camaro all from O'Reilly's (and I'm going to throw in that Autozone and other generic parts stores are the same.) I'd recommend wither Napa or try and get an OEM or high quality one online if you do end up needing to replace it. The cheap parts store parts are just that, cheap....
Reply With Quote
  #5  
Old 02-08-2017, 11:02 PM
Ghiaguy Ghiaguy is offline
New User
 
Join Date: Feb 2017
Posts: 2
Ghiaguy is starting off with a positive reputation.
91 bronco 302, startd but no idle...

I left my bronco stored at Lake Havasu City last year in April an it ran fine no issues...
I got bak in October an it refused to start. Drained 2 gals gas from it, replaced fuel pump, filter, an regulao
tor an have 80 lbs pressure at fuel rail. Still wont idle.
ckd all vacuum line like on carb system but all good. Replaced all sensors ss OBD 1 system was faulty an neva worked wen ford began using it.
Ckd voltage at dist an injectors an dist was good but erratic at injecrtors...
next step is ecu. If this dont work im open to suggestions....

​​​​​​​Ghiaguy

Quote:
Originally Posted by Bubba Jones View Post
Yeah testing fuel pressure is definitely something you'll want to do to try and check that off the list.

Your problem sounds similar to when my pickup coil was failing and finally totally failed however. That is something inside the distributor so it's easier just to replace the entire distributor if that sensor is bad. When that starts to go, it messed up the signal to send spark to the plugs so you won't get spark. It can happen intermittently, then all of a sudden fail completely. You'll want to do some testing though before throwing parts at is like rla2005 said.

Other things to check would be idle air control valve, throttle position sensor, checking for vacuum (probably some vacuum leaks are present if you've never checked that). I would definitely start by testing fuel pressure though.

If by chance you do happen to need a new distributor, don't get one from O'Reilly's DON'T DO IT!

I've had two fail on my Bronco, one on my Camaro, and one of my friend's camaro all from O'Reilly's (and I'm going to throw in that Autozone and other generic parts stores are the same.) I'd recommend wither Napa or try and get an OEM or high quality one online if you do end up needing to replace it. The cheap parts store parts are just that, cheap....
Reply With Quote
  #6  
Old 02-09-2017, 02:28 PM
Ghiaguy Ghiaguy is offline
New User
 
Join Date: Feb 2017
Posts: 2
Ghiaguy is starting off with a positive reputation.
91 runs but wont idle

91 bronco 302, started but no idle...

I left my bronco stored at Lake Havasu City last year in April an it ran fine no issues...
I got bak in October an it refused to start. Drained the 2 gals gas from it, replaced fuelpump, filter, an regulator an have 80 lbs pressure at fuel rail. Still wont idle.
ckd all vacuum line like on carb system but all good.
Replaced all sensors , still no good
OBD1 system was faulty an neva worked wen ford began using it so no help there

Ckd voltage at dist an injectors an dist was good but erratic at injectors...
next step is ecu. If this dont work im open to suggestions....

​​​​​​​Ghiaguy


Quote:
Originally Posted by Tnhill View Post
I have a 91 with a 302 injected. It runs fine going down the road but at an idle it might run for a half hour then die or it might die right away. Sometimes it dies when i put it in gear. I can put some gas in it and put it in gear and its fine. It used to fire right back up till last night it died and i had to let it sit over night then it fired right up. I changed inline fuel filter and scraped the distributor cap. But it died again on me for the 3rd time today. The first time it fired ack up right after the the second it took ab hour And now im dead in a parking lot. I was thinking fuel pump. My bro says its an idle problem. I does run a low idle and when cold and randomly will jump between 500 and 1300rpm...any thoughts?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 5.4 f250 will start then dies! Brandon1153 1999 to 2016 Super Duty 6 05-07-2015 06:41 AM
7.3 Randomly dies, only at idle. Brody Olson 1999 - 2003 7.3L Power Stroke Diesel 2 01-06-2015 08:04 PM
More cold and it does it again. Shelbynut 6.0L Power Stroke Diesel 28 01-01-2014 07:12 PM
Dies when shifted into gear AZRRC 1973 - 1979 F-100 & Larger F-Series Trucks 5 11-06-2013 01:23 AM
Engine Rebuild gone awry JTHill24 Aerostar 17 02-02-2004 11:08 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:56 AM.