07 Navigator liftgate only opens with remote - Ford Truck Enthusiasts Forums

Go Back  Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Reload this Page >

07 Navigator liftgate only opens with remote

Notices
2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

07 Navigator liftgate only opens with remote

Reply

 
 
 
  #1  
Old 10-13-2016, 11:06 PM
Navigator777's Avatar
Navigator777
Navigator777 is offline
Freshman User
Thread Starter
Join Date: Nov 2008
Location: Ashland, WI
Posts: 33
Navigator777 is starting off with a positive reputation.
07 Navigator liftgate only opens with remote

07 Navigator liftgate only opens with remote not with rear handle or button.
Any ideas?
 
Reply With Quote
  #2  
Old 10-16-2016, 07:56 PM
PLCguy
PLCguy is offline
Freshman User
Join Date: Oct 2016
Posts: 28
PLCguy is starting off with a positive reputation.
I have a similar issue on my 2011 Navi L. I turned off the power liftgate using the MFD on the dash (my garage isn't big enough to open liftgate and I was worried my family would damage the liftgate opening it. After I did that, the rear handle makes a noise, but does not release the latch. My remote opens the liftgate with power but rear handle is essentially useless (doesn't open power or allow it manually)

Have you checked if the Power Liftgate ON/OFF setting on your multi function dash display. I don't know how you turn on or off for the 2007 model.
 
Reply With Quote
  #3  
Old 10-16-2016, 11:51 PM
Navigator777's Avatar
Navigator777
Navigator777 is offline
Freshman User
Thread Starter
Join Date: Nov 2008
Location: Ashland, WI
Posts: 33
Navigator777 is starting off with a positive reputation.
Originally Posted by PLCguy View Post
I have a similar issue on my 2011 Navi L. I turned off the power liftgate using the MFD on the dash (my garage isn't big enough to open liftgate and I was worried my family would damage the liftgate opening it. After I did that, the rear handle makes a noise, but does not release the latch. My remote opens the liftgate with power but rear handle is essentially useless (doesn't open power or allow it manually)

Have you checked if the Power Liftgate ON/OFF setting on your multi function dash display. I don't know how you turn on or off for the 2007 model.
That's exactly what this one is doing. Yes I checked it and its set to ON.
 
Reply With Quote
  #4  
Old 10-17-2016, 08:35 AM
PLCguy
PLCguy is offline
Freshman User
Join Date: Oct 2016
Posts: 28
PLCguy is starting off with a positive reputation.
So mine is OFF, yours in ON, and they both do the same thing?

Now I know something is definitely wrong.
 
Reply With Quote
  #5  
Old 10-20-2016, 07:54 PM
PLCguy
PLCguy is offline
Freshman User
Join Date: Oct 2016
Posts: 28
PLCguy is starting off with a positive reputation.
Well Navigator777, looks like no one is going to help us, so we'll have to help each other. When you pull the rear latch, do you hear any noises in the liftgate, like it's trying to open. If not, it could be the latch button itself is broken.

I've seen reports of the actuator cable for the liftgate release breaking, but if it works with the remote, then the cable must be ok.
 
Reply With Quote
  #6  
Old 10-28-2016, 10:47 PM
Navigator777's Avatar
Navigator777
Navigator777 is offline
Freshman User
Thread Starter
Join Date: Nov 2008
Location: Ashland, WI
Posts: 33
Navigator777 is starting off with a positive reputation.
Originally Posted by PLCguy View Post
Well Navigator777, looks like no one is going to help us, so we'll have to help each other. When you pull the rear latch, do you hear any noises in the liftgate, like it's trying to open. If not, it could be the latch button itself is broken.

I've seen reports of the actuator cable for the liftgate release breaking, but if it works with the remote, then the cable must be ok.
I was actually posting for my dad, I sold my Navigator a few years back. Dad lives 300 miles away so it was talking to him on the phone. It finally ended up he did have it turned off, after your post matched his description exactly I had him go in and set it to what ever it wasn't, figuring he was reading it wrong, hes not too tech savvy.
And sure enough he changed it and now it all working again.

I recently had to find him a replacement air suspension pump and I think the guy that installed it for him somehow turned it off.

Thanks for the help, hes a 78 year old happy camper not that he doesn't have to pay for a fix
 
Reply With Quote
  #7  
Old 10-30-2016, 12:04 PM
PLCguy
PLCguy is offline
Freshman User
Join Date: Oct 2016
Posts: 28
PLCguy is starting off with a positive reputation.
Good. Glad you got it figured out.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MackGuy
1997-2006 Expedition & Navigator
3
03-05-2018 04:37 PM
aspenly
2007 - 2014 Expedition & Navigator
1
03-30-2017 10:51 AM
salazar44
1997-2006 Expedition & Navigator
2
01-02-2017 02:48 PM
bbells2009
1997-2006 Expedition & Navigator
49
10-11-2016 02:20 PM
the-pred
1997-2006 Expedition & Navigator
2
08-17-2016 05:57 PM


Thread Tools
Search this Thread
Quick Reply: 07 Navigator liftgate only opens with remote


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: