2012 new to me truck is giving issues already - Ford Truck Enthusiasts Forums



2009 - 2014 F150 Discuss the 2009, 2010, 2011, 2012, 2013 and 2014 Ford F150
Sponsored by:
Sponsored by:

2012 new to me truck is giving issues already

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-07-2016, 03:08 PM
fordf350man's Avatar
fordf350man fordf350man is offline
Senior User
Thread Starter
 
Join Date: May 2015
Location: Dallas, TX
Posts: 469
fordf350man is starting off with a positive reputation.
2012 new to me truck is giving issues already

Hey guys. I just bought a 2012 f150 with the 5.0 (pic in my profile pic). Remote started it this morning to warm it up since its cold down here today. When I walked out steam was coming from the front of the grille. Killed the engine immediately popped the hood and engine looked clean looked under the truck and different story. There was antifreeze all over the driveway so I called the warranty company I got when I purchased the truck. 3 hours later tow truck finally arrives. He starts it up to move into position to get it on and the motor is shaking but no knocking or ticking noise or anything it was only on 20-25 seconds while he backed it up and then wanted me to feel it. It was definitely dumping fuel to get warmed up as RPMs were high but it definitely had a shake to it that was abnormal.

So first thing. No I did not check the oil level (yes I am a dummy). I did look in the antifreeze overflow plastic tank and it was empty. I was thinking the steam was a pinhole in the radiator so when the truck got up to pressure it started steaming through it since no antifreeze on the engine and steam was coming out of the grille where the rad sits.

The shake has me concerned though. Do you think a truck would shake like that on start-up with low coolant levels? Truck never overheated as I killed it once I saw the steam. It's at the dealership now getting looked at.
Reply With Quote
  #2  
Old 01-08-2016, 11:23 AM
FordService's Avatar
FordService FordService is offline
Official Ford Rep
 
Join Date: Oct 2010
Posts: 3,124
FordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud of
Quote:
Originally Posted by fordf350man View Post
...The shake has me concerned though. Do you think a truck would shake like that on start-up with low coolant levels? Truck never overheated as I killed it once I saw the steam. It's at the dealership now getting looked at.
Hi fordf350man,

I wanted to touch base and see if you've heard anything from the dealership. How many miles are on your rig? I'd like to do what I can to assist.

Crystal
Reply With Quote
  #3  
Old 01-08-2016, 11:32 AM
fordf350man's Avatar
fordf350man fordf350man is offline
Senior User
Thread Starter
 
Join Date: May 2015
Location: Dallas, TX
Posts: 469
fordf350man is starting off with a positive reputation.
Hi Crystal,

I usually hang around the 87-96 section so good to see that a ford representative is on the forums! Truck has 36K so if its anything power-train its still under manu warranty. I also purchased a 3rd party warranty that the cadallic dealership I bought it from sells so I will not be out of pocket a dime just out of pocket from my truck!

I heard back this AM. The dealership I bought it from is being smart and sending the truck to the local ford dealership this morning. Oil was fine, coolant definitely was way low. So hoping its just something with the cooling system and nothing with the block. By the symptoms I still would not be surprised if they told me a pinhole on the front of the rad. I won't know more until North Central calls Crest (where I bought the truck) and lets them know what is going on. So I am in limbo until then. At least its back at ford so I know only motorcraft parts will go on!

Thanks for checking in!

David
Reply With Quote
  #4  
Old 01-08-2016, 11:57 AM
FordService's Avatar
FordService FordService is offline
Official Ford Rep
 
Join Date: Oct 2010
Posts: 3,124
FordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud ofFordService has much to be proud of
Quote:
Originally Posted by fordf350man View Post
Hi Crystal,

I usually hang around the 87-96 section so good to see that a ford representative is on the forums! Truck has 36K so if its anything power-train its still under manu warranty. I also purchased a 3rd party warranty that the cadallic dealership I bought it from sells so I will not be out of pocket a dime just out of pocket from my truck!

I heard back this AM. The dealership I bought it from is being smart and sending the truck to the local ford dealership this morning. Oil was fine, coolant definitely was way low. So hoping its just something with the cooling system and nothing with the block. By the symptoms I still would not be surprised if they told me a pinhole on the front of the rad. I won't know more until North Central calls Crest (where I bought the truck) and lets them know what is going on. So I am in limbo until then. At least its back at ford so I know only motorcraft parts will go on!

Thanks for checking in!

David
You're quite welcome, David! Let me know what you find out from the Ford Dealership. If you continue to work with them, I'll be able to step in and assist (if needed).

Crystal
Reply With Quote
  #5  
Old 01-08-2016, 11:59 AM
fordf350man's Avatar
fordf350man fordf350man is offline
Senior User
Thread Starter
 
Join Date: May 2015
Location: Dallas, TX
Posts: 469
fordf350man is starting off with a positive reputation.
Your a sweetheart! I will let you know!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Steam and excessive water on start up Brian0075 EcoBoost (all engine sizes) 0 08-04-2017 07:59 PM
Water pump SAlexander Modular V10 (6.8l) 3 07-05-2017 05:53 PM
Steam and a miss! fivo2fst4u 1999 - 2003 7.3L Power Stroke Diesel 7 05-19-2016 03:11 AM
Steam coming from exhaust gdiehl 6.7L Power Stroke Diesel 10 01-29-2016 02:02 PM
Producing steam! Joe/GA 6.7L Power Stroke Diesel 26 11-04-2015 05:22 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 11:36 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: