Notices
Pre-Power Stroke Diesel (7.3L IDI & 6.9L) Diesel Topics Only

Relay keeps clicking after start but not before

 
  #1  
Old 01-02-2016, 12:00 PM
Realslowww
Realslowww is offline
Elder User
Thread Starter
Join Date: May 2010
Posts: 993
Realslowww is starting off with a positive reputation.
Relay keeps clicking after start but not before

Only sometimes and truck was hard to start this morning, used a slight wiff of ether


Thanks
 
  #2  
Old 01-02-2016, 01:06 PM
speedwrench72's Avatar
speedwrench72
speedwrench72 is offline
Posting Guru
Join Date: Dec 2012
Location: western washington
Posts: 1,065
speedwrench72 is starting off with a positive reputation.
the glow controller is clicking after the WTS light go's out is normal!!!! if you immediately turn key all the way off then back to on it resets the glow system, it will heat until hot then maintain with clicking the controller see's the temperature of the glows by the resistance value of the glow plugs them selves' as long as you have the correct glows installed. they must be feed back type... when starting a very cold engine full throttle is used.. the glows will click after starting to keep them hot. if it dies after a few seconds restart.. this to is normal as cold air will chill the cylinders... I drive 33 miles to work with two stop lites 55 mph my van is hard to warm the inside so I freeze half the way to work so I use the block heater this makes a huge difference in warm up time and I don't need to wait for glows just jump in and crank it, fires up immediately this when 20* out is real nice...the other day I didn't plug it in and had to wait for glows..still started but you could tell it was cold and stiff with thick oil...and the over drive wouldn't kick in till half way to work,,tranny has a sensor must be 70* internal temp before OD will work even with thermostatic controlled cooler so no down side to keeping it pluged in at work I park it whare my work truck is parked and plug it in there to the cord I use on the fuel truck.. I am spoiled....
 
  #3  
Old 01-02-2016, 02:10 PM
Realslowww
Realslowww is offline
Elder User
Thread Starter
Join Date: May 2010
Posts: 993
Realslowww is starting off with a positive reputation.
IT was around 40 or 50, is that cold enough for it to keep clicking and hold the peddle to the floor ? thanks for the info.
 
  #4  
Old 01-02-2016, 03:05 PM
Macrobb's Avatar
Macrobb
Macrobb is offline
Postmaster
Join Date: Dec 2011
Posts: 3,818
Macrobb is gaining momentum as a positive member of FTE.Macrobb is gaining momentum as a positive member of FTE.
Originally Posted by Realslowww View Post
IT was around 40 or 50, is that cold enough for it to keep clicking
Unless the engine is /hot/(100+F), the glow plug system should activate.
When you first turn on the key, you should hear one 'click' as the glow plug relay activates. The dash lights will all dim when it's on. After 1-20 seconds, depending on temps, you will hear another click as it turns off. Dash lights will become brighter. After that, you will hear clicking on and off every second or so as it maintains the temps(dash lights will also dim and brighten as this happens).
The WTS light should go off at this point.

This is when you should try to start the engine. If it's really cold, you can try turning the key off for a couple of seconds, then back on to reset the process... but the first "on" time will be a lot shorter, due to the GPs being already warm.
Originally Posted by Realslowww View Post
and hold the peddle to the floor ?
This depends on your IP and timing. Ford says you're supposed to have it halfway to the floor when warm, fully when cold. My engine won't start if it's more than 1/8 of the way down. It needs the extra advance to fire off... But it's also got an 'all-out' R&D pump.
A stock pump, well, it depends. Try it both ways and see what works the best for you.
The other two IDIs in my family start just fine with it only depressed a little, for what it's worth. They also have used, somewhat worn stock IPs.
 
  #5  
Old 01-03-2016, 05:04 PM
Realslowww
Realslowww is offline
Elder User
Thread Starter
Join Date: May 2010
Posts: 993
Realslowww is starting off with a positive reputation.
Thanksjjjllll
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kmjone00
Testing.....
14
09-19-2016 10:30 PM
vinceadragna
1968-2013 Full Size Vans
2
01-19-2016 04:45 PM
Ken N Tx
3.8 & 4.2L V6
4
01-07-2016 04:33 AM
Whitey Ford
1994.5 - 1997 7.3L Power Stroke Diesel
19
12-02-2015 10:11 AM
Jera Lynn Hitlaw
General Automotive Discussion
1
11-27-2015 11:12 PM


Thread Tools
Search this Thread
Quick Reply: Relay keeps clicking after start but not before


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.